unable to update to 6.3