Иногда не запускается AdGuard

Discussion in 'Техническая поддержка (AdGuard для Windows)' started by bar0n, Mar 4, 2012.

  1. Insulin

    Insulin New Member

    Joined:
    Jul 11, 2011
    Messages:
    32
    Проблема решена! Спасибо за оперативную помощь!
     
  2. Максим Жихарев

    Максим Жихарев New Member

    Joined:
    Oct 29, 2012
    Messages:
    5
    Вопрос 1. Я убрал галочку из программы и добавил ярлык в папку "Автозагрузка". Программа запускается развёрнутой. Как заставить её запускаться свёрнутой?
    Вопрос 2. Если убрать ярлык из папки "Автозагрузка" и поставить галочку в программе, она не запускается с системой вообще. В чём может быть причина? Как решить проблему?
    Система Windows 7 x64 SP1.

    Достаточно решение 2-го вопроса. Если же решения нет, то я буду признателен, если получу ответ на 1-й.
     
  3. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,144
    Причина может быть в том, что у программы выставлено свойства - запускать от имени администратора.
    Это самая частая проблема, если снять галку, то все должно быть в порядке.

    Насчет того, что запускается развернутой - скажите, вы какой ярлык перетащили? Точно без дополнительных параметров запуска?
     
  4. Slipknot

    Slipknot New Member

    Joined:
    Nov 1, 2012
    Messages:
    1
    Да бывает пару раз в месяц тоже не запускается Win 7 SP1 x64
     
  5. Максим Жихарев

    Максим Жихарев New Member

    Joined:
    Oct 29, 2012
    Messages:
    5
    В справке программы я не нашёл никаких параметров запуска, поэтому вписать их в ярлык тоже не мог. Есть ли параметр, принудительно запускающий программу свёрнутой? И почему всё-таки программа не запускается сама, когда галочка стоит?
     
  6. vvgNovanet

    vvgNovanet Moderator Moderator

    Joined:
    Nov 9, 2010
    Messages:
    4,654
    Сейчас всяко пробовал.
    Наоборот я её развернутой запустить не могу.
    У вас точно она не запущена. Может просто значка в трее нет. ( такое случается )
    В диспетчере задач процесс не присутствует ?

    Adguard запускается в развёрнутом виде только тогда когда его запускают 2 раза.
    т.е если его полностью вырубить, то после первого запуска он запускается в свёрнутом виде, а если его не вырубать а снова запустить то он просто открывает своё окно.

    Это проверили ?
    [​IMG]
     
    Last edited by a moderator: Nov 1, 2012
  7. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,144
    И еще одна штука для диагностики -- посмотрите пожалуйста в лог самой Windows:

    Нам нужна запись из журнала событий Windows, чтобы понять в чем проблема.

    Вот примерная инструкция, как её получить:

    1. Нажмите Пуск
    2. В строке поиска введите eventvwr (как показано на этом скриншоте: http://i.imgur.com/lQdhK.png)
    3. Будет найдена одна программа, запустите ее
    4. Открывшееся окно будет выглядеть вот так: http://i.imgur.com/90IWr.png
    5. Откройте журнал "Приложение" (слева вверху, выделен на скриншоте красной рамкой)
    6. Найдите в журнале ошибки, совпадающие по времени с запуском Adguard. Скорее всего источником ошибки будет .NET Runtime
     
  8. ozaki2000

    ozaki2000 Beta Tester

    Joined:
    Sep 30, 2012
    Messages:
    39
    Как бы там ни было, я стал всегда убирать галочку "автозапуск" в программе, а также в программе Revo 1.83 (ну привык я к ней, и бесплатна к тому же). Иначе замечал, Виндовс может не загрузиться, и ОСь здесь не при чём, Линукс выручал хоть... Как бы там не было, убрал из автозапуска, а как в инет выходить - вручную запускаю, и проблем никаких нет, а это главное.
     
  9. LEXA

    LEXA New Member

    Joined:
    Dec 28, 2012
    Messages:
    2
    Не то что не запускается...
    Поставил на комп знакомой (ХР, машина древняя, 6 лет назад покупала), в процессах прога висит, в трее значка нет. (((
    Несколько раз двойной клик на значке на рабочем столе результата не дал - окно программы не появилось.

    Шо делать?
     
  10. alexzem88

    alexzem88 Beta Tester

    Joined:
    Jan 8, 2011
    Messages:
    3
    Сегодня включив комп. обнаружил что Adguard не запустился как обычно при старте Windows7 sp1,помогла переустановка с чисткой реестра.
     
  11. grogt

    grogt New Member

    Joined:
    Jan 4, 2013
    Messages:
    1
    У меня тоже такая проблема,иногда помогает перезагрузка 2-3 раза,иногда переустановка версия программы 4.2.2.0 обновить не могу,систама вин 7 про
     
  12. Andrey_Ra

    Andrey_Ra New Member

    Joined:
    Apr 22, 2013
    Messages:
    3
    CLR20r3

    Свежеустановленный ноутбук с Windows 8. Поставил AdGuard, все работало. В какой-то момент перестала запускаться. При этом в журнале Приложений Windows фиксируется ошибка:
    Контейнер ошибки -703931183, тип 5
    Имя события: CLR20r3
    Отклик: Нет данных
    Идентификатор CAB: 0

    Сигнатура проблемы:
    P1: adguard.exe
    P2: 5.5.590.3465
    P3: 510ce6e6
    P4: mscorlib
    P5: 4.0.30319.18033
    P6: 50b5a536
    P7: 6274
    P8: 1c
    P9: System.InvalidOperationException
    P10:


    Сейчас делаю как советуют тут: https://forum.adguard.com/showthread.php?374-Р*елиз-версии-5-1&p=5736#post5736

    (у меня действительно был один пустой тэг "<DbProviderFactories/>").

    Теперь я переустанавливают AdGuard и поэтому у меня тут будет перезагрузка. Если больше ничего не напишу - значит помогло :).

    Не помогло. Сижу дальше с ошибкой CLR20r3
     
    Last edited: Apr 22, 2013
  13. Andrey_Ra

    Andrey_Ra New Member

    Joined:
    Apr 22, 2013
    Messages:
    3
    Ага, нашел решение:
    1. Запустил "gpedit.msc".
    2. Открыл ветку "Конфигурация компьютера"->"Конфигурация Windows"->"Параметры безопасности"->"Локальные политики"->"Параметры безопасности".
    3. Поменял значение параметра "Системная криптография: использовать FIPS-совместимые алгоритмы для шифрования, хэширования и подписывания" с "Включен" на "Отключен.
    4. Выполнил команду "gpupdate /force"
    5. Стартовал AdGuard (без ошибок).

    fips_bad.png
    fips_change.png
    fips_good.png
     
  14. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,144
    Круто, спасибо за то, что нашли решение!

    А что вас навело на такое решение?
     
  15. Confessor

    Confessor Administrator Administrator

    Joined:
    Jan 30, 2012
    Messages:
    354
    System.InvalidOperationException в System.Security.Cryptography.RijndaelManaged..ctor() если не ошибаюсь :)
    Rijndael не совместим с FIPS.

    Добавлю тогда решение для ОС у которых доступ к политике безопасности ограничен:
    - необходимо изменить значение реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\fipsalgorithmpolicy
    Enabled со значения 1 на 0.
     
  16. Крабс

    Крабс New Member

    Joined:
    May 6, 2013
    Messages:
    44
    Ситуация такая.
    Сегодня установил браузер IE10 вместо IE9.После этого перестал работать работать Adguard версия 5.6.
    Удалил его полностью через панель управления,потом ещё руками зачистил папки.Скачал с сайта уже версию 5.7,установил,ключ активации был уже введён.
    Но не запускается.Выдает ошибку "Невозможно подключение".
    Лог:
    Сигнатура проблемы:
    Имя события проблемы: CLR20r3
    Сигнатура проблемы 01: adguard.exe
    Сигнатура проблемы 02: 5.7.978.5041
    Сигнатура проблемы 03: 52276938
    Сигнатура проблемы 04: System.Runtime.Serialization
    Сигнатура проблемы 05: 4.0.0.0
    Сигнатура проблемы 06: 4ba1f437
    Сигнатура проблемы 07: 10fd
    Сигнатура проблемы 08: 73
    Сигнатура проблемы 09: UGLLJEKU33DFTS0DJYVUMOGWUG0QVCQJ
    Версия ОС: 6.1.7601.2.1.0.768.2
    Код языка: 1049
    Дополнительные сведения 1: 0a9e
    Дополнительные сведения 2: 0a9e372d3b4ad19135b953a78882e789
    Дополнительные сведения 3: 0a9e
    Дополнительные сведения 4: 0a9e372d3b4ad19135b953a78882e789

    Ознакомьтесь с заявлением о конфиденциальности в Интернете:
    http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0419

    Если заявление о конфиденциальности в Интернете недоступно, ознакомьтесь с его локальным вариантом:
    C:\Windows\system32\ru-RU\erofflps.txt

    В панели задач иконка появляется,но тут же исчезает,с рабочего стола программа не запускается.
    Но самое смешное,что Адгуард на самом деле запущен: на страницах присутствует иконка помощника и он работает!Но на мои действия программа не реагирует никак.
    Win 7 x64,программа в исключениях брандмауэра.
    Прилагаю все скриншоты.
    [​IMG]
    [​IMG]
     
  17. Крабс

    Крабс New Member

    Joined:
    May 6, 2013
    Messages:
    44
    Господа Разработчики!
    Ну так что делать с моей проблемой,не сочтите за труд дать хоть какой-нибудь ответ.
    Ситуация более чем странная: Адгуард работает,помощник на страницах есть,реклама фильтруется более-менее успешно.Но мне недоступны никакие действия с Адгуардом,даже открыть его не могу.
    Парадокс.
    Если где-то уже был такой вопрос/ответ,пожалуйста,ткните носом,сам найти не смог.
    Жду ответа.
     
  18. toby_43

    toby_43 Beta Tester

    Joined:
    Apr 23, 2011
    Messages:
    1,418
    попробуйте проделать следующее и сообщите помогло нет, мне лично помогло
     
  19. Крабс

    Крабс New Member

    Joined:
    May 6, 2013
    Messages:
    44
    toby_43
    Это я уже прочитал и сделал,прежде чем написать второй пост.
    Ничего не изменилось абсолютно.
    Насчет обновления баз ничего не могу сказать,поскольку я даже не могу посмотреть,обновляются они,или нет.
    Тупик какой-то.Может,кто ещё чего подскажет?
    Сейчас ещё потыкаюсь,потом переустановлю программу,если не поможет - в топку.Другого решения не вижу.Надоели бесконечные глюки на ровном месте.
     
  20. toby_43

    toby_43 Beta Tester

    Joined:
    Apr 23, 2011
    Messages:
    1,418
    Проблема не ординарная надо ждать администрацию, в топку снести тоже не вариант, так как расширения для браузеров многое не блокируют