Некорректная работа расширения на сайте tradingview.com

helk

New Member
Имеется Opera 35.0.2066.92 (ДА, древняя, но так надо, обновлять нельзя) и сайт tradingview.com На сайте имеется окно графиков по технологии HTML5.
При установленном расширении Adguard Антибанер 2.5.11 не выводится собственно сами графики, оболочка сайта отображается. Отключение adguard не помогает. Решается только удалением плагина из браузера. Графики отображаются даже без перезагрузки браузера, надо только обновить страницу по F5.
И наоборот, при установке расширения Adguard Антибанер графики продолжают отображаться при утановленном и включенном плагине, но только до обновления страницы по F5.
В браузере Chrome 49.0.2623.75 сайт tradingview.com отображается корректно.
При использовании других блокировщиков рекламы AdBlockPlus , Ghostery всё работает корректно.
Настройки плагина по умолчанию.
Вопрос: можно ли настроить отображение графиков и, если да, то как?
 

vasily_bagirov

Administrator
Staff member
Administrator
@helk повторить не получилось.

В предыдущих версиях расширения подобная проблема наблюдалась?
 

helk

New Member
Предыдущими не тестил, поскольку этот глюк обнаружил месяца два назад и долго не мог найти причину.
Пожалуй, это единственный баг, замеченный мною в плагине. Но критичный, т.к. надо пользоваться сайтом, а простое отключение расширения проблему не убирает.
Собственно, на сайте tradingview.com блокировать рекламу мне не надо, но есть другие вкладки и на других сайтах очень надо блокировать )
Окно сайта при глюке выглядит вот так (см. скрин)

Забыл указать, что у меня Windows XP x64

upd: если установить плагин adguard в Оперу и СРАЗУ его отключить, то графики отображаются нормально даже после обновления страницы. А если установить - включить (включён по умолчанию) и обновить страницу - то не отображает до полного удаления из браузера.
 

Attachments

Last edited:

vasily_bagirov

Administrator
Staff member
Administrator
@helk откройте проблемную страницу, перейдите в инструменты разработчика и откройте там вкладку "Консоль", затем сделайте скриншот и выложите его здесь. Может быть из этого удастся что-то понять.
 

helk

New Member
Значит так. Adguard расширение было установлено в Opera, но не включалось. Сайт работал нормально.
Затем через вкладку opera://extensions/ был включён Adguard Антибанер Версия 2.5.11 Все настройки по умолчанию. Браузер не перезагружался.
Вкладка (окно) сайта https://www.tradingview.com/chart/a4wxm1wo/ обновилась по F5. Область графиков висит в постоянном обновлении.

Другие элементы страницы работают.

Однако, в браузере Chrome версии 49.0.2623.75m тот же сайт с установленным Adguard Антибанер Версия 2.5.11 отображается корректно! Хоть и присутствуют ошибки
 

Attachments

Top