Некорректное удаление версии 5.1

Discussion in 'Контроль качества бета-версий' started by Talisman, Jan 30, 2012.

  1. Talisman

    Talisman Beta Tester

    Joined:
    Dec 18, 2010
    Messages:
    1,022
    Возникла такая ситуация. Перед установкой 5.2 я решил полностью удалить доктора вэба, ди и Adguard тоже решил снести. Но случился такой казус. Начался процесс деинсталляции нормально, но последи процесса получилось вот что:

    [​IMG] [​IMG] [​IMG] [​IMG]

    Процесс деинсталяции висит на этом и дальше двигаться, без участия пользователя не собирается. После того, как вручную удалить из процессов Adguard, всё, вроде бы, доходит до конца, но не выскакивает сообщение об деинсталяции, не просит перезагрузку, просто исчезает окно с процессом деинсталляции.

    Повторил попытку два раза - результат один. Перед деинсталяцией сам Adguard не закрывал, но, думаю, многие бы пользователи не закрыли. Значек Adguard из трея пропадает, как будто программа закрылась автоматически. Поэтому прошу рассмотреть данную ситуацию.
     
  2. Talisman

    Talisman Beta Tester

    Joined:
    Dec 18, 2010
    Messages:
    1,022
    После закрытия Adguard перед деинсталяцией, чего и следовало ожидать, всё прошло штатно. Похоже деинсталятор не может корректно завершить работу программы во время процесса.
     
  3. Confessor

    Confessor Administrator Staff Member Administrator

    Joined:
    Jan 30, 2012
    Messages:
    351
    Да, Вы правы, проблема действительно в том что деинсталлятор не может корректно закрыть запущенное приложение. Для корректного удаления через "Установку/удаление программ" Adguard лучше закрыть вручную. Либо при появлении диалоговое окно вида:
    [​IMG]
    выбрать пункт "Не закрывать..." и нажать "Ок".

    Последующие версии программы проблему содержать не будут.
     
  4. Talisman

    Talisman Beta Tester

    Joined:
    Dec 18, 2010
    Messages:
    1,022
    Отлично! Спасибо!