Ошибка подключения!

giga0503

New Member
:mad: 12.05.2014 09:20 Включаю ноутбук запускаю Adguard а мне показывает что Связь со службой отсутствует. Нажмите кнопку ПОДКЛЮЧИТСЯ для восстановления работы программы. Сейчас мое время 11:40 все это время я пытался подключится и уже два раза перезагружал ноутбук и все-равно напрасно!!!
 

Confessor

Administrator
Administrator
Здравствуйте.

Сама по себе данная проблема не нормально, а если не помогла кнопка "Подключиться" с первого раза, то проблема как минимум довольно необычна.
Чтоб разобраться в ее причинах нам нужен логи программы и системы, инструкцию для их получения я отправляю вам личным сообщением.
 

Quasar

New Member
Сбой.jpg

Здравствуйте!
У меня точно такая же проблема... Уже третий день не могу понять в чём дело. Купил лицензию и никак не могу войти в программу.
Помогите!
 
Last edited by a moderator:

WSK

Beta Tester

Здравствуйте!
У меня точно такая же проблема... Уже третий день не могу понять в чём дело. Купил лицензию и никак не могу войти в программу.
Помогите!
Было у меня пару раз тоже самое. Останавливаем службу Adguard Service


Удаляем файл dbase.s3db (слетят все настройки и собственные правила)


Запускаем службу Adguard Service
 
Last edited by a moderator:

Quasar

New Member
Службы.jpg

Службы УЖЕ были отключены...

ProgramData.jpg

И в папке ничего не было...
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
Подождите, служба была отключена? В этом то и проблема.

Вообще такое чаще всего бывает если у вас нарушена установка Microsoft .NET Framework.
Попробуйте переустановить его (скачайте по этой ссылке):
http://go.microsoft.com/?linkid=9831986

Очень часто помогает это решение.

Насчет лицензии, как только мы решим вашу проблему, напишите пожалуйста мне в личку на форуме.
Постараемся вам компенсировать потерю времени.
 

vvgNovanet

Moderator
Moderator
Блин, почему нужно по 100 раз писать одно и тоже.
Quasar, вверх глаза поднять лень ?
 

avatar

Administrator
Staff member
Administrator
Блин, почему нужно по 100 раз писать одно и тоже.
Quasar, вверх глаза поднять лень ?
Это нормально когда приходишь на форум с поисковой выдачи например, а не читаешь с самого начала.
Всю тему прочитать не всегда успеваешь.

Ну и опять же, не все пользователи знают (да и вообще не должны знать) что такое .NET Framework.
С этим зоопарком разного софта на Windows можно абсолютно любую проблему получить:(.

Мы в шестой версии хотим соскочить с нынешнего способа обмена сообщениями между службой и UI.
Уж больно много этих проблем с ошибкой подключения. Сделаем свой велосипед, дольше, но надежнее.
 
Last edited by a moderator:

Gumbo

к̅̿̑͌̂͒̉ͯ̈́̇͆
Это нормально когда приходишь на форум с поисковой выдачи например, а не читаешь с самого начала.
Всю тему прочитать не всегда успеваешь.

Ну и опять же, не все пользователи знают (да и вообще не должны знать) что такое .NET Framework.
С этим зоопарком разного софта на Windows можно абсолютно любую проблему получить:(.

Мы в шестой версии хотим соскочить с нынешнего способа обмена сообщениями между службой и UI.
Уж больно много этих проблем с ошибкой подключения. Сделаем свой велосипед, дольше, но надежнее.
Свой .net но с бэк-джеком и шлю..ми?)
 

avatar

Administrator
Staff member
Administrator
Свой .net но с бэк-джеком и шлю..ми?)
Не, почему-то очень часто в .NET бывает поврежден компонент, который мы используем (ServiceBase, ServiceModel).
Я не знаю почему это происходит, но вот такова жизнь. Будем избавляться от использования этого компонента.
 

Quasar

New Member
NET.JPG

Да при чём здесь поднять глаза не поднять, видел я там сообщение про Net, тоже не помогает!
 

avatar

Administrator
Staff member
Administrator

avatar

Administrator
Staff member
Administrator
Поймал, посмотрел логи:
Code:
Не удалось загрузить файл или сборку "System.Transactions.dll" либо одну из их зависимостей. Не найден указанный модуль.
Ну как есть, у вас поломан .NET Framework. Не хватает одной из его системных библиотек.

Мы на всякий случай выложили утилиту для удаления .NET на static.adguard.com.

Что нужно делать:
1. Загрузите утилиту Cleanup Tool по ссылке ниже:
http://static.adguard.com/cleanup_tool.exe

2. Запустите ее и, следуя инструкциям мастера, выберите версию .NET и нажмите кнопку Cleanup now.
Вам нужно проделать это для всех .NET от версии 4.5.1 до 2.0 (вообще все что найдется).

3. Перезагрузите компьютер

4. Установите Miscrosoft .NET Framework по ссылке:
http://www.microsoft.com/ru-RU/download/details.aspx?id=42643
 

Quasar

New Member
СПАСИБО ОГРОМНОЕ! ВСЁ НАКОНЕЦ-ТО ПОЛУЧИЛОСЬ И ТЕПЕРЬ МОГУ ИСПОЛЬЗОВАТЬ СВОЮ ЛИЦЕНЗИЮ! ВСЁ ТАКИ ДА, ПРОБЛЕМА БЫЛА В .NET Framework... ЕЩЁ РАЗ БОЛЬШОЕ СПАСИБО ЗА ПОМОЩЬ!
 

russia68

New Member
Здравствуйте.
такая же проблема, проделал все вышеуказанное - сдвигов нет
 

avatar

Administrator
Staff member
Administrator
Здравствуйте.
такая же проблема, проделал все вышеуказанное - сдвигов нет
Здравствуйте!

Пришлите пожалуйста логи Adguard, посмотрим в чем дело.

Можете нам на devteam@adguard.com прислать логи Windows и Adguard (все что есть)?

Вот как их получить:

Наши логи:
https://kb.adguard.com/index.php?/Ru...zhurnl-adguard

Windows:
https://kb.adguard.com/index.php?/Ru...zhurnl-windows
 

avatar

Administrator
Staff member
Administrator
Логи поймал.

Ошибка:
Code:
database disk image is malformed
Похоже повреждена база данных Adguard.
Удалите вручную директорию %programdata%\Adguard и запустите службу Adguard.
 

russia68

New Member
Логи поймал.

Ошибка:
Code:
database disk image is malformed
Похоже повреждена база данных Adguard.
Удалите вручную директорию %programdata%\Adguard и запустите службу Adguard.
Все заработало
Большое спасибо
 
Top