Ошибка подключения!

Discussion in 'Техническая поддержка (Adguard для Windows)' started by giga0503, May 12, 2014.

  1. giga0503

    giga0503 New Member

    Joined:
    May 12, 2014
    Messages:
    1
    :mad: 12.05.2014 09:20 Включаю ноутбук запускаю Adguard а мне показывает что Связь со службой отсутствует. Нажмите кнопку ПОДКЛЮЧИТСЯ для восстановления работы программы. Сейчас мое время 11:40 все это время я пытался подключится и уже два раза перезагружал ноутбук и все-равно напрасно!!!
     
  2. Confessor

    Confessor Administrator Staff Member Administrator

    Joined:
    Jan 30, 2012
    Messages:
    353
    Здравствуйте.

    Сама по себе данная проблема не нормально, а если не помогла кнопка "Подключиться" с первого раза, то проблема как минимум довольно необычна.
    Чтоб разобраться в ее причинах нам нужен логи программы и системы, инструкцию для их получения я отправляю вам личным сообщением.
     
  3. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,791
    Традиционно такая проблема бывает вызвана некорректным состоянием .NET Framework.

    Попробуйте переустановить его:
    http://go.microsoft.com/?linkid=9831986
     
  4. Quasar

    Quasar New Member

    Joined:
    May 31, 2014
    Messages:
    5
    Сбой.jpg

    Здравствуйте!
    У меня точно такая же проблема... Уже третий день не могу понять в чём дело. Купил лицензию и никак не могу войти в программу.
    Помогите!
     
    Last edited by a moderator: Jun 1, 2014
  5. WSK

    WSK Beta Tester

    Joined:
    Mar 18, 2012
    Messages:
    447
    Было у меня пару раз тоже самое. Останавливаем службу Adguard Service


    Удаляем файл dbase.s3db (слетят все настройки и собственные правила)


    Запускаем службу Adguard Service
     
    Last edited by a moderator: Jun 1, 2014
  6. Quasar

    Quasar New Member

    Joined:
    May 31, 2014
    Messages:
    5
    Службы.jpg

    Службы УЖЕ были отключены...

    ProgramData.jpg

    И в папке ничего не было...
     
    Last edited by a moderator: Jun 1, 2014
  7. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,791
    Подождите, служба была отключена? В этом то и проблема.

    Вообще такое чаще всего бывает если у вас нарушена установка Microsoft .NET Framework.
    Попробуйте переустановить его (скачайте по этой ссылке):
    http://go.microsoft.com/?linkid=9831986

    Очень часто помогает это решение.

    Насчет лицензии, как только мы решим вашу проблему, напишите пожалуйста мне в личку на форуме.
    Постараемся вам компенсировать потерю времени.
     
  8. vvgNovanet

    vvgNovanet Moderator Moderator

    Joined:
    Nov 9, 2010
    Messages:
    4,553
    Блин, почему нужно по 100 раз писать одно и тоже.
    Quasar, вверх глаза поднять лень ?
     
  9. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,791
    Это нормально когда приходишь на форум с поисковой выдачи например, а не читаешь с самого начала.
    Всю тему прочитать не всегда успеваешь.

    Ну и опять же, не все пользователи знают (да и вообще не должны знать) что такое .NET Framework.
    С этим зоопарком разного софта на Windows можно абсолютно любую проблему получить:(.

    Мы в шестой версии хотим соскочить с нынешнего способа обмена сообщениями между службой и UI.
    Уж больно много этих проблем с ошибкой подключения. Сделаем свой велосипед, дольше, но надежнее.
     
    Last edited by a moderator: Jun 2, 2014
  10. Gumbo

    Gumbo к̅̿̑͌̂͒̉ͯ̈́̇͆

    Joined:
    Aug 26, 2011
    Messages:
    809
    Свой .net но с бэк-джеком и шлю..ми?)
     
  11. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,791
    Не, почему-то очень часто в .NET бывает поврежден компонент, который мы используем (ServiceBase, ServiceModel).
    Я не знаю почему это происходит, но вот такова жизнь. Будем избавляться от использования этого компонента.
     
  12. Quasar

    Quasar New Member

    Joined:
    May 31, 2014
    Messages:
    5
    NET.JPG

    Да при чём здесь поднять глаза не поднять, видел я там сообщение про Net, тоже не помогает!
     
  13. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,791
  14. Quasar

    Quasar New Member

    Joined:
    May 31, 2014
    Messages:
    5
    Отправил.
     
  15. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,791
    Поймал, посмотрел логи:
    Code:
    Не удалось загрузить файл или сборку "System.Transactions.dll" либо одну из их зависимостей. Не найден указанный модуль.
    
    Ну как есть, у вас поломан .NET Framework. Не хватает одной из его системных библиотек.

    Мы на всякий случай выложили утилиту для удаления .NET на static.adguard.com.

    Что нужно делать:
    1. Загрузите утилиту Cleanup Tool по ссылке ниже:
    http://static.adguard.com/cleanup_tool.exe

    2. Запустите ее и, следуя инструкциям мастера, выберите версию .NET и нажмите кнопку Cleanup now.
    Вам нужно проделать это для всех .NET от версии 4.5.1 до 2.0 (вообще все что найдется).

    3. Перезагрузите компьютер

    4. Установите Miscrosoft .NET Framework по ссылке:
    http://www.microsoft.com/ru-RU/download/details.aspx?id=42643
     
  16. Quasar

    Quasar New Member

    Joined:
    May 31, 2014
    Messages:
    5
    СПАСИБО ОГРОМНОЕ! ВСЁ НАКОНЕЦ-ТО ПОЛУЧИЛОСЬ И ТЕПЕРЬ МОГУ ИСПОЛЬЗОВАТЬ СВОЮ ЛИЦЕНЗИЮ! ВСЁ ТАКИ ДА, ПРОБЛЕМА БЫЛА В .NET Framework... ЕЩЁ РАЗ БОЛЬШОЕ СПАСИБО ЗА ПОМОЩЬ!
     
  17. russia68

    russia68 New Member

    Joined:
    Jul 7, 2014
    Messages:
    2
    Здравствуйте.
    такая же проблема, проделал все вышеуказанное - сдвигов нет
     
  18. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,791
    Здравствуйте!

    Пришлите пожалуйста логи Adguard, посмотрим в чем дело.

     
  19. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,791
    Логи поймал.

    Ошибка:
    Code:
    database disk image is malformed
    
    Похоже повреждена база данных Adguard.
    Удалите вручную директорию %programdata%\Adguard и запустите службу Adguard.
     
  20. russia68

    russia68 New Member

    Joined:
    Jul 7, 2014
    Messages:
    2
    Все заработало
    Большое спасибо