При включенной защите в некоторых приложениях нет доступа к сети

ratox

New Member
Нет доступа к сети у Orbot и Dr.Tariff при включенной защите в режиме локального http прокси. В режиме локального VPN через Orbot не работает фильтрация трафика. Сайты смотреть можно, но с рекламой. У доктора тарифа вообще нет доступа к сети в любом режиме. Такие проблемы скорее всего есть и в других подобных программах. Будет ли это исправлено и возможно что нибудь сделать на версии 1.0.671?
 

avatar

Administrator
Staff member
Administrator
Спасибо, что сообщили!

Скорее всего мы сможем это поправить в следующем релизе.
 

titton

New Member
Через некоторое время исправной работы версии 1.0.671 ни с того, ни с сего перестали загружаться страницы интернета при подключении к 3G. В любом браузере. По WiFi все нормально. Установил версию 1.1.805 - проблема не исчезла...
 

avatar

Administrator
Staff member
Administrator
Через некоторое время исправной работы версии 1.0.671 ни с того, ни с сего перестали загружаться страницы интернета при подключении к 3G. В любом браузере. По WiFi все нормально. Установил версию 1.1.805 - проблема не исчезла...
Нужно больше данных.

Можете, пожалуйста, проделать следующее:
1. Переключить "Уровень логгирования" на "Записывать все" в расширенных настройках Adguard.
2. Повторите проблему.
3. Переключите уровень логгирования обратно на обычный.
4. Отправьте нам сообщение из программы (пункт меню "Сообщение в поддержку").

В сообщении напишите, что оно адресована лично мне.
 

avatar

Administrator
Staff member
Administrator
avatar, сделал. Заодно уточнил в сообщении кое что.
А можете заодно ticket ID написать здесь?
Я в отпуске сейчас, так что могу тормозить сильно с ответами, прошу прощения.
 

avatar

Administrator
Staff member
Administrator
Что такое ticket ID? Типа номер моей заявки?
Ага, на почту должен был прийти (ту что указывали когда в поддержку из программы писали).
 

titton

New Member
SQG-723-52671

Впрочем со мной уже пообщались (это были не вы?). Процитирую переписку здесь

- Сообщение для avatar с форума. На форуме я не совсем точно описал проблему. При включении передачи данных в телефоне программа включается (выходит из паузы). Но вот при попытке загрузить страницу:1)значок сети показывает 3G, хотя до этого было hspa. 2) страница не загружается 3) программа встает на паузу

- Очень похоже на то, что есть проблема с самой прошивкой.
То есть VPN не очень хорошо работает с ней.
Можно проверить, поставить какую-нибудь другую программу, которая использует VpnService API как и мы, и посмотреть, есть ли с ней такие проблемы.
Например, поставить NoRoot Firewall или webguard.


- Поставил webguard. Все работает нормально. По крайней мере на первый взгляд, а там уж посмотрим.

- Это очень хорошо, значит есть косяк в нашем коде и его можно исправить.
Завел дефект, будем внимательно читать ваш лог и править.



Добавлю еще, что проблема возникла кажется, когда обновил прошивку до 4.4.4
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
Это я был, все ок значит:)
Подождите пока праздники закончатся, будем исправлять.
 

Rom

New Member
Пользуюсь adguard для Windows - очень доволен программой. Фильтрует не намного лучше adblock, но позволяет очень удобно вручную блокировать рекламу на сайтах.
Попробовал установить Adguard для Android - вырубает сеть во всей приложениях. Что бы это значило и как с этим бороться? Версия Android 4.4.4
 
Last edited by a moderator:

vasily_bagirov

Administrator
Staff member
Administrator
Пользуюсь adguard для Windows - очень доволен программой. Фильтрует не намного лучше adblock, но позволяет очень удобно вручную блокировать рекламу на сайтах.
Попробовал установить Adguard для Android - вырубает сеть во всей приложениях. Что бы это значило и как с этим бороться? Версия Android 4.4.4
Опишите пожалуйста подробнее, пользуетесь через VPN или прокси?
Можете проделать следующее:
1. Переключите "Уровень логгирования" на "Записывать все" в расширенных настройках Adguard.
2. Повторите проблему.
3. Переключите уровень логгирования обратно на обычный.
4. Отправьте нам сообщение из программы (пункт меню "Сообщение в поддержку").
5. В этой теме напишите номер созданного в техподдержке тикета, чтобы мы могли найти и посмотреть отосланный вами файл.
 

Rom

New Member
Опишите пожалуйста подробнее, пользуетесь через VPN или прокси?
Можете проделать следующее:
1. Переключите "Уровень логгирования" на "Записывать все" в расширенных настройках Adguard.
2. Повторите проблему.
3. Переключите уровень логгирования обратно на обычный.
4. Отправьте нам сообщение из программы (пункт меню "Сообщение в поддержку").
5. В этой теме напишите номер созданного в техподдержке тикета, чтобы мы могли найти и посмотреть отосланный вами файл.
Через VPN как просит программа. Сообщение отправил Номер заявки: HTR-530-62825 ; Тема: [Adguard for Android] Дефект
 

avatar

Administrator
Staff member
Administrator
[/spoiler]
Через VPN как просит программа. Сообщение отправил Номер заявки: HTR-530-62825 ; Тема: [Adguard for Android] Дефект
Судя по логу у нашего приложения нет доступа в сети.

Скажите, а это 3G или Wi-Fi?
Если 3G, то включена ли у вас опция "Ограничить передачу данных в фоновом режиме"?
 

Rom

New Member
Пробовал и Wi-Fi и 3G выход в сеть вырубает напрочь при включенной защите adguard. Даже сообщение из программы не мог отправить.
 

Coool

New Member
да тоже заметил при включенном адгварде иногда вайфай становится серым и сетку не видит...
 

avatar

Administrator
Staff member
Administrator
А какая точно версия прошивки? Рутованная или не рутованная?
 

Rom

New Member
Версия Android 4.4.4
Версия прошивки G530HXXU1ANJ1
Версия ядра 3.10.28-199988
Номер сборки KTU84P.G530HXXU1ANJ1
Не рутированная, телефон новый.
 

avatar

Administrator
Staff member
Administrator
Спасибо за информацию!

В качестве временного решения можно использовать режим прокси.

Без рута для 3G настраивается вот так:
http://4pda.ru/forum/index.php?showtopic=601691&st=720#entry36285831

Для Wi-Fi инструкция по настройке в разделе "Помощь" в самом приложении.
 

Rom

New Member
Настроил прокси, по очереди для Wi-Fi и 3G, в обоих случаях та же история. Хром выдаёт : " Веб-страница недоступна". Выключаю adguard - пишет: " не удается подключиться к прокси серверу" так что прокси и порты прописал, думаю, правильно.
 
Top