Проблема IPv6/Teredo в utorrent

sheep

New Member
После установки adguard слетает teredo. ошибка в диспетчере устройств. Снимок.jpg
пользуюсь так как опсосы блокируют порты торрента.
Можно что нить сделать?
 
Last edited:

sayrus

Member
teredo не пользуюсь, но картина такая же, только вот не засекал после чего. Система второй день после переустановки.
 

avatar

Administrator
Staff member
Administrator
В сетевых настройках Adguard переключитесь на TDI-драйвер и включите teredo.
 

avatar

Administrator
Staff member
Administrator
Ну да, если галка "Использовать WFP драйвер" выключена, используется TDI-драйвер.
 

sayrus

Member
Как видите, TDI и был включен. Странно... Пусть автор топика дальше борется, а мы подождем результата :)
 

avatar

Administrator
Staff member
Administrator
Как видите, TDI и был включен. Странно... Пусть автор топика дальше борется, а мы подождем результата :)
Видимо когда-то был WFP включен, и тогда тередо отключило.
 

kvm

New Member
Точно такая же проблема. Купил, установил, получил восклицательный знак в диспетчере устройств teredo tunneling pseudo-interface. Именно после вашей программы разработчики.
Есть решение этой проблемы или нет?
 

sheep

New Member
нету. на английском форуме вроде затрагивали момент с проблемой teredo. ставте браузерную бесплатную, а эту другу подарите.
win 7 64 HP.
на 32б проблем вроде н ебыло, но это раньше. сейчас не вкурсе.
 
Last edited:

sayrus

Member
Я недавно на двух компах переустанавливал ситему. Сразу после установки Adguard вылазит ошибка teredo, после этого топика просто обратил на это внимание.
 

avatar

Administrator
Staff member
Administrator
Ну почему нету. Если драйвер используется TDI, то мы точно Teredo не трогаем.

То есть последовательность действий такая:
1. В сетевых настройках отключаете галку "Использовать WPF драйвер"
2. Включаете Teredo вручную:
Code:
netsh interface teredo set state enabled
Вроде все, будет работать.

@kvm, а зачем вам Teredo если не секрет?
 

sheep

New Member
То есть последовательность действий такая:
1. В сетевых настройках отключаете галку "Использовать WPF драйвер"
По умолчанию выключена.
3.JPG
2. Включаете Teredo вручную:
Code:
netsh interface teredo set state enabled
4.JPG
после установки программы:
1.JPG
После перезагрузки пк:
2.JPG
Пробовал и с включенным WPF,таже фигня. Teredo не работает. активная кнопка в юторренте всегда. не включается Teredo:
5.JPG

НЕТУ РЕШЕНИЯ
 
Last edited:

avatar

Administrator
Staff member
Administrator
С командой ошибся. Вот так надо:
Code:
netsh interface teredo set state default
 

sheep

New Member
нафиг эти экспереременты. непомогает нефига. с командой все ок но Teredo не работает и не включается.
даже после как снес программу.
опять винду с бекапа возврощать.
 

Ligre

Member
Такая же ситуация. Однако она была у меня и до использования Adguard.
А вы не используете для интернета мобильную связь? 3G/4G -модем или роутер
 

sheep

New Member
Такая же ситуация. Однако она была у меня и до использования Adguard.
А вы не используете для интернета мобильную связь? 3G/4G -модем или роутер
и модем и роутер с юсб портом для подключения свистка. вид подключения не относится к teredo.
пробовал устанавливать на чистую систему юторрент все работает отлично. как только устанавливаю adguard то ipv6/teredo слетает и фиг включишь.
 
Last edited:

Ajvar

New Member
Ну почему нету. Если драйвер используется TDI, то мы точно Teredo не трогаем.
Как бы не так.
Простите, конечно, за мой здоровый скептицизм, но после анализа происходящего я уверен, что это не так.


У меня появились 2 BSOD за неделю, причина одного была в драйвере Ethernet, чего никогда еще в жизни не было до этого. Зашел в Сетевые Адаптеры и увидел какой-то Tunnel Toredo и Знак Восклицания с кодом ошибки 10. Самого Tunnel я тоже никогда ранее не видел, а торрентом пользовался. Подозрения подтвердились тем, что когда ошибку исправляю, сам Tunnel исчезает из Диспетчера устройств.
После анализа зарегистрировался, чтобы создать тему здесь, а она уже есть.

Для того, чтобы Ошибки с Кодом 10 на Туннеле Toredo не возникали, нужно зайти в ветку реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters и поменять значение параметра "DisabledComponents" на "0" (Windows Default). Или просто использовать Microsoft Fixit 50440 (там же вся инфа о значениях).
Спасибо уважаемому point027 за помощь... во всем поиске причин и анализе.

После того, как я меняю значение с 8e на 0 - все становится на место. Однако при последующей перезагрузке Adguard опять меняет реестр, что приводит к тем ошибкам в Диспетчере устройств, а возможно и к BSOD, из-за которых я и начал искать причину и пришел к Tunnel Toredo.

ДОБАВЛЕНО:
Прикол в том, что хоть служба и локальная, я пока так и не смог запретить ей менять то значение, хоть и выставлял разрешения лишь на чтение разделу parameters ВСЕМ кроме Администратора. Как заблокировать доступ на изменение того значения Вашему сервису?
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
Прикол в том, что хоть служба и локальная, я пока так и не смог запретить ей менять то значение, хоть и выставлял разрешения лишь на чтение разделу parameters ВСЕМ кроме Администратора. Как заблокировать доступ на изменение того значения Вашему сервису?
Вообще никак. Давайте мы код проверим. Если teredo отключается при использовании TDI-драйвера, это наш косяк, и это надо исправлять.

Удивительно, что BSOD лезет из-за выключенного Teredo. В подавляющем большинстве случаев как раз включенный Teredo источник таких косяков.

Кстати проще всего побороть BSOD просто отключив teredo в utorrent:
Настройки - дополнительно
net.dissable_incoming_ipv6 меняем false на true
bt.transp_disposition меняем на 5
 

Ajvar

New Member
Вообще никак. Давайте мы код проверим. Если teredo отключается при использовании TDI-драйвера, это наш косяк, и это надо исправлять.

Удивительно, что BSOD лезет из-за выключенного Teredo. В подавляющем большинстве случаев как раз включенный Teredo источник таких косяков.

Кстати проще всего побороть BSOD просто отключив teredo в utorrent:
Я не знаю из-за чего были бсоды, но система недавно из 100% рабочего бэкапа, после которого раньше год почти работал, так что либо хардовая проблема, либо недавно используемая программа. А ничего нового кроме Адгуард.

Торедо не может запуститься с кодом 10. Если изменить значение реестра и перезапустить устройство в Диспетчере, то потом ошибки нет, даже если запустить службу.
Проверю поможет ли отложенный запуск службы... хотя нет. Оно может и поможет, но только если при каждом выключении ПК запускать обратно смену того аттрибута в реестре. Длинный костыль выходит.

Не факт, что адгуард на прямую мешает туннелю, а просто значение того реестра мешает запуститься.

В торренте изменил, но если бсоды из-за этого, то скорее нужно весь ip6 в системе вырубить.
 
Last edited by a moderator:
Top