Программа не хочет работать через прокси(

TORREN

New Member
Здравствуйте, столкнулся с проблемой следующего плана: на работе есть веб сервер, выступающий в качестве прокси, на котором стоит User Gate. Мой комп подключен к этому вебсерверу и при запуске AdGuard выдает "Нет сети". В IE настройки прокси включены, инет работает нормально, без сбоев. в чем может быть проблема? Может правило какое в User Gate добавить надо для вашей программы?
P.S. Версия последняя (4.1.8)
 

avatar

Administrator
Staff member
Administrator
Здравствуйте, столкнулся с проблемой следующего плана: на работе есть веб сервер, выступающий в качестве прокси, на котором стоит User Gate. Мой комп подключен к этому вебсерверу и при запуске AdGuard выдает "Нет сети". В IE настройки прокси включены, инет работает нормально, без сбоев. в чем может быть проблема? Может правило какое в User Gate добавить надо для вашей программы?
P.S. Версия последняя (4.1.8)
Можете запустить Adguard в режиме отладки и прислать нам получившийся лог?

Принцип примерно такой:
1. Удаляете файл agent.log из папки программы
2. Запускаете ее в режиме отладки (есть иконка в меню пуск для этого)
3. Повторяется ошибка с "Нет связи", присылаете нам файл agent.log для разбора.

Вопрос еще насчет настроек прокси в IE. Как именно выглядят настройки прокси? В каких там полях что прописано?
 

avatar

Administrator
Staff member
Administrator
Высылаю, жду ответа!
Кхмхм, ошибку вижу, а вот почему она вылезла - пока не вижу.

Нужна еще информация.

Что нужно сделать:

1. Пуск - Выполнить - "cmd"
2. Вводите команду ipconfig /all > C:\ipconfig.txt
3. Жмете "Enter"

Файл C:\ipconfig.txt нужен для анализа.
 

avatar

Administrator
Staff member
Administrator
Выкладываю конфиг
Вообщем разобрался. Сразу к выводам - судя по всему в ближайшее время починить эту проблему не получится, есть технические ограничения.

Проблема такая -- у вас для доступа в интернет используется только прокси сервер, и нет доступа ни к какому DNS-серверу. DNS нужен чтобы понимать, какому доменному имени сайта какой IP-адрес соответствует. Браузеру для доступа к сайтам это не нужно, а вот нам нужно (ограничения, накладываемой библиотекой, которую мы используем для запросов к страницам).

В будущем мы, возможно, перейдем на использование своей собственной библиотеки для доступа по HTTP. Но на это нужно время.


-----
Попиарю пока новую разработку. У вас же на работе UserGate используется. Есть у него такой конкурент - Traffic Inspector.
Мы вместе с ними выпускаем в ближайшее время плагин Adguard для Traffic Inspector. Так что если убедите своих перейти на TI, не нужно будет на свою машину ничего устанавливать.
 
Last edited by a moderator:

TORREN

New Member
Жаль, конечно... Ну чтож, будем ждать тогда.
P.S. На TI переходить организация не собирается, т.к. только недавно потратились Юзергейт
 

avatar

Administrator
Staff member
Administrator
Жаль, конечно... Ну чтож, будем ждать тогда.
P.S. На TI переходить организация не собирается, т.к. только недавно потратились Юзергейт
Ну вообще если ваш админ сможет настроить локальный DNS-сервер, то проблема решится. Только вот я не знаю, насколько это правильно для вашей конкретной сети.
 

FlaerSteap

New Member
Есть проблема, Adguard установился нормально, но при включении горит красным и пишет нет связи, работаю в конторе где стоит прокси сервер в настройках IE все прописано, адрес,порт.
 

avatar

Administrator
Staff member
Administrator
Есть проблема, Adguard установился нормально, но при включении горит красным и пишет нет связи, работаю в конторе где стоит прокси сервер в настройках IE все прописано, адрес,порт.
А авторизация есть на этом прокси?
 

CKV

Beta Tester
AdGuard и прокси

Скачал AdGuard 4.2.2.0 и установил на домашний комп и на рабочий.
Дома всё прекрасно работает, проблема на работе - компьютер в домене и доступ в интернет сделан через прокси-сервер, требующий авторизацию.

AdGuard при запуске пишет "Нет связи", окно программы красное, и висит, не запуская защиту.

Запустил отладочный режим, вот кусок лога (agent.log):
Code:
WARNING:, AdBlock.Agent, 4, 31.08.2011 9:11:10, Cannot connect to the server: System.Net.WebException: Удаленный сервер возвратил ошибку: (407) Требуется проверка подлинности посредника.
   в System.Net.HttpWebRequest.GetResponse()
   в AdBlock.Commons.Rest.RestClient.Execute[T](String uri, String method, String format, Object[] parameters)
   в AdBlock.Commons.Rest.RestClient.Post[T](String uri, String format, Object[] parameters)
   в AdBlock.Domain.Client.ServiceClient.SendStatus(String applicationId, String appVersion, String serverVersion, String applicationKey, String affiliateId, String couponId, Int32 blocked)
   в AdBlock.Domain.Service.ApplicationService.LMZ8eHqR56Wk1RrsE0c(Object , Object , Object , Object , Object , Object , Object , Int32 blocked)
   в AdBlock.Domain.Service.ApplicationService.GetLicenseStatus()
   в AdBlock.Agent.AgentForm.1co5q6qEE3HcSRaWplJ(Object )
   в AdBlock.Agent.AgentForm.Ajd0Eb3SZv(Object , DoWorkEventArgs )
Видимо, проблема с авторизацией на прокси. Подскажите, как решить данную проблему? Заранее спасибо!
 

avatar

Administrator
Staff member
Administrator
Видимо, проблема с авторизацией на прокси. Подскажите, как решить данную проблему? Заранее спасибо!
Пока что никак. Если хотите - попробуйте установить альфа-версию Adguard 5, там есть поддержка работы через прокси-сервер с авторизацией (напишите мне в ЛС, пришлю инструкцию как установить альфа-версию).
 

kindwolfman

New Member
Есть проблема, Adguard установился нормально, но при включении горит красным и пишет нет связи, работаю в конторе где стоит купить прокси сервер в настройках IE все прописано, адрес,порт.
Я так и не понял вы решили вашу проблему ?
 
Top