Сбрасываются пользовательские фильтры с $$

moraks

Beta Tester
Проявилась весьма неприятная проблема, мои HTML фильтры с правилом $$ удаляются, обычно после перезагрузки ПК, но не всегда...
У mail.ru, к примеру есть код, который сбрасывает все правила скрытия от ADG. (назывется "активатор")
Страница выглядит так:
rek_1.jpg
я вырезаю его правилом:
Code:
mail.ru$$script[tag-content="acronym"]
и страница выглядит так:
rek22.jpg
т.е. убираются лишние блоки, директ, подписки...
Но вот беда, мои правила с $$ постоянно исчезают.
 

avatar

Administrator
Staff member
Administrator
У mail.ru, к примеру есть код, который сбрасывает все правила скрытия от ADG. (назывется "активатор")
@Alex302 имеет нам смысл такое к себе добавить?

Но вот беда, мои правила с $$ постоянно исчезают.
Только они? Остальные остаются как есть?
Просто пользовательский фильтр используется, или кастомный фильтр из файла например?
 

moraks

Beta Tester
Да именно правила с $$ исчезают, я их сам набрал с клавиатуры в новой строке списка пользовательских фильтров.
Есть подозрение, что они сбрасываются из-за того, что я несколько раз переписываю правило, пока не найду уникальный селектор для фильтрации.
Пока разбавляю их простыми правилами с ## и вот такой вид держится:
12334.jpg
А если оставить более 2х фильтров с $$ подряд в конце списка, то они сбросятся...

*У mail.ru скрипты идут с пометкой в комментариях Time zone, и по-видимому различаются по регионам, потому добавлять их в общий фильтр бесполезно...
 
Last edited:

avatar

Administrator
Staff member
Administrator
Есть подозрение, что они сбрасываются из-за того, что я несколько раз переписываю правило, пока не найду уникальный селектор для фильтрации.
Да, есть там такой баг.
 
Top