[5.7 Alpha] Firefox + SSL = Connection is Untrusted

Discussion in 'Quality Control' started by Boo Berry, Jul 26, 2013.

  1. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,434
    As I figured, any issues with the 5.7 alpha would be because of the HTTPS filtering. Anyways I'm testing Adguard 5.7 alpha with Firefox 22 and on SSL sites I'm met with the following error;

    http://img690.imageshack.us/img690/969/aojo.jpg

    It seems Firefox doesn't like Adguard's SSL filtering method. I do understand that this is probably due to a Firefox setting (default settings, using clean profile) and I'm sure there's probably no workaround for it other than either turning the setting off for that error in Firefox... if there is one. Or maybe it just needs an issuer chain to be provided like the technical details say? Thought I'd report it just in case anyone else tried using Firefox with Adguard 5.7 alpha on SSL sites. :)

    You can easily reproduce this by going to any HTTPS site in Firefox, e.g. https://www.yahoo.com/
     
    Last edited by a moderator: Jul 26, 2013
  2. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    11,957
    Hm, we install our certificate into Firefox.

    Do you use portable version of Firefox or not?
     
  3. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,434
    Nope, using the installed version of Firefox 22 (US-En version) with a clean profile. I just cleaned the profile again and it's still doing it.
     
  4. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,434
    I figured it out. You have to disable filtering for Firefox, start a clean profile normally, then enable filtering for Firefox and start it up and HTTPS is working. So that means when you clean the profile manually or add an additional profile using the profile manager you have to start the browser with filtering off for it so when you enable filtering the certificate is installed correctly. If you start the browser after manually cleaning or using the profile manager to remove/add a new profile without disabling/re-enabling browser filtering, it'll error out on HTTPS.

    Perhaps Adguard can detect whether or not the certificate is installed correctly when you just clean the profile out (when you clean all files out of the profile folder).
     
    Last edited by a moderator: Jul 26, 2013
  5. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,434
    Did this again (without deleting/recreating profile) by just upgrading Firefox from 22 to 23 via the auto-update feature. Of course, disabling filtering then enabling filtering with the browser closed fixed it.
     
  6. Accel

    Accel Beta Tester

    Joined:
    Oct 8, 2012
    Messages:
    233
    same issue with this..
     
  7. rickyoh

    rickyoh Beta Tester

    Joined:
    Feb 3, 2012
    Messages:
    562
    also getting this behaviour after resetting firefox.
     
  8. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    11,957
    There was a bug in previous beta-version.

    The bug is now fixed, but your Firefox certificate storage could be broken because of the previous Adguard version.

    To fix delete all "Adguard CA" certificates from the Firefox storage (Settings - Advanced - Certificates - View Certificates)
    and restart Firefox.
     
  9. rickyoh

    rickyoh Beta Tester

    Joined:
    Feb 3, 2012
    Messages:
    562
    have reset firefox and verified that i do not have any "Adguard CA" certificates installed. still getting the connection untrusted error.
     
  10. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,434
    Turn the browser filtering off then back on with Firefox/Pale Moon/Waterfox/etc closed so it'll recreate them.
     
  11. rickyoh

    rickyoh Beta Tester

    Joined:
    Feb 3, 2012
    Messages:
    562
    @venom do you get this issue after resetting or reinstalling firefox ? also adding an exception adds the certificate as well.
     
  12. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,434
    Yes I do. Even after deleting all profile files then immediately starting Firefox without turning filtering off then back on for the browser.
     
  13. rickyoh

    rickyoh Beta Tester

    Joined:
    Feb 3, 2012
    Messages:
    562
    thank you for confirming this issue. hopefully it can be fixed.
     
  14. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    11,957
    It can be fixed but the priority is minor for now.
     
  15. Cary

    Cary Beta Tester

    Joined:
    Feb 6, 2014
    Messages:
    19
    Workaround:

    The issue is still present in 5.8.x, but I have found that if you untick the SSL filtering option, reboot, then tick the option again, the issue will be resolved. Another option is to use AdGuard as a proxy, and set up Firefox accordingly.
     
    Last edited: Feb 16, 2014
  16. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,434
    I manually import the certificate if I encounter this issue; e.g. clean Firefox profile.