6.2.357.1887 Windows - built-in updater not working

Discussion in 'Discussion (Beta Versions)' started by AnthonyB, Jun 7, 2017.

  1. AnthonyB

    AnthonyB Beta Tester

    Joined:
    Jun 22, 2014
    Messages:
    66
    I'm running 6.2.357.1887 beta on Windows 10 Build 16199 (insider Fast Ring).

    It has just detected that an update is available (6.2.369.1938), I click "Update" button and it downloads the new version and then does nothing.

    This same behaviour occurred on an earlier version of AG at one stage from memory.
     
  2. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,214
    It closes completely, right? Without restarting the app?

    I noticed this too when updating, it updates but it doesn't reopen the Adguard for Windows app. I found myself having to manually start the app from the Start Menu to get it back (which it prompts with the updated message).
     
  3. pegas

    pegas Beta Tester

    Joined:
    Apr 18, 2014
    Messages:
    263
    The same experience. Apart this hitch, all is working fine.
     
  4. Confessor

    Confessor Administrator Administrator

    Joined:
    Jan 30, 2012
    Messages:
    354
    I need your logs, guys :)
    Installer (instead of %tmp% look at %windir%\temp) and app.
     
  5. pegas

    pegas Beta Tester

    Joined:
    Apr 18, 2014
    Messages:
    263
    Sorry but as I regularly use CCleaner all temp files are gone from my system. :-(
     
  6. AnthonyB

    AnthonyB Beta Tester

    Joined:
    Jun 22, 2014
    Messages:
    66
    Sorry, I rebooted and then it seemed to update itself.
     
  7. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,144
    Guys, please save the logs if you face this issue when the new beta version is out :)