Accidentally Deleted One or Two Apps From the Filtered Apps List

Steppinwolf

New Member
Moving too quickly, I accidentally removed one, possibly two apps from the top of my Filtered apps list. Since the list is alphabetical and I don't think it was anything I added, I'm hoping someone could help by letting me know the top few default apps on your list. Here's what's at the top of my list now:

AdGuard filtered apps 2021-04-16 111018.jpg
 

m_makino

New Member
Maybe WWAHost and Microsoft Edge.
JSON:
        :
        :
        "FilteredApplications":[
            :
            :
            {
                "Name": "Microsoft Edge",
                "FileDescription": null,
                "ExecutableNames": [
                    "msedge.exe",
                    "msedge_proxy.exe"
                ],
                "AbsolutePath": null,
                "InstalledConditions": [
                    {
                        "Pattern": "%PROGRAMFILES%\\Microsoft\\Edge Beta\\Application",
                        "Type": 1
                    },
                    {
                        "Pattern": "%PROGRAMFILES(x86)%\\Microsoft\\Edge Beta\\Application",
                        "Type": 1
                    },
                    {
                        "Pattern": "%PROGRAMFILES%\\Microsoft\\Edge Dev\\Application",
                        "Type": 1
                    },
                    {
                        "Pattern": "%PROGRAMFILES(x86)%\\Microsoft\\Edge Dev\\Application",
                        "Type": 1
                    },
                    {
                        "Pattern": "%LOCALAPPDATA%\\Microsoft\\Edge SxS\\Application",
                        "Type": 1
                    },
                    {
                        "Pattern": "%PROGRAMFILES%\\Microsoft\\Edge\\Application",
                        "Type": 1
                    },
                    {
                        "Pattern": "%PROGRAMFILES(x86)%\\Microsoft\\Edge\\Application",
                        "Type": 1
                    }
                ],
                "ApplicationType": 0,
                "ProductName": null,
                "IsEnabled": true,
                "FilterHttps": true,
                "BlockNetworkAccess": false
            },
            :
            :
            {
                "Name": "Modern UI hosted apps",
                "FileDescription": null,
                "ExecutableNames": [
                    "WWAHost.exe"
                ],
                "AbsolutePath": null,
                "InstalledConditions": [
                    {
                        "Pattern": "%systemroot%\\System32\\WWAHost.exe",
                        "Type": 1
                    }
                ],
                "ApplicationType": 2,
                "ProductName": null,
                "IsEnabled": true,
                "FilterHttps": true,
                "BlockNetworkAccess": false
            },
            :
            :
However, "FilteredApplications" seems to include many apps (e.g. browsers such as Firefox, Opera...) as default settings.
You can't conclude that these were the apps that disappeared, as only the apps installed on your PC are displayed.

Therefore, I think the most reliable procedure for restoring the settings is as follows.
  1. Export the current settings
  2. Initialize the settings and export again
  3. Extract the exported settings archive, rewrite FilteredApplications in ./settings.json, and then import.
 

Steppinwolf

New Member
Thanks for the help. Yes, I can see now that this will not be a reliable way to determine what's missing. Edge and WWAHOST.exe still appear in my filtered list. The list appears to be alphabetical (at least when viewing in the app), so I believe the deleted executables have names that begin with the letter A, B or C (before Chrome). I wish I had backed up settings in the beginning. I'm not usually this careless.

I've worked with json files a bit in other apps, but most of what you're talking about here is over my head:
  1. I exported settings and got a .adg file type instead of json. I tried opening the file in VS Code hoping it would be json internally despite the file type, but it's apparently some kind of binary file, not json. How did you get json output?
  2. I need to read about initializing the settings. I'm guessing this will reset everything back to default.
  3. I'll have to find a reference for your third step.
Looks like I have some reading to do...
 
Top