AdG blocking none browser apps

Sportif

New Member
I play Wildstar (NCSoft).

Adgaurd blocks HTTP/HTTPs traffic from the game launcher. Even adding the launcher to the browser list and disabling filtering is failing t o bypass filter.

With ADG enabled
wadenable.png

With ADG disabled
 

Sportif

New Member
Thanks but that's a no go. AG still blocks the content in the launcher. It does effect WoW's launcher though.
I have added all of the Wildstar executables and set them to NOT filtered. That did not work either. -_- We need a exclusion option.

I am not using the WFP driver as I am on Win7 and have no need for it.
 

Nameless

Beta Tester
I'll be honest i dont know much about the application filtering, i just filter my browser and thats it.

The only other things i can suggest are:
Whitelist nc-soft if they are the creaters and ask them what ips the client uses so you can unblock them (if you explain why they should tell you) other than that, wait for a dev here to reply but he's on vacation at moment is the english speaking dev.
 

avatar

Administrator
Staff member
Administrator
Adguard does not filter none-browser applications.

Are you sure that this launcher does not somehow embeds browser?
Please look at the processes list when you launch the game.
What new processes do you see there?
 

Boo Berry

Moderator + Beta Tester
Moderator
Perhaps it's using an IE process or another browser process with the launcher? You could try enabling logging to try to find what rule(s) are blocking the request(s).
 

Sportif

New Member
Address: http://wildstar.patcher.ncsoft.com/6682/Launcher.exe.bin
Time: 5/18/2014 9:04:47 PM
Status: Request processed
Request details:

Bytes received: 361
Bytes sent: 141

Address: http://wildstar.patcher.ncsoft.com/version.txt
Time: 5/18/2014 9:04:54 PM
Status: Request processed
Request details:

Bytes received: 340
Bytes sent: 131

Address: http://www.wildstar-online.com/en/launcher/
Time: 5/18/2014 9:04:56 PM
Status: Error
Request details:

Error processing the request:
System.Net.ProtocolViolationException: Http base line violates protocol: 0

Source: Adguard.Http
Stack trace: at Adguard.Http.Protocol.HttpBaseStatusLine..ctor(Byte[] lineBytes)
at Adguard.Http.Protocol.HttpResponse.ParseStatusLine(Byte[] statusLine)
at Adguard.Http.Protocol.HttpBase.ParseStatusLine(Stream stream)
at Adguard.Http.Protocol.HttpBase..ctor(Stream stream)
at Adguard.Network.Filter.HttpFilter.GetResponse(RecordingStream remoteRecordingStream)
at Adguard.Network.Filter.HttpFilter.ProcessRequest(HttpRequest request, FilteringContext filteringContext, RecordingStream remoteRecordingStream)
at Adguard.Network.Filter.HttpFilter.ProcessConnection(RecordingStream localRecordingStream, RecordingStream remoteRecordingStream)
at Adguard.Network.Filter.HttpFilter.Filter()



Bytes received: 0
Bytes sent: 203

Address: http://wildstar.patcher.ncsoft.com/6682/Launcher.exe.bin
Time: 5/18/2014 9:04:56 PM
Status: Request processed
Request details:

Bytes received: 424
Bytes sent: 159

Address: http://www.wildstar-online.com/en/launcher
Time: 5/18/2014 9:04:56 PM
Status: An exception was activated
Request details:

The following rule exception was activated:
@@||wildstar-online.com$elemhide,content,urlblock,jsinject

Bytes received: 346
Bytes sent: 127
What's next?

I added the executable to the browser list and chose not to filter but that setting is being looked over.

So...
 

Nameless

Beta Tester
adding whildstar-online.com should work i have seen this code in past ($document) so try these two and remove what u already added.

@@||wildstar-online.com$document
@@||wildstar.patcher.ncsoft.com$document
 

Sportif

New Member
Made the change to the filter as suggested. Still not resolved.

Address: http://wildstar.patcher.ncsoft.com/version.txt
Time: 5/19/2014 7:43:35 AM
Status: An exception was activated
Request details:

The following rule exception was activated:
@@||wildstar.patcher.ncsoft.com$document

Bytes received: 340
Bytes sent: 131

Address: http://wildstar.patcher.ncsoft.com/6682/Launcher.exe.bin
Time: 5/19/2014 7:43:35 AM
Status: An exception was activated
Request details:

The following rule exception was activated:
@@||wildstar.patcher.ncsoft.com$document

Bytes received: 361
Bytes sent: 141

Address: http://wildstar.patcher.ncsoft.com/version.txt
Time: 5/19/2014 7:43:40 AM
Status: An exception was activated
Request details:

The following rule exception was activated:
@@||wildstar.patcher.ncsoft.com$document

Bytes received: 340
Bytes sent: 131

Address: http://wildstar.patcher.ncsoft.com/6682/Launcher.exe.bin
Time: 5/19/2014 7:43:41 AM
Status: An exception was activated
Request details:

The following rule exception was activated:
@@||wildstar.patcher.ncsoft.com$document

Bytes received: 361
Bytes sent: 141

Address: http://www.wildstar-online.com/en/launcher
Time: 5/19/2014 7:43:41 AM
Status: An exception was activated
Request details:

The following rule exception was activated:
@@||wildstar-online.com$document

Bytes received: 346
Bytes sent: 127

Address: http://www.wildstar-online.com/en/launcher/
Time: 5/19/2014 7:43:41 AM
Status: Error
Request details:

Error processing the request:
System.Net.ProtocolViolationException: Http base line violates protocol: 0

Source: Adguard.Http
Stack trace: at Adguard.Http.Protocol.HttpBaseStatusLine..ctor(Byte[] lineBytes)
at Adguard.Http.Protocol.HttpResponse.ParseStatusLine(Byte[] statusLine)
at Adguard.Http.Protocol.HttpBase.ParseStatusLine(Stream stream)
at Adguard.Http.Protocol.HttpBase..ctor(Stream stream)
at Adguard.Network.Filter.HttpFilter.GetResponse(RecordingStream remoteRecordingStream)
at Adguard.Network.Filter.HttpFilter.ProcessRequest(HttpRequest request, FilteringContext filteringContext, RecordingStream remoteRecordingStream)
at Adguard.Network.Filter.HttpFilter.ProcessConnection(RecordingStream localRecordingStream, RecordingStream remoteRecordingStream)
at Adguard.Network.Filter.HttpFilter.Filter()



Bytes received: 0
Bytes sent: 203

Address: http://wildstar.patcher.ncsoft.com/6682/Launcher.exe.bin
Time: 5/19/2014 7:43:42 AM
Status: An exception was activated
Request details:

The following rule exception was activated:
@@||wildstar.patcher.ncsoft.com$document

Bytes received: 424
Bytes sent: 159

Address: http://wildstar.patcher.ncsoft.com/6682/Patch.index.bin
Time: 5/19/2014 7:43:43 AM
Status: An exception was activated
Request details:

The following rule exception was activated:
@@||wildstar.patcher.ncsoft.com$document

Bytes received: 361
Bytes sent: 140
 

avatar

Administrator
Staff member
Administrator
I added the executable to the browser list and chose not to filter but that setting is being looked over.
I don't think that it could help. Better remove it from the browsers list - Adguard won't filter it's traffic for sure.


Could you please send Adguard logs to devteam@adguard.com?
Also we'd like to know when you've launched Wildstar last time.

How to get our logs:
https://kb.adguard.com/index.php?/Russian/Knowledgebase/Article/View/23/0/how-can-i-get-adguard-log-files
 

Nameless

Beta Tester
I don't think that it could help. Better remove it from the browsers list - Adguard won't filter it's traffic for sure.
He's already said that adguard is filtering it when its not in the list, boo berry thought maybe the launcher is using IE to get the page working? Maybe disabling IE from adguard will makle it work?
 

avatar

Administrator
Staff member
Administrator
He's already said that adguard is filtering it when its not in the list, boo berry thought maybe the launcher is using IE to get the page working? Maybe disabling IE from adguard will makle it work?
I am 100% sure that we do not filter it when it's not in the list.

But maybe we've broken some connections of the launcher. We should see error in our logs in this case.
It may use IE also, we'll check it.
 

Boo Berry

Moderator + Beta Tester
Moderator
If it's not using IE, it's probably using Chromium. One thing you could do is try disabling filtering for IE and Chrome in Adguard, then try to see if the launcher works. If that doesn't work you can try a process of elimination by disabling browsers one-by-one and retrying the launcher each time to see which one(s) could be the culprit.
 

Sportif

New Member
So I followed all suggestions here. With no luck. Carbine/NCSoft made some changes to their launcher and all is well for now. Even with this being resolved by their changes... it's still perplexing that AdG would filter a none browser app & would not respect the "do not filter" setting when applied.

As a note. Before the launcher changes.. disabling filtering for the suggested browsers did not help.

I suppose this is a closed case.
 
Top