AdG blocking none browser apps

Discussion in 'Technical Support (Adguard for Windows)' started by Sportif, May 4, 2014.

  1. Sportif

    Sportif New Member

    Joined:
    May 4, 2014
    Messages:
    5
    I play Wildstar (NCSoft).

    Adgaurd blocks HTTP/HTTPs traffic from the game launcher. Even adding the launcher to the browser list and disabling filtering is failing t o bypass filter.

    With ADG enabled
    wadenable.png

    With ADG disabled
    [​IMG]
     
  2. Nameless

    Nameless Beta Tester

    Joined:
    Mar 19, 2014
    Messages:
    723
    Not sure if this will work but no harm in trying...

    @@||wildstar-online.com
     
  3. Sportif

    Sportif New Member

    Joined:
    May 4, 2014
    Messages:
    5
    Thanks but that's a no go. AG still blocks the content in the launcher. It does effect WoW's launcher though.
    I have added all of the Wildstar executables and set them to NOT filtered. That did not work either. -_- We need a exclusion option.

    I am not using the WFP driver as I am on Win7 and have no need for it.
     
  4. Nameless

    Nameless Beta Tester

    Joined:
    Mar 19, 2014
    Messages:
    723
    I'll be honest i dont know much about the application filtering, i just filter my browser and thats it.

    The only other things i can suggest are:
    Whitelist nc-soft if they are the creaters and ask them what ips the client uses so you can unblock them (if you explain why they should tell you) other than that, wait for a dev here to reply but he's on vacation at moment is the english speaking dev.
     
  5. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,081
    Adguard does not filter none-browser applications.

    Are you sure that this launcher does not somehow embeds browser?
    Please look at the processes list when you launch the game.
    What new processes do you see there?
     
  6. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,511
    Perhaps it's using an IE process or another browser process with the launcher? You could try enabling logging to try to find what rule(s) are blocking the request(s).
     
  7. Sportif

    Sportif New Member

    Joined:
    May 4, 2014
    Messages:
    5
    What's next?

    I added the executable to the browser list and chose not to filter but that setting is being looked over.

    So...
     
  8. Nameless

    Nameless Beta Tester

    Joined:
    Mar 19, 2014
    Messages:
    723
    adding whildstar-online.com should work i have seen this code in past ($document) so try these two and remove what u already added.

    @@||wildstar-online.com$document
    @@||wildstar.patcher.ncsoft.com$document
     
  9. Sportif

    Sportif New Member

    Joined:
    May 4, 2014
    Messages:
    5
    Made the change to the filter as suggested. Still not resolved.

     
  10. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,511
    This might be an incompatibility, avatar will have to look into this.
     
  11. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,081
  12. Nameless

    Nameless Beta Tester

    Joined:
    Mar 19, 2014
    Messages:
    723
    He's already said that adguard is filtering it when its not in the list, boo berry thought maybe the launcher is using IE to get the page working? Maybe disabling IE from adguard will makle it work?
     
  13. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,081
    I am 100% sure that we do not filter it when it's not in the list.

    But maybe we've broken some connections of the launcher. We should see error in our logs in this case.
    It may use IE also, we'll check it.
     
  14. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,511
    If it's not using IE, it's probably using Chromium. One thing you could do is try disabling filtering for IE and Chrome in Adguard, then try to see if the launcher works. If that doesn't work you can try a process of elimination by disabling browsers one-by-one and retrying the launcher each time to see which one(s) could be the culprit.
     
  15. Sportif

    Sportif New Member

    Joined:
    May 4, 2014
    Messages:
    5
    So I followed all suggestions here. With no luck. Carbine/NCSoft made some changes to their launcher and all is well for now. Even with this being resolved by their changes... it's still perplexing that AdG would filter a none browser app & would not respect the "do not filter" setting when applied.

    As a note. Before the launcher changes.. disabling filtering for the suggested browsers did not help.

    I suppose this is a closed case.