AdGuard блокирует работу OpenVPN

Discussion in 'Техническая поддержка (AdGuard для Windows)' started by Gutta, May 7, 2017.

  1. Gutta

    Gutta New Member

    Joined:
    Apr 19, 2017
    Messages:
    31
    Установила и настроила по инструкции VPN подключение с помощью OpenVPN 2.4.1
    VPN от FORNEX, IP динамический, файл настроек "готовый".

    OpenVPN не может установить соединение, постоянно пишет "переподключение", если Adguard отключить, проблема исчезает и соединение устанавливается.
    После установки VPN соединения с помощью OpenVPN, Adguard не работает, даже не даёт обновить фильтры программы, как решить возникшую проблему?

    С другими VPN клиентами, например, HideME, такой проблемы не возникает.
     
    Lugnovka likes this.
  2. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,905
    @Gutta сервис платный, поэтому повторить у себя не можем. Потребуются логи.

    Как их собрать и отправить нам:

    1) В меню в трее кликните на иконке Adguard правой клавишей, выберите "Расширенные - Уровень логгирования - Подробный". Затем повторите проблему (обязательно обратите внимание на точное время), после чего переключите логгирование обратно на "Обычное".

    2) Следуйте этой инструкции, чтобы найти логи: https://kb.adguard.com/ru/windows/solving-problems/adguard-logs

    3) Отправьте их в поддержку support@adguard.com и укажите в сообщении предпринятые вами шаги по повторению проблемы и отмеченное время.

    4) В этой теме укажите customer ID, который будет указан в автоматическом ответе от поддержки.
     
  3. Gutta

    Gutta New Member

    Joined:
    Apr 19, 2017
    Messages:
    31
    Всё готово, подробные логи и отчёт о диагностике отправила. ID 1557672
     
  4. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,905
    @Gutta спасибо за логи.

    Не могли бы вы взглянуть в свой конфиг и сказать, какой протокол там используется? Интересует строчка наподобие
    Code:
    proto udp
    (proto - протокол).

    Также интересует строка
    Code:
    remote x.x.x.x 1194
    Где x.x.x.x - это IP-адрес, а на месте 1194 будет какой-то номер порта.

    Можете ответить через поддержку или прямо здесь, как вам удобнее.
     
  5. Gutta

    Gutta New Member

    Joined:
    Apr 19, 2017
    Messages:
    31
    Я отправила Вам в пм сам готовый конфиг файл, я в этом не сильно разбираюсь.
     
  6. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,905
    @Gutta конфиг получили, спасибо. Приблизительно как мы и думали, использование UDP протокола и 443 порта скорее всего и ведет к такому поведению. Здесь много общего ещё с этой проблемой: https://github.com/AdguardTeam/AdguardForWindows/issues/1482

    Мы завели задачу, будем работать над её решением:
    https://github.com/AdguardTeam/AdguardForWindows/issues/1749

    Тем временем, вы можете попробовать использовать альтернативные порты в конфиге (не 443), есть шанс, что это поможет.
     
  7. Gutta

    Gutta New Member

    Joined:
    Apr 19, 2017
    Messages:
    31
    Хорошо, спасибо.
    Буду ждать обновления :)
     
  8. U_Syrex

    U_Syrex New Member

    Joined:
    Apr 29, 2016
    Messages:
    17
    Сейчас установил и настроил OpenVPN 2.4.5, проблем с подключением или с работой AdGuard нет, всё хорошо.