AdGuard для Windows, Crome и гугловские сайты.

Discussion in 'Техническая поддержка (AdGuard для Windows)' started by sayrus, Jun 16, 2014.

  1. sayrus

    sayrus Member

    Joined:
    Mar 23, 2014
    Messages:
    158
    При попытке зайти на сайт www.google.ru, https://play.google.com/ выскакивает такое окно
    [​IMG]
    При старте хрома он пытается залогиниться в профиле хрома по адресу chrome://chrome-signin/?source=0
    Вместо этого действия пустое окно
    [​IMG]
    При отключении фильтрации Crome в настройках Adguard все функционирует нормально.
    Как восстановить работоспособность гугловских сервисов и при этом не отключать блокировку рекламы на этих сервисах?
     
  2. Confessor

    Confessor Administrator Staff Member Administrator

    Joined:
    Jan 30, 2012
    Messages:
    353
    Здравствуйте.

    Очень любопытно, данная проблема повторяется скажем после перезагрузки компьютера?
    Используется обычный google chrome с оф. сайта а не какая либо сборка?
    Используется ли какое-либо антивирусное ПО, файрволы или прочее ПО имеющее отношение к фильтрации интернет трафика?
    И последнее, не могли бы Вы сказать/показать какие используете расширения для браузера, можно скрином в личном сообщении.

    Если проблема постоянная, то очень походе на конфликт, а вот с чем, антивирус/расширения, это еще предстоит выяснить.
     
  3. sayrus

    sayrus Member

    Joined:
    Mar 23, 2014
    Messages:
    158
    Здравствуйте
    Chrome с официального сайта.
    Установлен касперский
    [​IMG]
    Установлены следующие расширения
    [​IMG]
    Adblock, естественно, отключен, пользовался им до приобретения Adguard.
    Только что проверил - проблема повторяется.
    Если выгрузить касперского - проблема повторяется. Больше никакого антивирусного ПО не установлено.


    Сразу после перезагрузки гугловские сайты заработали нормально, но, после того как комп полностью прогрузился, проблема вернулась.
    Система Windows 7 Домашняя расширенная.
    Бранмауэр Windows отключен.
    Отключил все расширения - не помогло.
     
    Last edited by a moderator: Jun 17, 2014
  4. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,932
    А что значит полностью прогрузился?
    Какие-то еще программы запускались помимо Adguard?


    Еще вопрос - а наблюдается ли эта проблема если вы заходите, к примеру, на https://mail.ru (важно, чтобы в адресе было именно https)?
     
  5. sayrus

    sayrus Member

    Joined:
    Mar 23, 2014
    Messages:
    158
    После появления рабочего стола комп еще некоторое время грузится, программы в атозагрузке не мгновенно же запускаются., вот я запустил хром именно в момент, когда еще не все запустилось. В автозагрузке проги от ноута да яндекс-диск.
    Автозагрузка:
    [​IMG]
    [​IMG]
    Mail.ru тоже не работает. (я пользуюсь оперой 12.14, но она потихоньку умирает, вот и задумался перейти на хром, но не получается)
    [​IMG]

    Почта на яндексе тоже не работает - появляется такое же окно как и у гугла.
    Если после перезагрузки запустить хром до старта Adguarg, то сайты не блокируются, но и реклама не режется, после перезагрузки хрома проблема опять появляется (это к слову о прогрузке, сейчас проследил внимательнее).


    Балин... Сейчас после загрузки зашел в почту на мейле, а там релама не режется и даже помощника нет, на шлавной мейла и помощник есть и реклама режется, а после входа в почту Adguard не отрабатывает.
     
    Last edited by a moderator: Jun 17, 2014
  6. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,932
    Так, ну похоже у нас тут сложная ситуация с нашим сертификатом, его каким-то образом вычистили отовсюду.

    Попробуйте вручную его установить.

    Вот тут у нас инструкция:
    https://kb.adguard.com/index.php?/R...View/8/0/soedinenie-ne-javljaetsja-doverennym

    Внизу в этой статье инструкция для всех браузеров кроме Оперы и Firefox.
    Но там же в статье ссылка на инструкцию для них.
     
  7. sayrus

    sayrus Member

    Joined:
    Mar 23, 2014
    Messages:
    158
    В опере сертификат был установлен.
    По инструкции для остальных браузеров установил, перезагрузил комп - в хроме не работает.
    Более детально ошибка
    [​IMG]
    Похоже проблема с самим сертификатом. Может вы пришлете отдельно сертификат, если такое возможно, чтобы всю прогу не переустанавливать.
     
  8. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,932
    Ничего себе как оно бывает.

    Попробуйте сделать вот что:
    1. Удалите директорию %programdata%\Adguard\NetworkTemp (!только вышлите мне Adguard CA.crt для анализа что пошло не так)
    2. Перезагрузите компьютер
     
  9. sayrus

    sayrus Member

    Joined:
    Mar 23, 2014
    Messages:
    158
    Сертификаты отправил.
    В хроме все заработало.
    В опере 12.14 на гавной режет рекламу, а в веб-интерфейсе почты слева внизу висит банер и отсутствует значек помощника.
     
  10. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,932
    Насчет оперы - в ней отключилась фильтрация HTTPS, видимо сертификат был не найден Adguard'ом при старте защиты.
    Для нее желательно сертификат установить вручную, как здесь указано: http://blog.adguard.com/ru/howto/podderzhka-filtratsii-https-soedineniy-v-portable-brauzerah.html
     
  11. sayrus

    sayrus Member

    Joined:
    Mar 23, 2014
    Messages:
    158
    Удалил и установил по инструкции сертификат в оперу - не помогло.
    Включал, выключал фильтрацию для оперы, пробовал выключать, включать фильтрацию https - не помогло.
    Переустановил Adguard с удалением всех настроек - не помогло.
    Остается надеяться, что само пройдет :)

    Прикол в том, что фильтрация работает в почте яндекса и гугла, не работает только в мейловской почте.
     
    Last edited by a moderator: Jun 17, 2014
  12. sayrus

    sayrus Member

    Joined:
    Mar 23, 2014
    Messages:
    158
    Установил себе оперу 22 - ситуация с майлом полностью повторилась. Рекламу вырезал расширением Ghostery.
     
  13. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,932
    Старую оперу при этом не удалили?

    Adguard не начнет фильтровать HTTPS в опере, пока сертификат наш не будет установлен (инструкция выше в треде).
     
  14. sayrus

    sayrus Member

    Joined:
    Mar 23, 2014
    Messages:
    158
    У оперы 12.14 и 22 общий только значек, и то цветом отличается. Они не влияют на работу друг друга.
    Сертификаты стоят
    [​IMG]
    Реклама сейчас не моргает из-за Ghostery , поэтому пока забью на эту проблему.
     
  15. sayrus

    sayrus Member

    Joined:
    Mar 23, 2014
    Messages:
    158
    Вчера вечером переустановил обе оперы с полным удаление настроек и удалением оставшихся папок. В опере 22 все заработало нормально, в опере 12.14 так и не работает https фильтрация на mail.ru.
    Я в виртуальной машине с Win 8.1 установил Adguard и оперу 12.14 - на главной фильтры работают и есть значек помощника, в интерфейсе почты висит реклама и нет значка помощника, сертификат вручную установил при первом запуске оперы, сертификат автоматом не подхватился.
    [​IMG]
     
  16. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,932
    Что-то уже слишком похоже становится на наш дефект.
    Мы проверим отдельно, спасибо!
     
  17. sayrus

    sayrus Member

    Joined:
    Mar 23, 2014
    Messages:
    158
    И 22 опера частично дружит с https на mail.ru. С главной страницы перехожу в почта - фильтрция есть. Через некоторое время после прочтения писем фильтрация и значек Adguard пропадают; не закрывая эту вкладку, создаю новую и захожу на главную mail.ru, потом в почту - фильтрация и значек есть, а на старой вкладке отсутствует.
    Как-то опера некоректно отрабатывает. На других почтовых сервисах редко бываю ничего по ним сказать не могу.
    Еще в связи с последними событиями по блокировке lostfilm стал пользоваться расширением Zenmate, при его работе реклама не режется, но я не знаю механизм его работы и не знаю возможно ли это обойти (хотя Zenmate влезает в настройки прокси).
    Любы данные, скрины, отчеты информационных утилит готов предоставить.
     
  18. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,932
    Тут вся проблема в том, что установлена Opera 12.
    Adguard отключает фильтрацию HTTPS сразу для обеих, когда считает, что в Опере не установлен сертификат.
    Почему он так считает в случае Opera 12, это другой вопрос, но если бы ее не было - все бы работало.