AdGuard 5.10 beta version release

Discussion in 'Release Notes (Beta Versions)' started by avatar, Apr 30, 2014.

  1. Rian

    Rian Beta Tester

    Joined:
    Jun 6, 2014
    Messages:
    137
    Okey checked again it uses much less.......... 42.3 MB..... Thanks for clarifying :)
    Also i need to report an issue i have been having since i installed AdGuard (not just beta)....it just happens randomly.... sometimes when i try to open a webpage it doesnt load (i will see a blank page) when i reload everything is fine....... i am waiting for my proof .... i will get you when it happens again.....

     
  2. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,171
    Don't know where to post this, but here's some useful rules I made while running Chrome with an Android user agent (to spoof mobile);

    ||google_ads_iframe*
    ||google_ads_frame*
     
  3. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,144
    Thanks!
    What do they block?
     
  4. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,171
    Mobile ads, actually. :p
     
  5. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    Don't mean to be a pain in the a$$, any idea when 5.10 will be released to the world?
     
  6. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,171
    Reading the Russian sections (Google Translate in Chrome FTW!) there should be another 5.10 beta this week.
     
    Last edited by a moderator: Jun 30, 2014
  7. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    Thanks BB.
     
  8. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,171
    You're welcome! :)
     
  9. Nameless

    Nameless Beta Tester

    Joined:
    Mar 19, 2014
    Messages:
    733
    Any news on 5.10 being released avatar?

    Mostly after the subscription lists, not that i have many issues but will help those that want them most.
     
  10. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,144
    Next beta will be in the end of this week.
    Filters subscriptions is one of new features in it.
     
  11. Nameless

    Nameless Beta Tester

    Joined:
    Mar 19, 2014
    Messages:
    733
    Thanks avatar =)

    Yes i read it on the road map, be interesting to see how it all works and to see what organisation canbe done =)
     
  12. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,171
    You guys might want to check out the Google Chrome 37 64-bit dev channel builds. Yes, I'm aware they're developer builds but I'm noticing sometimes that either filtering will completely fail (forcing me to restart the PC) and/or YouTube Center isn't being injected to the webpages. Other browsers, including Chromium 38 64-bit seems to be working fine.

    Hopefully it's just an issue in Chrome that'll get fixed. Once 37 (and 64-bit builds hopefully) hits beta, I'll keep watching out for issues like these.
     
  13. steve1209

    steve1209 Beta Tester

    Joined:
    Mar 31, 2014
    Messages:
    501
    Hey Boo Berry,

    I switched to Chrome Dev Version 37.0.2062.3 dev-m (64-bit) and haven't had any problems at all, can you give a site that completely fails or causes you to restart your computer, no such problems on Win 7 SP1 X64 for me!
     
  14. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,171
    The problem isn't specific sites. It's just sometimes Adguard isn't filtering x64 Chrome.exe at all forcing me to either restart the browser, disable/re-enable filtering, disable/re-enable Chrome filtering, rebooting, etc. Very odd indeed. Of course, I'm using the WFP driver with KIS 2015 TR so there's a possibility an incompatibility exists.
     
  15. steve1209

    steve1209 Beta Tester

    Joined:
    Mar 31, 2014
    Messages:
    501
    Hey BB,

    I'm using the WFP driver as well and still haven't encountered a problem Win 7 X64, I'm using Avira Free V2014 A/V which just came out of Beta, EMSISoft Anti Malware Beta V9.0.0.4157 and Malwarebytes Anti-Malware Beta 2.0.2.1012
     
  16. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,171
    Hmmm. Right now I'm not *too* concerned about it, but I'll keep a lot out just in case (especially if Chrome 37 x64 gets pushed to the beta phase). I'm hoping it's just a dev build-specific issue which will be resolved with a future dev build. Worst case, however, would be the KIS incompatibility rearing its ugly head in a new way. Time will tell indeed.

    Also avatar, will the next beta fix the Adguard extension in Firefox not being updatable from your servers while Adguard for Windows is actively filtering? :p

    ---------- Post added at 07:52 PM ---------- Previous post was at 06:32 PM ----------

    Ahh, noticed something important. It seems to be only SSL sites that fail to be filtered - HTTP filtering is fine. Sounds familiar, no? I can tell SSL filtering is failing because I have the Chrome extension installed for integration/Assistant purposes - HTTP sites display all while SSL sites display no count at all and ads show. That leads me to the following potential conclusions;

    - There's a SSL filtering bug when filtering 64-bit Chrome processes.
    - There's an incompatibility with KIS 2015 TR and Adguard's WFP driver.
    - There's a bug or a change which breaks this, hence causing this issue in the current 64-bit dev build of Google Chrome - Chromium builds seem to be fine however Chromium hasn't been updated for a week so I'll have to wait and see on this one.

    It could be a combination of multiple factors too, not honestly sure. More testing will be conducted. What I'm going to do next? Switch to the TDI driver and try to reproduce it there.
     
  17. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,144
    Of course:)

    What for Chrome x64, we'll wait until beta-version stage. It's too early right now.
     
  18. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    I guess it's fair to say that the next 5.10 beta has been delayed? Is there an new ETA?
     
  19. marke68

    marke68 Beta Tester

    Joined:
    Jun 28, 2014
    Messages:
    7
    I must admit i'm the same,other than the odd jump in memory use which has always rectified itself i've found nothing worthy of reporting.:)
     
  20. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,144
    Monday I hope. Sorry guys, too many bugs this time, it is just not ready to become beta right now.
    I've put aside android version and coding myself to make it ready asap.

    ---------- Post added at 08:09 PM ---------- Previous post was at 08:08 PM ----------

    Hehe, don't worry, I am pretty sure next beta will have some bugs:)