AdGuard 5.7 alpha version release

avatar

Administrator
Staff member
Administrator
Dear beta-testers!

Adguard 5.7 version is ready for alpha-testing.

What is the difference between alpha and beta versions:
1. Alpha versions are _not_ stable. Be ready for bugs:)
2. This is why there is no auto-update to alpha-versions.

List of features in this alpha-version

+ Adguard now use new network filtration driver
No more redirect, no more conflicts with other software.

+ All conflicts Adguard has with other software are now resolved
+ Complete filtration of browsers in Modern UI mode (Adguard 5.6 did not filter Modern UI if Avast or Kaspersky is installed)
+ HTTPS filtration

- Proxy mode is for backward compatibility only. We plan to remove it in Adguard 6.0.

How to install alpha version

1. Download installation package from http://static.adguard.com/5/alpha/adguardInstallerAlpha.exe
2. This is very important: run it with admin privileges (right click on the file and select Run as Administrator)

--
Regards,
Adguard team
 

Boo Berry

Moderator + Beta Tester
Moderator
I've clean installed the alpha and thus far it's working fine (make sure you reboot after uninstalling/reinstalling or else filtering doesn't work) - HTTPS filtering is working absolutely great! Goodbye Adblock (for HTTPS filtering only) for Chrome/Firefox/Opera! Now, what I did for this testing is I did clean profiles for Chrome, Chromium, Firefox and Opera. I've also reset IE to its defaults and I'll start massive testing with websites tonight and tomorrow. If I find anything I'll be sure to report it. :)
 

avatar

Administrator
Staff member
Administrator
Great, thank you very much!:)

Some problems were reported this night:

1. Problem with Internet Explorer 10 (cannot open some web sites)
2. Some net::ERR_EMPTY_RESPONSE errors in Google Chrome
3. Adguard assistant do not work on facebook.com
 

Boo Berry

Moderator + Beta Tester
Moderator
Adguard assistant also doesn't appear on gamecopyworld.com and sometimes in IE10 when you open multiple tabs, they stay white and never load.
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
Also, Adguard seems to be messing up Maxthon's favorites sync feature and causing it to error out. Works fine when filtering is disabled.
 

avatar

Administrator
Staff member
Administrator
UPDATE from Jul, 30

New alpha version is available -- 5.7.894.4693

Fixed problems with filtration in Windows XP
Fixed random error responses in chrome: net::ERR_EMPTY_RESPONSE
Fixed problem with Maxthon favourites synchronization
 

avatar

Administrator
Staff member
Administrator
UPDATE2 from Jul 30

New alpha version is available -- 5.7.895.4697.

Fixed problems with Adguard Assistant in previous alpha-version.
 

rickyoh

Beta Tester
Excellent work, the hard work on this version really shows. https filtering is working really well and i am excited to test this fuctionality. will keep an eye out for any issues.
 

avatar

Administrator
Staff member
Administrator
UPDATE from Jul, 31

Adguard 5.7.903.4708 alpha version is available.

Change log:

* We are now using TDI driver instead of WFP driver on Windows 7. This should fix BSODs (Windows 7 + uTorrent + Adguard)

* We use another protocol for inter-process communication between GUI and windows service.
GUI works much faster now.

* Some minor fixes in network filtration library. Resolved some issues with HTTP protocol.
 

Boo Berry

Moderator + Beta Tester
Moderator
Question, can something be done about this...

http://img855.imageshack.us/img855/9259/a93z.jpg

What I'm talking about is when you're trying to block an element and you click Advanced settings... it creates the expanded window below the visible drawn screen. Can this be modified so the full Advanced settings can be shown without needing to drag the assistant window up to see the Block and other buttons (the full window)?
 

Boo Berry

Moderator + Beta Tester
Moderator
Something I just noticed, the icon used for Pale Moon is using the SRWare Iron icon, not a Pale Moon icon.
 
Top