AdGuard 5.9 beta release

avatar

Administrator
Staff member
Administrator
so does this mean that it will analyze content in future ?
We were thinking about categorizing content using dictionaries.

another question; how does parental control handle sites that are unknown to WOT ? because as i see it these sites, if undesirable, could slip through parental control because WOT does not identify them as such. i feel that a straight up whitelist would be sufficient for web site blocking; if any site is not on the white list it is blocked!
Depends on the filtering sensitivity level.
Blocks them for the highest levels.

also cannot download a file with parental control enabled. after inputting a password to allow the download to begin, it does not.
Executable or a file from the blacklisted domain?
 

rickyoh

Beta Tester
thank you for your clarifications/answers, but if you don't mind:

We were thinking about categorizing content using dictionaries.
dictionaries ? how do you mean ?

Depends on the filtering sensitivity level.
Blocks them for the highest levels.
the highest level being early childhood ? so for the other two levels, sites that are unknown to WOT are displayed ?


Executable or a file from the blacklisted domain?
executable file.

also, having the issue quoted here but now in Avant when using the firefox engine. maxthon seems fixed, thank you.
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
dictionaries ? how do you mean ?
Something like this:

Dictionary1 (category porn):
word1 weightOfWord1
word2 weightOfWord2
word3 weightOfWord3

Dictionary2 (category politics):
word4 weightOfWord4
word5 weightOfWord5
word6 weightOfWord6

We can analyze the web page and count the weight of each category.
For each category we have a weight limit. Web page is blocked if weight limit is hit.

the highest level being early childhood ? so for the other two levels, sites that are unknown to WOT are displayed ?
These sites are blocked for "Young" and "Early childhood"
 

Boo Berry

Moderator + Beta Tester
Moderator
Anything new regarding KIS 2014 + Adguard + WFP driver + Google domains (https://news.google.com/) randomly giving either SSL errors in Firefox or blank pages in Chrome? There's a new KIS patch (patch E) and I retested this, however I still experience the issue.
 

Boo Berry

Moderator + Beta Tester
Moderator
Yeah, with 8 it'll work fine but with 8.1 it'll go screwy. :p Hopefully with the Windows 8.1 Update 1 coming soon, more incompatibilities don't arise.
 
Last edited by a moderator:

Accel

Beta Tester
by the way is there any news about the new build which using the program to contact server for rating.adguard.com? it's kind of annoying to not having adguard in my system
 

avatar

Administrator
Staff member
Administrator
by the way is there any news about the new build which using the program to contact server for rating.adguard.com? it's kind of annoying to not having adguard in my system
Tomorrow it will be available (maybe today but I am not sure).
 

KoalaK

Beta Tester
Hi,

Installed 5.8 on windows 7 64 bits system then updated to latest beta without issue
After one day of use i have no bug to report
Adguard with Parental Control disabled working nicely with my main browser Iron
Other realtime security software : NOD32 v7 (HIPS deactivated) and Online Armor without Webshield
Memory usage is still heavy : 100 Mo for each Service and UI components.
 

Boo Berry

Moderator + Beta Tester
Moderator
As I also posted in this topic, higher resource usage, especially when watching videos/loading games/using Flash or Java/etc. might be something we have to live with. Also considering web browsers like Firefox and Chrome seem to also spike in resource usage too.

Hopefully I'm wrong though and something can be done about this. :D
 

Cary

Beta Tester
Hopefully I'm wrong though and something can be done about this. :D
No, you're right. Using Firefox Nighly x64, I've had YouTube come to a complete and utter stop, locking the browser. This doesn't happen if I'm using Proxomitron.
Incidentally, trying to get AWAY from Proxo. While it's redirect avoidance is brilliant, I'm finding it increasingly incompatible with the interwebs.
 

KoalaK

Beta Tester
Help button link to KB page not to Online Help
There is no more local Helpfile and link is start menu is still there
 

avatar

Administrator
Staff member
Administrator
As I also posted in this topic, higher resource usage, especially when watching videos/loading games/using Flash or Java/etc. might be something we have to live with. Also considering web browsers like Firefox and Chrome seem to also spike in resource usage too.
At least we will fix memory usage on large files download soon.

---------- Post added at 03:01 PM ---------- Previous post was at 02:58 PM ----------

Help button link to KB page not to Online Help
There is no more local Helpfile and link is start menu is still there
Thank you! Looks like it is update issue, everything is good on clean install.
 

avatar

Administrator
Staff member
Administrator
We've released new beta-version (5.9.1062.5426).

Change log:

* Fixed issues with high memory and CPU usage on large file upload
* Fixed random firefox HTTPS filtration absense
* Improved userscripts support -- added @document-start and some greasemonkey API functions support
* Fixed issue with broken images blocked by parental control
* Some bugfixes for parental control
* Added localization
* Added rocket-script blocking support
* Improved Adguard Assistant performance

Serious tasks which are still open:

* Compatibility issue Windows 8.1 + WFP + KIS2014
* High disk load on system startup
* Some minor issues with text and UI
* Some defects with update from 5.8 to 5.9
* We want to add an opportunity to disable SSL-filtration for specific web sites
 

Boo Berry

Moderator + Beta Tester
Moderator
Have you guys reproduced the KIS 2014 issue(s)? If you guys need help, I'll try to write a step-by-step reproduction for it.
 

avatar

Administrator
Staff member
Administrator
UPDATE

Found a critical bug in this beta so I've disabled it for now.
Sorry, wait for tomorrow please:(

---------- Post added 27-02-2014 at 12:01 AM ---------- Previous post was 26-02-2014 at 11:59 PM ----------

Have you guys reproduced the KIS 2014 issue(s)? If you guys need help, I'll try to write a step-by-step reproduction for it.
We've reproduced it, working on fix.
 

Boo Berry

Moderator + Beta Tester
Moderator
If you don't mind, I'd like to know the technical information for the reason(s) the incompatibility with KIS2014 happens. :D You guys might find other issues - for example there may be issues with a default KIS2014 install and blank web pages, slow page loading, etc. for both drivers with all browsers. But because I excluded Adguard and all browser processes in Kaspersky any issues I may notice with both drivers don't happen - just WFP in that case.

Actually, I'll remove Adguard/web browsers from exclusion and see what happens.

And whoops, updated. What's the critical bug and do we need to downgrade?
 
Last edited by a moderator:
Top