AdGuard 5.9 beta release

Boo Berry

Moderator + Beta Tester
Moderator
Quick question, when you click check for updates for extensions (userscripts) do disabled userscripts update too even though they're disabled?
 

avatar

Administrator
Staff member
Administrator
Does Adguard use blocking rules for HTML filtering too?
Yes it does. Using element hiding rules only is not good - you'll see broken images/iframes/etc.

Removing these types of objects is ok but we also remove all links to the blocked resources.
We do it because if we miss such links and you click on it - you'll get an empty response.

The problem is that Adguard wouldn't know if request is for the web page or for some page element (image/flash/etc).

So we try to make our own rules more "precise" to avoid false-positives.

--
Someday we'll stop blocking links. Just need some time to find proper solution.

---------- Post added at 08:09 PM ---------- Previous post was at 07:42 PM ----------

Quick question, when you click check for updates for extensions (userscripts) do disabled userscripts update too even though they're disabled?
Yes, they do

---------- Post added at 08:09 PM ---------- Previous post was at 08:09 PM ----------

YouTube Center doesn't save (local storage) settings it seems in Internet Explorer or Firefox. This *may* be because of the script currently being partially broken - in the case of IE I don't have an alternative to check. Setting save fine in Chrome.
We'll check it, thanks
 

Boo Berry

Moderator + Beta Tester
Moderator
Ah, excellent. If the script is actually broken, let me know and I'll inform the author (though he seems MIA for the time being). But if it is indeed broken I'll probably wait for the 5.9 release, so the author can trial Adguard to test the script for compatibility.
 
Last edited by a moderator:

pablozi

Beta Tester
Hello
I have a strange issue with AdGuard (stable and beta) on abnamro.nl website (Dutch bank).
After logging in to my bank account i cannot see accounts list - website needs to be refreshed then they appear.
And second thing on the same website - I cannot log out with AdGuard enabled.
When AG is disabled none of the issues are present.
Tested on IE 11, W8.1 x64 PL.
 

avatar

Administrator
Staff member
Administrator
Hello
I have a strange issue with AdGuard (stable and beta) on abnamro.nl website (Dutch bank).
After logging in to my bank account i cannot see accounts list - website needs to be refreshed then they appear.
And second thing on the same website - I cannot log out with AdGuard enabled.
When AG is disabled none of the issues are present.
Tested on IE 11, W8.1 x64 PL.
I think there's an issue with Adguard filters.

Could you add this domain to exceptions and try again?
 

DoctorPC

Beta Tester
Can we get some release notes for todays beta version?

Thanks.

Oh, I cannot upgrade to the latest beta version. It says the installer package is damaged. o_O
 

Cary

Beta Tester
I noticed that there are wellsfargo.com exemptions in the english filter pushed out today. Yet, I still cannot make a secure connection with the bank. Were these exceptions already part of the english filters, or are they new?
 

avatar

Administrator
Staff member
Administrator
I noticed that there are wellsfargo.com exemptions in the english filter pushed out today. Yet, I still cannot make a secure connection with the bank. Were these exceptions already part of the english filters, or are they new?
We cannot disable https filtration per domain -- for now.
So you should wait for the next release -- we'll hardcode this exception as a workaround (until we add https filtration exceptions to UI).

---------- Post added at 10:25 AM ---------- Previous post was at 10:06 AM ----------

Can we get some release notes for todays beta version?
Release candidate is coming, fixing some minor bugs and improving localization.

What's left:
1. HTTPS issue with Virgin Mobile and Wellsfargo.
2. Update from 5.x to 5.9 issues (broken shortcuts, unused files left)
3. Localization (for example switch to spanish to see the problem)
4. Some minor userscripts issues

Oh, I cannot upgrade to the latest beta version. It says the installer package is damaged. o_O
Wow, strange. Could you reproduce it and send us your log files?
 

avatar

Administrator
Staff member
Administrator
Ah, excellent. If the script is actually broken, let me know and I'll inform the author (though he seems MIA for the time being). But if it is indeed broken I'll probably wait for the 5.9 release, so the author can trial Adguard to test the script for compatibility.
We've checked it and it works fine in IE and Firefox.

How we tested:
1. Changed Youtube Center settings
2. Closed browser
3. Opened it again
4. Check Youtube Center settings
 

thomster

Beta Tester
In the latest beta the Statistics - Traffic graph does not seem to function. This is the first beta I've tried so I don't know whether it functioned previously. It doesn't matter what time frame I select (Today, Last week etc.) nothing appears.

2014-03-07 10_02_21-Adguard Web Filter.png
 

avatar

Administrator
Staff member
Administrator
In the latest beta the Statistics - Traffic graph does not seem to function. This is the first beta I've tried so I don't know whether it functioned previously. It doesn't matter what time frame I select (Today, Last week etc.) nothing appears.
Confirmed, thank you!
 

puff-m-d

Beta Tester
Hello,

This may have been mentioned before but if so, I missed it... This concerns the check for updates option from the tray icon. Would it not be more convenient and sensible to just have one check for updates that would automatically check all three? Or if not, at least add an "update all" option to the right click menu along with the three current options? Especially with beta testing where new program releases come out a lot more often, it would be so much easier to just check for updates once and take care of all available updates. I think having the three separate update options could be confusing to the less experienced and new users and think it would be best for all to keep it as simple as possible...
 

avatar

Administrator
Staff member
Administrator
parental control preventing the loading of some images on http://www.bhphotovideo.com/c/buy/Wearable-Tech/ci/24005/N/3957447225 the product images load with parental control off.
Thank you, we'll fix it soon.

---------- Post added at 10:42 AM ---------- Previous post was at 10:40 AM ----------

Hello,

This may have been mentioned before but if so, I missed it... This concerns the check for updates option from the tray icon. Would it not be more convenient and sensible to just have one check for updates that would automatically check all three? Or if not, at least add an "update all" option to the right click menu along with the three current options? Especially with beta testing where new program releases come out a lot more often, it would be so much easier to just check for updates once and take care of all available updates. I think having the three separate update options could be confusing to the less experienced and new users and think it would be best for all to keep it as simple as possible...
We'll do it in Adguard 6 -- one button for all updates (maybe two buttons - one for program updates, second for filters/extensions).
 
Top