AdGuard 5.9 release

avatar

Administrator
Staff member
Administrator
I am pleased to announce Adguard 5.9 release.

Version 5.9 brings a large number of changes to Adguard.

New features

Adguard Extensions



In version 5.9, there is an opportunity to install extensions (userscripts). They are designed to extend the functionality of websites. How exactly will the functionality be extended depends on the particular userscript. This can be a pop-up blocking, blocking of flash requests, possibility to download music and video from social networks and much more.

You can learn more from this post in our blog.

Improved video ads blocking

In this version, Adguard learned to recognize most of the video ads on its own without relying on filter databases.

Parental Control



During the existence of the program, we have received many requests from our users about implementing the "Parental Control" in it. Many parents found Adguard helpful, because when using it the child didn’t see inappropriate advertising.

Finally, in the version 5.9 we are ready to introduce “Parental Control” - a separate module of the program.
You can learn more from this article.

Fixed and improved in this version

  • Fixed a problem with high load on the CPU and memory consumption when downloading large files
  • Fixed a problem with the occasional lack of HTTPS-connections filtering in Firefox and Opera
  • Fixed a problem with high load on the CPU and disk on system startup
  • Optimized and speeded up the work of Adguard Assistant
  • Added support for rocket-script filtering
  • Fixed Adguard compatibility issue with Kaspersky Internet Security 2014 for Windows 8.1 x64

Big thanks to all beta testers

Thanks to everyone who has volunteered to test Adguard 5.9!
You do it so good that I am starting to think that you all are professional software testing engineers!:)

Our future plans

As always we are missing all deadlines.
One day we'll learn how to do everything in time:).

So what's in progress now:

Firefox extension - we have just started development

Adguard for Android - development is in progress. We will soon get a working prototype (not ready for public yet but it is a very important step).

Adguard for Mac OS X - the same as for android version. Prototype is coming soon.

Adguard 6 for Windows - new design is ready. Working on first UI client prototype.
 
Last edited by a moderator:

superssjdan

New Member
Working really well along with Eset on my system.Excellent,excellent work done by the developers.I am so happy I discovered adguard a few months ago,after previously having used admuncher.It truly is the best at what it does,far exceeding what I thought was possible.I am also running KIS on my wife's windows 7 64 bit pc and have yet to try Adguard's latest update on that one.I see Avatar that you use KIS yourself.I have also used it for many years on at least 1 of my machines.Just a quick question for you related to KIS and ie along with Adguard:Do you use Enhanced protected mode and Enable 64 bit processes for enhanced protected mode for IE?I had previously found that KIS didn't seem to run as smoothly with those active.Kudos to the entire Adguard team for the superb job on the latest update!
 

Boo Berry

Moderator + Beta Tester
Moderator
KIS2014 + IE11 x64/Enhanced Protected Mode is working fine here... if you enable the WFP driver under Adguard's options > Settings > Network. Make sure Extended interface is enabled to see the options. Otherwise, IE11 x64/Enhanced Protected Mode won't work with the default TDI driver.
 

superssjdan

New Member
KIS2014 + IE11 x64/Enhanced Protected Mode is working fine here... if you enable the WFP driver under Adguard's options > Settings > Network. Make sure Extended interface is enabled to see the options. Otherwise, IE11 x64/Enhanced Protected Mode won't work with the default TDI driver.
Thank you so much for the quick reply and help.Will update my wife's machine the second she is done her schoolwork.
 

Boo Berry

Moderator + Beta Tester
Moderator
Yeah, it's something that should go into the FAQ article at some point. With the default TDI driver, Adguard can't filter Enhanced Protected Mode or the Modern UI version of Internet Explorer where-as the WFP driver can. I guess you're wondering why the WFP driver isn't default then? Well, in past testing there was a couple issues with the WFP driver; mainly an incompatibility with uTorrent + teredo tunneling which *could* trigger a BSOD when running both at random. The developers tried to workaround the issue several times (an example would be disabling teredo tunneling system-wide), however I'm not sure of the current status of that issue (e.g. if it was workedaround either in Adguard or the teredo tunneling BSOD was fixed in uTorrent itself which is the actual cause of this incompatibility). There was (and still may) be a WFP driver incompatibility with ESET's products, mainly ESET Smart Security but I believe that too was fixed in 5.8 if I remember right where-as the KIS2014 incompatibility with the WFP driver on Windows 8.1 was fixed in 5.9.
 
Last edited by a moderator:

superssjdan

New Member
Yeah, it's something that should go into the FAQ article at some point. With the default TDI driver, Adguard can't filter Enhanced Protected Mode or the Modern UI version of Internet Explorer where-as the WFP driver can. I guess you're wondering why the WFP driver isn't default then? Well, in past testing there was a couple issues with the WFP driver; mainly an incompatibility with uTorrent + teredo tunneling which *could* trigger a BSOD when running both at random. The developers tried to workaround the issue several times (an example would be disabling teredo tunneling system-wide), however I'm not sure of the current status of that issue (e.g. if it was workedaround either in Adguard or the teredo tunneling BSOD was fixed in uTorrent itself which is the actual cause of this incompatibility). There was (and still may) be a WFP driver incompatibility with ESET's products, mainly ESET Smart Security but I believe that too was fixed in 5.8 if I remember right where-as the KIS2014 incompatibility with the WFP driver on Windows 8.1 was fixed in 5.9.
Thanks for the detailed information.It's very much appreciated.The latest update is up and running well on my wife's pc as well.The only thing I didn't get around to before she hurried me off her pc was setting up exceptions in KIS for adguard.Seems to be running great without setting up exceptions.At this point I would only set up exceptions in KIS only if recommended.Don't believe in tinkering too much if it's not needed.I also posted in the techie portion in the Webroot community forum earlier today(I am a community guide there)about the availability of this new update,along with a changelog.I have tried to turn a great many people on to the product as I believe in it.It's amazing how many people out there aren't satisfied with their adblockers,but are not yet aware of Adguard.I will continue to promote and endorse the product wherever I frequent.It's fantastic.
 

Boo Berry

Moderator + Beta Tester
Moderator
Yeah, I don't have Adguard on KIS' exceptions list and it runs pretty well. :D Got a link to that topic you posted?
 

avatar

Administrator
Staff member
Administrator
I had previously found that KIS didn't seem to run as smoothly with those active.
We've fixed incompatibility with KIS 2014 in Adguard 5.9.

But they are testing path F now (http://forum.kaspersky.com/index.php?showtopic=290233)
and we heard that incompatibility is back:(.

Anyway, we plan to implement a patch for Adguard 5.9 next month.
If KIS incompatibility is back - we'll fix it.

---------- Post added at 12:57 PM ---------- Previous post was at 12:16 PM ----------

Yeah, it's something that should go into the FAQ article at some point. With the default TDI driver, Adguard can't filter Enhanced Protected Mode or the Modern UI version of Internet Explorer where-as the WFP driver can.
I hope one day we'll use WFP driver only.

WFP is rather new technology, so we all (I mean not us only, but all developers who use it) need time to step on all rakes:).
 

Boo Berry

Moderator + Beta Tester
Moderator
WFP is rather new technology, so we all (I mean not us only, but all developers who use it) need time to step on all rakes:).


Incompatibility again in Patch F, eh? I might have to test that patch and see.
 

avatar

Administrator
Staff member
Administrator
Incompatibility again in Patch F, eh? I might have to test that patch and see.
Heh, I've just remembered a funny thing. Kaspersky Lab was the first company I've had a real job interview:).
It was 2006 if i remember it right, fourth year of my study in the university.

Didn't get this job:).
 

Boo Berry

Moderator + Beta Tester
Moderator
Reading the release notes for Patch F, it looks like it's aimed towards Windows 8.1 Update 1. In that case, maybe I should update to Patch F and test?
 

Boo Berry

Moderator + Beta Tester
Moderator
Just did, started repeating my Google domain tests where it'd fail before on 8.1 with KIS2014... not seeing any issues, actually. Is there any particular site(s) where this incompatibility is said to show?
 

avatar

Administrator
Staff member
Administrator
Just did, started repeating my Google domain tests where it'd fail before on 8.1 with KIS2014... not seeing any issues, actually. Is there any particular site(s) where this incompatibility is said to show?
We've heard about vk.com (images could not be fully loaded).
 

Boo Berry

Moderator + Beta Tester
Moderator
Don't think I can create an account there, but the pre-login page loads up fine, hmmmm.

EDIT: I found some links to people's profiles/pages on there, and I tested 20 pages... images load up fine for me. Tested in Chrome, Firefox, Internet Explorer and Maxthon and all images load fine.

---------- Post added at 12:57 PM ---------- Previous post was at 12:44 PM ----------

Can you get a specific non-working link from the user who reported this (along with the browser used where it fails)? I'd like to test this further. :)
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
Can you get a specific non-working link from the user who reported this (along with the browser used where it fails)? I'd like to test this further. :)
Asked him for the link. As I know he used Firefox.
 

Boo Berry

Moderator + Beta Tester
Moderator
Alright, I'll use Firefox for the conclusion of the testing but I still haven't noticed anything as of yet. :) Hopefully it was 'fixed' in Windows 8.1 Update 1. :D
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
Alright, I'll use Firefox for the conclusion of the testing but I still haven't noticed anything as of yet. :) Hopefully it was 'fixed' in Windows 8.1 Update 1. :D
Or maybe it's not Kaspersky, but something else on his machine.

Anyway thank you for testing it. It's good to know we have not got compatibility issues back:).
 

Ozymandias

New Member
I'm currently using Chrome, ZenMate and the Ad Guard extension with no problems.

I thought I'd give 5.9 a go (disabling the Ad Guard extension) however pages will not load when ZenMate is active - turning off ZenMate allows pages to load.

Is this a limitation or is there a work around?
 
Top