AdGuard 7.1.2817 - Live Functions Losing Connection

Discussion in 'Technical Support (AdGuard for Windows)' started by actually, Jun 28, 2019.

  1. actually

    actually New Member

    Joined:
    Jun 3, 2019
    Messages:
    9
    Hello,

    Live functions of websites are losing connection when a filter is updated or when AG is disabled/enabled. When a filter is checked for an update, if there is no available update, then this problem does not occur.

    Twitch chat, sometimes Twitch live stream, and HTML5 multiplayer games are affected by this. Perhaps other live services; customer support, IRC, YouTube Live.

    You can reproduce this by going to agar.live, selecting play so you are in the game, then while in the game disable AG protection and then enable, and you will lose connection with the game. The same happens if a filter is updated.


    Windows 7 64
    Firefox 67.0.4
    AdGuard 7.1.2817 - (CL 1.4.32) - Release
     
  2. Chinaski

    Chinaski Support Marine Staff Member Administrator Moderator

    Joined:
    Apr 15, 2019
    Messages:
    568
    @actually
    Hello there!
    When you disable or enable protection, traffic starts to redirected through AdGuard, so there is a short-term loss of connection.
    As for filters, now there is a certain problem with their updates and loss of connection.
    In the coming days, there is a fix for this problem.
    Turn on the update channel Nightly and follow the news :)
     
  3. actually

    actually New Member

    Joined:
    Jun 3, 2019
    Messages:
    9
    Ah that is good to hear, thanks
     
  4. Rock

    Rock New Member

    Joined:
    Feb 16, 2018
    Messages:
    2
    The fix should be to Release build ASAP.
     
  5. actually

    actually New Member

    Joined:
    Jun 3, 2019
    Messages:
    9
    Hi @Rock

    Until the update arrives, perhaps change the Filter update check period to a longer period than what you currently have selected. This way the amount of disconnections are reduced.