[*] Adguard and Firefox.

Discussion in 'Missed Ads' started by Bruce Ramsay, Mar 12, 2019.

  1. Bruce Ramsay

    Bruce Ramsay New Member

    Joined:
    Mar 9, 2019
    Messages:
    20
    I added The Washington Post to my exclusions so I can't do a "report the website" as Adguard is not filtering it. It seems to be working OK but now I get this message from Firefox which I don't know what it is about. This leads me to believe it is a Firefox issue. 2019-03-13_205910.jpg
     
  2. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    24,900
  3. Bruce Ramsay

    Bruce Ramsay New Member

    Joined:
    Mar 9, 2019
    Messages:
    20
  4. Bruce Ramsay

    Bruce Ramsay New Member

    Joined:
    Mar 9, 2019
    Messages:
    20
    Here's the latest...............When I disabled the pop-up blocker it seems to be working OK. See attachment. I hope this is it.
     

    Attached Files:

  5. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    24,900
    @Bruce Ramsay Hmm. Interesting. Please write AdGuard and Firefox versions(full version numbers)?

    @zebrum could you please check it?
     
  6. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    24,900
    It is not for visitors. It is for site developers:)
     
  7. Bruce Ramsay

    Bruce Ramsay New Member

    Joined:
    Mar 9, 2019
    Messages:
    20
     

    Attached Files:

  8. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    24,900
    Finally:) Reproduced. It seems it is a bug.
    Please add this string to PopupBlocker in AdGuard settings(as line 66)
    Code:
    // @exclude *://*.washingtonpost.com/*
    
    Where it is:
    upload_2019-3-14_23-4-10.png
     
  9. Bruce Ramsay

    Bruce Ramsay New Member

    Joined:
    Mar 9, 2019
    Messages:
    20
    Not sure where to add it. As soon as I enable popup blocker.....no comment sections.
     
  10. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    24,900
  11. Bruce Ramsay

    Bruce Ramsay New Member

    Joined:
    Mar 9, 2019
    Messages:
    20
  12. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    24,900
    Hi. Please open AdGuard settings -> Extensions. Disable enabled Popup Blocker and enable another "Popup Blocker Beta", and check for updates.
     
  13. Bruce Ramsay

    Bruce Ramsay New Member

    Joined:
    Mar 9, 2019
    Messages:
    20
    Where is the "Popup Blocker Beta"?
     
  14. Bruce Ramsay

    Bruce Ramsay New Member

    Joined:
    Mar 9, 2019
    Messages:
    20
    This is all I see.
     

    Attached Files:

  15. Bruce Ramsay

    Bruce Ramsay New Member

    Joined:
    Mar 9, 2019
    Messages:
    20
    So....have we given up on fixing this bug??
     
  16. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,937
    It should be visible on beta version of AdGuard for Windows, you can change to beta update channel to get it.
     
  17. worldsdream

    worldsdream Beta Tester

    Joined:
    Mar 30, 2016
    Messages:
    1,491
    I can confirm what @Bruce Ramsay is saying. I am on the beta (fresh install on a Windows machine). I only see "Adguard Popup Blocker".
     
  18. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,937
  19. worldsdream

    worldsdream Beta Tester

    Joined:
    Mar 30, 2016
    Messages:
    1,491
    Yup, that one is the beta. The final release should be the same now as the beta. Same build 2.5.13.
     
  20. Bruce Ramsay

    Bruce Ramsay New Member

    Joined:
    Mar 9, 2019
    Messages:
    20
    Thanks for the update. It's too bad that it felt like pulling teeth to get answers.