AdGuard assistant disappears and AdGuard stops filtering

steve1209

Beta Tester
Hi All,

Using AdGuard nightly 7.0.2261.5797
Win 10 home version 1903 OS build 18342.8
Chrome Version 72.0.3626.121 (Official Build) (64-bit)

I open my homepage in chrome which is my Gmail inbox, I see the assistant and AdGuard is filtering.
using that same tab, I now switch to my bank and as expected no assistant or AdGuard. I then use that same tab, go back to gmail inbox (homepage), then no AdGuard assistant and AdGuard is not filtering.

I can give Team viewer access, if any of the AdGuard team would like to look into it for me!!
 

Boo Berry

Moderator + Beta Tester
Moderator
It's the service worker issue that's known about. Happens with Outlook too and the only way to workaround or "suppress" it for the time being is blocking the service worker.

Code:
||mail.google.com/mail/u/0/sw.js$empty,important

Might be a good idea to clear the browser cache and cookies or you can press F12 to open the console/developer tools in Chrome, go to Application then Service Workers then Unregister it. You can also go to Clear storage and dump it and everything else and refresh.
 

Boo Berry

Moderator + Beta Tester
Moderator
For completeness sake for those users who might encounter this issue on Outlook, here's the rule to block the service worker there too. I've also edited the Gmail rule above to add important at the end. ;)

Code:
||outlook.live.com/mail/sw.js$empty,important

And here's the issue on GitHub if you want to follow progress: https://github.com/AdguardTeam/CoreLibs/issues/597
 

steve1209

Beta Tester
@Boo Berry,

Looking at GitHub, it appears the issue is closed??? It obviously seems to still be a problem, one I never had in version 6 AdGuard only started with V7

EDIT sorry see its still open...
 
Last edited:

Boo Berry

Moderator + Beta Tester
Moderator
It's probably related to CoreLibs, as I never had the issue either in the pre-CL versions of AG for Windows or AG for Mac.
 
Top