AdGuard Assistant not showing up on all sites

Discussion in 'Technical Support (AdGuard for Windows)' started by steve1209, Nov 24, 2014.

  1. steve1209

    steve1209 Beta Tester

    Joined:
    Mar 31, 2014
    Messages:
    442
    Last edited by a moderator: Nov 24, 2014
  2. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,214
    I wouldn't have both Assistants enabled. In this case, I'd disable the stable version and use the beta version.

    You're right though, Assistant doesn't show up on that site.
     
  3. steve1209

    steve1209 Beta Tester

    Joined:
    Mar 31, 2014
    Messages:
    442
  4. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,214
    Yeah, like I said I can confirm the Assistant doesn't show up there. Something for avatar to make note of. ;)
     
  5. mysteriously

    mysteriously Beta Tester & Translator

    Joined:
    May 4, 2014
    Messages:
    508
    Yep, I also can confirm this, checked all browsers from signature
     
  6. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,896
    Got it, thank you for the bug report!
     
  7. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,896
    I've checked it. The problem is that this site has invalid HTML code (there is no <body> tag).

    In such cases we do not inject Assistant code.
     
  8. Dolfi

    Dolfi Banned

    Joined:
    Nov 21, 2014
    Messages:
    218
    Couldn't AG just insert/append AGA code? The user can add the site to exceptions if it didn't work out (== made things worse)?
     
  9. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,896
    For this particular site it will be ok.
    But what if we inject our code to something like ajax response? Could be dangerous.
     
  10. steve1209

    steve1209 Beta Tester

    Joined:
    Mar 31, 2014
    Messages:
    442
    Hi Avatar,

    Thanks for looking into this. It was strange, the new version just came out and my 1st Google search found the problem, it was strange...
     
  11. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,896
    Anyway thank you! We should think more about injecting Assistant code on these invalid pages.