Adguard blocking captive network

Jecht_Sin

New Member
At work I connect to WiFi via a Captive Network. That means I do the following:

- The WiFi at work shows as open
- I connect my MBP to it
- A popup window shows, which asks for the credentials
- I authenticate
- After that I have connection to the Internet

The problem is that when Adguard is enabled, the popup window shows but the content is empty. I tried to add the following rules:

@@||serneth2.site.org$document
@@|site.org$document

where the first should be the full FQDN of the proxy server doing the authentication (site.org is fake), but they do not work. I have got the syntax from other sites I whitelisted.

Right now I have tried also adding

@@||serneth2.site.org^$document
@@||site.org^$document

as I understood it is the correct syntax from the Adguard FAQ, but I'll have to wait for Monday to test them. And I doubt they will work anyway.

First of all, which one is the correct syntax? I don't mind to open the whole "site.org", since it only connects to the Intranet (no ads). Could it be some interferences from Adguard with the macOS Captive Networks?

Thanks.
 

Jecht_Sin

New Member
Is anyone from Adguard reading these forums? I suspect this would be a common issue with Captive Networks.
 
Top