AdGuard blocking Windows Security "Select Certificate" window

hyperexpert

New Member
I had to uninstall Adguard on my computer because it is blocking Windows Security "Select Certificate" window on two of my PCs.

Basically, we have MFA setup at work with either smart card certs or locally installed certs. When Adguard is installed and I try to log on, it completely blocks the Windows Security window like shown in the screenshot below. Even disabling Adguard doesn't help. The only way to get it to work is to completely uninstall Adguard. Is there a fix or a workaround for this?

Browsers: Edge, Chrome, and Firefox
OS: Windows 10 64-Bit
Adguard Version: 6.1.258.1302

 

avatar

Administrator
Staff member
Administrator
Hi!

So if I get it right, you use certificate or smart card authentication somewhere and with Adguard installed it does not work?

The only way to get it to work is to completely uninstall Adguard
Let's narrow it down to either Adguard presence or to Adguard filtering.

1. Does it help to stop Adguard windows service? In this case AG does nothing to the traffic.
2. Does it help to turn HTTPS filtering off in Adguard settings (settings -> general -> filter https traffic)?
3. Does it help to add the domain name to the "HTTPS exclusions"?
 

hyperexpert

New Member
Hi!

So if I get it right, you use certificate or smart card authentication somewhere and with Adguard installed it does not work?
Correct! I will try this again on Monday and report back. Don't have access to my work PC over the weekend.
 

hyperexpert

New Member
So I tried all of these 3 suggestions and they all help bring the Windows Security window back! Obviously, I don't want to do the first 2, but adding the domain to HTTPS exclusions fixed it. I need to do some more testing in our enterprise environment.

Thank you so much for the help. At least now I can have Adguard installed again.
 

avatar

Administrator
Staff member
Administrator
Correct! I will try this again on Monday and report back. Don't have access to my work PC over the weekend.
Great, thank you for checking it!

I don't yet understand why did it happen. In theory AG should properly detect authentication request and stop filtering for that domain. I wonder why it didn't work properly in your case.
 
Top