AdGuard breaks Amazon Video (UK) on MacOS (Safari/Browser/Chrome)

Discussion in 'Technical Support (AdGuard for Mac)' started by janguv, Aug 14, 2017.

  1. janguv

    janguv New Member

    Joined:
    Aug 14, 2017
    Messages:
    5
    Hi,

    OS: MacOS 10.12.6
    Browser: all in title, focussing on Safari 10.1.2
    Problem: Amazon Video (.co.uk) won't play with ad blocking enabled.

    In detail: on clicking a thumbnail or Resume link, the Amazon video player loads, plays a trailer, but when it's finished will output a 7031 error code. Works without Adguard ad blocker enabled.

    Specific conditions: it occurs when clicking on any Amazon Prime Video links, such as:
    - https://www.amazon.co.uk/gp/video/detail/[video link]
    - https://www.amazon.co.uk/gp/product/[video link]

    Workaround: so far, adding (sans quotes) "amazon.co.uk/gp/" to the whitelist works. Less than ideal.

    Extra information: It's pretty strange because everything was working fine, and then all of a sudden stopped. I haven't updated Adguard, the OS, or the browser lately. I have a hunch that the issue is related to the trailers which Amazon airs before videos. They don't always show them, but often do. When the ad blocker is disabled (or the whitelist edited), then the trailers are often skipped. With it enabled, the trailers always show (and then the problem occurs).

    Let me know if you need more detail.
     
  2. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    24,900
    Hi
    The links are not working
    [​IMG]
    Please provide working links and filters list.
     
  3. janguv

    janguv New Member

    Joined:
    Aug 14, 2017
    Messages:
    5
    Well that's why I indicated that they were incomplete – the square bracket phrase shows there would be a specific video link after. ANY link which begins with the URLs I posted was setting off the problem.

    E.g., this would have done so: https://www.amazon.co.uk/gp/video/detail/B06VW8Y81Y/ (click to watch trailer)

    But today I'm testing by removing the whitelist filter I provided, and it's back to normal again. Honestly, I'm flumoxxed.

    This is the only explanation I can think of:

    I was using a VPN connected to an American server and accidentally loaded up an Amazon video. I realised and quickly disconnected from that server, and went back to using my home connection. From that point onwards, the problem wouldn't go away, on my usual connection, even after:

    - rebooting
    - using different browsers
    - clearing caches
    - updating silverlight
    - disabling browser add-ons

    None of that helped. The only thing that worked was turning off Adguard's ad blocker, and it worked every time, across all browsers, and after restarting.

    So: could it be due to a possible automated filter change from when I used the VPN to connect to an American server? Did that trigger some change in Adguard?
     
  4. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    24,900
  5. janguv

    janguv New Member

    Joined:
    Aug 14, 2017
    Messages:
    5
    Since the issue has now resolved on its own, I think I should leave it for now.

    If it happens again, I'll post according to the section rules, with screenshots etc.

    In answer to your question – no, I only mention the VPN issue because I wonder if Adguard automatically selected a new filter when I was on the VPN previously. Otherwise, the issue is completely independent of the VPN, and only concerns Adguard and Amazon.

    Cheers