Adguard breaks DNSCrypt

Discussion in 'Technical Support (AdGuard for Mac)' started by bigdata, Jan 27, 2018.

Tags:
  1. bigdata

    bigdata New Member

    Joined:
    Jul 9, 2017
    Messages:
    10
    I’m no longer able to use DNSCrypt for Mac after I installed Adguard. Specifically, DNSCrypted can no longer change the system DNS most of the time, it’s back to the default DNS from the router. Even when it successfully changes the system DNS, I get an error message saying the domain can’t be reached even when the DNACrypt application says it’s connected to a resolver.

    Any idea how to fix this? Thanks!
     
  2. zebrum

    zebrum Administrator Staff Member Administrator

    Joined:
    Nov 21, 2016
    Messages:
    515
    @bigdata hi! Does it happen with specific DNS server or with any?
     
  3. bigdata

    bigdata New Member

    Joined:
    Jul 9, 2017
    Messages:
    10
    It breaks the whole application.
     
  4. zebrum

    zebrum Administrator Staff Member Administrator

    Joined:
    Nov 21, 2016
    Messages:
    515
    AdGuard 1.5.3?

    The problem starts right after you installed AdGuard? What happens if AdGuard app is running but protection is disabled? And what other applications do you have? (e.g. antivirus programs)
     
  5. bigdata

    bigdata New Member

    Joined:
    Jul 9, 2017
    Messages:
    10
    Yes, the latest AdGuard. Disabling protection doesn't make it work either. I've had this issue on two Macs now.
     
  6. zebrum

    zebrum Administrator Staff Member Administrator

    Joined:
    Nov 21, 2016
    Messages:
    515
    Are those two Macs connected to the same wi-fi network?

    Let's reinstall AdGuard! If it won't help I'll ask you to collect logs.

    Can't reproduce the issue, both apps work perfectly well on my side.
     
  7. bigdata

    bigdata New Member

    Joined:
    Jul 9, 2017
    Messages:
    10
    Yes they are connected to the same Wi-Fi but I also tried it at work. Still didn't work.
     
  8. bigdata

    bigdata New Member

    Joined:
    Jul 9, 2017
    Messages:
    10
    Apologies. It's a coincidence that the DNS server I've been using went down at the same time I installed AdGuard. It's working now.