AdGuard can't start protection in Network Extension filtering mode

donmed777

New Member
Hi
I'm using AdGuard 2.5.1.928 with the latest version of macos Big Sur
The app only works for me when I change the feltering mode from network extension to automatic proxy
But this caused me a problem with poor internet traffic and high ping rate

Note: when I activate network extension, I get the following error message:
adguard won't work correctly
some adguard services were not started correctly. Please contact the support team.

Is there a solution to my problem?
Regards
 

Chinaski

Quality Assurance
Staff member
Administrator
Moderator
Hello there!

To troubleshoot this issue, we need to get the app logs.

Here's what we need you to do:

1. Menu -> Gear -> Advanced -> Logging level -> Debug;
2. Reproduce the issue (and remember the exact time when it happened);
3. Menu -> Advanced -> Export Logs and System Info...;
4. Send the archive to apple@adguard.com and share a link to this topic on the forum.



After you send the logs, try to just reinstall the application.
Delete it and download it from the link provided.
 

superandrew

New Member
I am having the exact same problem. I tried uninstalling, resetting, I tried enabling debug to send the logs to the support, but since this happens on startup, the debug setting is not kept by adguard on any restart. No solution, despite installing latest nightly every day. Starting to consider using a different blocker for a while
 

superandrew

New Member
My problems with this are the following:
1. I use a proxy to debug the applications I develop, I guess this is conflicting with the automatic proxy configuration, but I will try just to be sure
2. once I start adguard manually, it seems to work properly, so this is only - albeit extremely annoying - just a startup warning. So should I swich to a configuration that is less supported or will (possibly, if not possibly) cause issue with my work?

But just to be sure: noone is having issues with adguard and bigsur? if it is so, then it must be some other software which is conflicting on my machine.
 

Boo Berry

Moderator + Beta Tester
Moderator
AdGuard for Mac is running perfectly on my Big Sur install, no issues whatsoever.
 

oldsarge

Member
I am not having any problems with AG and Big Sur. Besides Big Sur, AG and MWB are the only programs on my iMac. When I had a windows machine many years ago, I did have problems although I was not using AG or MWB. My only solution was to uninstall everything except windows and then, reinstall one program at a time, restart the computer, and continue doing this until I found the offending application. Very tedious but it worked. And then I would get rid of the bad program and find an alternate that did work. But on the iMac, everything just works.
 

Boo Berry

Moderator + Beta Tester
Moderator
It's very possible it could be. There's been incompatibility issues between Little Snitch and AdGuard for Mac over the years.
 

superandrew

New Member
unfortunately, it is not the problem that generates the error. I tried uninstalling it and nothing changes. After a complete cleanup and reset of AdGuard, I came up with a very few logs, and I noticed this error:
Code:
2020/11/22 20:47:58:599  (AANProxyServerHandler) Reload configuration started.
2020/11/22 20:47:58:600  (AANProxyServerHandler) CA Certificate/pkey loaded successful.
2020/11/22 20:47:58:602  (AANProxyServerHandler) Stealth config is empty.
2020/11/22 20:47:58:602  (AANProxyServerHandler) Filtering config created.
2020/11/22 20:47:58:602  (AANProxyServerHandler) Config created.
2020/11/22 20:47:58:617  ANServiceManager    Start: Service type is 0
2020/11/22 20:47:58:637  ANServiceManager    Start: +++Started VPN service
2020/11/22 20:47:58:647  ANServiceManager    Start: ++++Received RPC endpoint from VPN service
2020/11/22 20:47:58:647  ANServiceManager    Start: +++Failed to decode RPC endpoint: Error Domain=NSCocoaErrorDomain Code=4864 "*** -[NSKeyedUnarchiver _initForReadingFromData:error:throwLegacyExceptions:]: data is NULL" UserInfo={NSDebugDescription=*** -[NSKeyedUnarchiver _initForReadingFromData:error:throwLegacyExceptions:]: data is NULL}
2020/11/22 20:47:58:647  (AANProxyServerHandler[0x60000244c000] startProxy) Can't start CoreLibs service: Error Domain=NSCocoaErrorDomain Code=4864 "*** -[NSKeyedUnarchiver _initForReadingFromData:error:throwLegacyExceptions:]: data is NULL" UserInfo={NSDebugDescription=*** -[NSKeyedUnarchiver _initForReadingFromData:error:throwLegacyExceptions:]: data is NULL}
Is this something that some of you have seen in his working version? The file is

com.adguard.mac.adguard-setapp 2020-11-22--19-44-57-991

Unfortunately, the support requested me to enable the debug level on logs, but even if I do, because this happens only on restart (after that I can start adguard manually and it works) I have no clue on what to do.
 

jstaubr

New Member
I was having the same issue and it lead to the adguard team connecting to my computer to investigate the issue. Unfortunately they couldn't think of anything that was wrong at that time but I hope it gave them some thoughts on how to try and enable the system extension in the future builds.
In the log there is something about the extension being forbidden by the syspolicy.
Error occurred when request processing: OSSystemExtensionErrorDomain, 10 (forbiddenBySystemPolicy)

If you open your console.app and search for "extension" you might see the same error.


edit: I managed to make it work (at least in my case).
I have an MDM managed mac and I'm also that MDM server administrator. I just created a new profile that specificaly allowed extension from team TC3Q7MAJXF and bundle id com.adguard.mac.adguard.network-extension. (I tried to just allow team TC3Q7MAJXF and type of extension "network" but that failed the same way for some reason)
Before you ask - I have the general profile set to allow user approvals of system extensions so this should not be needed (Parallels and Eset Endpoint both poped up with the extension allow dialog)
 
Last edited:

superandrew

New Member
In my case I was able to solve the issue by:

1. uninstalling little snitch (not sure if it was the culprit)
2. cleaning every leftover of vpn profiles created by adguard and/or little snitch in Preferences/Network.

I’ll let you know if this is finally solved or not, even after reinstalling little snitch
 
Top