Adguard causing phone reboot on Android 10

OMGJJ

New Member
Many Adguard users including me have reported this on the Google Pixel subreddit. On a Pixel phone with adguard active you will occasionally get full system reboots when opening an app. This is a serious issue and turning off Adguard completely fixes it.
 

Blaz

Moderator & Translator
Staff member
Moderator
Are you on latest AdGuard nightly? So far I did not experience the issue on latest nightly in my Pixel 3 XL.
 

PaulQ

New Member
I can corroborate what s/he said above. I am experiencing almost once daily spontaneous reboots since Android 10 (past roughly 2 weeks). I only started narrowing it down to AdGuage today through some discussion on a forum which also pointed me to those Reddit threads.

I am not on nightlies. I guess I could go do that. I don't like being on a beta track but if it will take care of the problem temporarily until the release version is ready, I could do it.
 

Paul W

New Member
I am also having the same issue. Since upgrading to Android 10 on my Pixel 2 XL, my phone has been restarting about once a day. Sometimes it's while the phone is in use, sometimes it's happening while the phone is in my pocket or during the middle of the night. I can't confirm that it's AdGuard just yet, but since other users are claiming this I'm going to disable the app and see if that fixes the problem. I'm using the current release version of adguard.
 

PaulQ

New Member
Hello there!
Pretty curious problem.
It would be nice if you could catch the problem and send logs. (Also, please collect Logcat).
Are you saying that the AdGuard developers have not acknowledged this as an "official" issue at this time? It may not be AdGuard but what is the status of this from the developer's perspective right now?
 

Paul W

New Member
Just a clarification... I said I was using the release version, but I was actually on the beta version.
 

tox1c90

Beta Tester
I have the same issue on my Pixel 3a on Android 10 using the latest release version of Adguard. I'm not using any DNS filtering (DNS module is disabled in Adguard) so it's not the private DNS bug which was discussed multiple times at Reddit and Google.

It's completely random, not even necessarily every day. Usually it happens for me when returning back to the home screen or opening an app. The screen freezes for a short amount of time and then the phone does a soft reset.

I disabled Adguard and haven't experienced one single reboot after that. What I could still try is to disable filtering of all apps, so it will only filter the browser, and check if I still get random restarts... Only OS-related stuff which is blocked according to filtering logs are two Google analytics requests by "Android OS" like every few hours or when you switch network. I find it a bit hard to believe that this could cause Android to crash completely.

Or could it just be an Android 10 bug when connected to a VPN for an extended period of time? I could also try keeping a connection to my home routers VPN for 24/7 and see if it crashes at some point.

Are you on latest AdGuard nightly? So far I did not experience the issue on latest nightly in my Pixel 3 XL.
Does this mean you always used Adguard nightly and never had this issue, or does it mean you had the issue in the beginning, then updated to nightly and the problem was gone? The latter case would be more of an indication that the problem is fixed in nightly builds.
 
Last edited:

Paul W

New Member
Just an update...I disabled AdGuard for 2 days and did not have a single reboot. Previous to this, my phone was rebooting at least once per day on Android 10.

I was using the beta release before. I'm going to switch to the nightly build and see what happens. I enabled the advanced logging just in case.
 

Blaz

Moderator & Translator
Staff member
Moderator
I always used nightly builds and never experienced it so far.
 

tox1c90

Beta Tester
Tried disabling "filtering of all apps" and didn't get any reboot since then.
I updated to nightly now, put it back to default and will check if it's fixed.
 

PaulQ

New Member
Tried disabling "filtering of all apps" and didn't get any reboot since then.
I updated to nightly now, put it back to default and will check if it's fixed.
How long have you gone without a reboot? It seems that if you can get to two days, you are in the clear.

I sent logs in a couple days ago.
 

PaulQ

New Member
Tried disabling "filtering of all apps" and didn't get any reboot since then.
I updated to nightly now, put it back to default and will check if it's fixed.
Are you referring to the setting in the "content blocking" settings... Block ads in all apps?
 

PaulQ

New Member
I turned off "Block Ads in All Apps" (SETTINGS > CONTENT BLOCKING...)

My phone did not reboot for two days. I had to turn it off to install a new screen protector today so I didn't go any longer. I'll leave this setting off and see if it reboots. The issue might be related to this setting. I'll post here if my phone does not reboot in 3 days.
 
Top