Adguard combining chrome extension ZenMate seems doesn't block ads

Discussion in 'Technical Support (Adguard for Windows)' started by november_ra1n, Mar 26, 2014.

  1. november_ra1n

    november_ra1n New Member

    Joined:
    Mar 24, 2014
    Messages:
    13
  2. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,258
    That's right -- Adguard's HTTPS filtration cannot work along with ZenMate.

    Workaround for now:
    1. Disable HTTPS filtration in Adguard
    2. Install Adguard's chrome extension

    HTTPS pages will be filtered by extension.
    HTTP -- will be filtered by Adguard for Windows.
     
  3. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,618
    What's the technical reason for this incompatibility? I'm curious.
     
  4. Zero3K

    Zero3K New Member

    Joined:
    Mar 22, 2014
    Messages:
    14
    I think its because its using a proxy to do its work, which AdGuard can't filter.
     
  5. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,258
    Devs did not understand it yet. I think this is a bug on our side, but don't have time to research it properly.
     
  6. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,258
    Ok, i've found the problem.

    ZenMate uses "double-SSL" for https web sites.

    What ZenMate do:
    1. Opens SSL tunnel to their proxy
    2. Sends CONNECT request and builds a tunnel to the web site
    3. Transfers original traffic (crypted, it is https after all) through this tunnel

    Now we know what to do so we will fix this in the next patch.
     
  7. Venky

    Venky Beta Tester

    Joined:
    Jul 19, 2013
    Messages:
    146
    Hi, can you also check if this is the case with Tor Browser which has https everywhere enabled by default. https websites do not seem to be working in tor. http website seems to work fine.
     
  8. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,618
    Last edited by a moderator: Mar 30, 2014
  9. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,258
    Ok, we'll check it, thank you for reporting it.
     
  10. november_ra1n

    november_ra1n New Member

    Joined:
    Mar 24, 2014
    Messages:
    13
    Thanks to bringing this issue, i had same trouble with Tor Browser i was blaming browser itself however as avatar confirm and will check we will have to wait. Also i just cant wait if he can manage to cut high CPU usage down with version 6.
     
  11. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    2,618
    Hi there, the incompatibility with ZenMate has been addressed in the 5.10 release that's currently in the beta testing phase. :) Regarding TOR Browser, I personally have nothing to report yet. At some point I'll need to download it and see if all it requires is manually importing the certificate as I think that's the root cause of that issue. However if this issue is persisting, please create a new topic regarding this in this section of the forums so it can be properly tracked.