Adguard Firefox master password

Discussion in 'Technical Support (AdGuard for Mac)' started by Kuba, Jul 2, 2019.

  1. Kuba

    Kuba New Member

    Joined:
    Jul 2, 2019
    Messages:
    3
    Hi,

    AdGuard used to ask for Firefox master password every time I rebooted.
    Since the new version upgrade it happens every time I unlock my mac.

    I have multiple firefox profiles which I delete and recreate for browser developement testing so I cannot just set the master password or import the certificate.

    Is there a way to disable this behavior? I tried to disable and subsequently delete Firefox from adguard app filtering but to no avail... Please advise :(

    Thank you!
    K.
     
  2. Chinaski

    Chinaski Support Marine Staff Member Administrator Moderator

    Joined:
    Apr 15, 2019
    Messages:
    600
    @Kuba
    Good day!
    Please update to Nightly version and try to reproduce your issue.
    It's not your task has been created on GitHub?
     
  3. Kuba

    Kuba New Member

    Joined:
    Jul 2, 2019
    Messages:
    3
    @Chinaski
    Good day to you too!
    I've installed the latest nightly and I can still reproduce the issue.
    The problem on github seems to be related but not the same. Currently I have two firefox profiles. The default one doesn't seem to be affected.
    Only the second one always pops up in the box when adguard asks for master password and to install root certificate. I tried to put the certificate there by hand but adguard seems to not detect it.

    I think it should stop bothering with firefox if I remove the app from app filtering settings...

    Thank you for your time :)
     
  4. Kuba

    Kuba New Member

    Joined:
    Jul 2, 2019
    Messages:
    3
    You can probably ignore this if you can. I tried to create a new profile from scratch and it doesn't seem affected by this and works as it should.
    It's probably just the one debug profile I use which I drag between multiple OS that is a little bit corrupt. I can't even create a master password for it.

    K.