AdGuard for Android 1.0 beta version

pbmcmlxxi

Beta Tester
Hi, my experience so far..

Installed AdGuard on N8000 – Latest Omni Rom, and found the following:

Install went ok. Initially went to activate it and it failed – noticed then protection was off, after turning on protection and it creating a vpn went to activate and it activated ok. When clicking check for update with protection enabled and also disabled it just keeps spinning to check. When I turned off the wi-fi it then crashed AdGuard. I then turned wi-fi back on and loaded AdGuard, it then got stuck on loading protection, and also seems to have lost the premium key and reverted to non-premium features.
Appears to filter ok in Chrome beta, usual type ads in FB still appear.
 

avatar

Administrator
Staff member
Administrator
Hi, my experience so far..

Installed AdGuard on N8000 – Latest Omni Rom, and found the following:

Install went ok. Initially went to activate it and it failed – noticed then protection was off, after turning on protection and it creating a vpn went to activate and it activated ok. When clicking check for update with protection enabled and also disabled it just keeps spinning to check. When I turned off the wi-fi it then crashed AdGuard. I then turned wi-fi back on and loaded AdGuard, it then got stuck on loading protection, and also seems to have lost the premium key and reverted to non-premium features.
Appears to filter ok in Chrome beta, usual type ads in FB still appear.
Could you please send a message from the app to our support?
Need your log files.
 

pbmcmlxxi

Beta Tester
Could you please send a message from the app to our support?
Need your log files.
Tried via app with AdGuard active and it failed. Disabled AdGuard and tried sending it failed - error sending feedback.
Restarted tablet and tried sending report it just seems to get stuck on please wait.

Is there a way to get the files required and email them?

Have now managed to send. Will also send a PM.
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
Besides the random crashes things seem to be working okay. I can confirm both m.ky3.com and m.tmz.com loads slowly and lags down Chrome without Adguard enabled. Personally, I can't wait to try the Local HTTP Proxy mode, since I'm rooted and that should work pretty decently. I know the app has a feature request feedback form, but I'll post these here since I have a helpful link to include;

1) Add Adguard to the notification area and notification drawer while running. The API guide for this is found here.
2) Allow import/export of .txt user filters. I have my exported user filters from Adguard for Windows on my device already that I'd like to import.
 

avatar

Administrator
Staff member
Administrator
1) Add Adguard to the notification area and notification drawer while running. The API guide for this is found here.
We'll do it for proxy mode. VPN mode already has constant notification and you can use it to open to Adguard.

2) Allow import/export of .txt user filters. I have my exported user filters from Adguard for Windows on my device already that I'd like to import.
Good idea, thank you!
 

avatar

Administrator
Staff member
Administrator
Tried that before it doesn't help.
Good, looks like a bug. Thank you!

---------- Post added at 09:18 PM ---------- Previous post was at 09:17 PM ----------

I mean it's good that we've found the bug:)
 

Boo Berry

Moderator + Beta Tester
Moderator
Probably a good idea to turn off application filtering until it's looked into/resolved.
 

fabjazz

Beta Tester
Hi !

I am using adguard on one plus one cm11s kitkat 4.4.4, there is a problem to send image with Whatsapp when adguard is enabled.. when I switch off, it is ok and image is sending.
 
Last edited by a moderator:

hanschke

Beta Tester & Translator
@Boo Berry

thats right but I want to tell it ;) Can we have a workaround for the disabling when you want to use airdroid? If I dont disable it aidroid cannot see the phone. Maybe a message can come that if you want to use airdroid it dont work behind a vpn or I have set something wrong?
 

pbmcmlxxi

Beta Tester
will there be plans to implement within the application filtering, a user option to select which apps are filtered/not filtered? As with @hanschke I had to disable app filtering to access airdriod, an option to select which apps would be nice though I guess not essential. :)
 

Boo Berry

Moderator + Beta Tester
Moderator
will there be plans to implement within the application filtering, a user option to select which apps are filtered/not filtered? As with @hanschke I had to disable app filtering to access airdriod, an option to select which apps would be nice though I guess not essential. :)
This I hope too. It'd allow to filter applications with Google ads embedded for example, so I don't have to patch them out anymore.
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
Hi !

I am using adguard on one plus one cm11s kitkat 4.4.4, there is a problem to send image with Whatsapp when adguard is enabled.. when I switch off, it is ok and image is sending.
Have you tried disabling application filtering in Adguard's settings?

Just want to be sure that the problem is in our filters and not in our VPN implementation.
 
Top