AdGuard for Maс 2.4

adgkart

Administrator
Staff member
Administrator
Moderator
Here comes AdGuard for Mac 2.4! Two betas served as cornerstones for this new version and we are glad to present it to you five months after the previous release.

The biggest thing that has changed here is the new Assistant. CoreLibs has traditionally been updated, too, which enhanced filtering quality. In other aspects, 2.4 is more of a bugfix release. We cleaned it from the recurrent problems of the previous versions, polished it up, so it works nice and smooth.

[Enhancement] The old Assistant has been replaced with a native Assistant browser extension #669, #670
AdGuard Browser Assistant is a new browser extension that simultaneously takes over the roles of the old Assistant and of the integration mode. We definitely support the functional approach, so we thought: why distribute workload between two old tools when one new extension can handle it better? Now let us tell you what AdGuard Browser Assistant is capable of.



What can you do with the help of the Assistant? Enable/disable filtering on the current webpage, manually block any element on the page, reporting the website if something goes wrong or view the filtering log. Now you have all these features without the limitations that appeared in the integration mode or in the old Assistant.



When you install AdGuard for Mac for the first time (or update it to the new version), the Safari Assistant will be installed automatically. If you use another browser, you can download the Assistant at this link. Or, you can install the Assistant for your default browser via app settings or during the onboarding process.

Changelog
  • [Fixed] Incorrect information about QUIC connections is displayed in the filtering log #532
  • [Fixed] Filtering in Microsoft Edge Beta doesn't turn off when removing the browser from filtered applications #663
  • [Fixed] AdGuard does not preserve the Whitelist #674
  • [Fixed] Fast user switching might corrupt certificate database #675
  • [Fixed] AdGuard doesn’t work in Brave Beta 1.7.64 #689
  • [Enhancement] Different build configurations for beta/release/nightly #615
  • [Enhancement] "What's new" screen now shows up after major app updates #671
  • [Other] New localizations: Croatian, Persian, Romanian, Thai #678
CoreLibs has been updated to 1.5.269
  • [Fixed] Incorrect extended CSS rule causes problems with JS rules’ work * #1147
  • [Fixed] Rules with :style() are converted incorrectly #1149
  • [Fixed] Issue with LINE extension #1280
  • [Fixed] Rules with restricted domains do not match requests without referer #1286
  • [Fixed] Stealth mode error #1290
  • [Fixed] Cosmetic rules can be used as CSS rules #1293
  • [Fixed] Basic rules with wilcard in top level domains are not working #1298
  • [Enhancement] “Proceed anyway” option doesn’t work correctly if a website is blocked by a rule with $all modifier #1267
  • [Enhancement] New rule selection algorithm for the cases when HTTPS filtering is disabled #1291
This release on GitHub.
Download this build here.
 

SilverSpur

New Member
Apparently updating to this version, TURNS OFF the blocking UNTIL you install AND ACTIVATE the browser extension.

Maybe that is said in the UNREADABLE HIPSTER DBAG GRAY TEXT in the popup box after instal?

I wouldn't know, as I don't waste time trying to read UNREADABLE HIPSTER DBAG GRAY TEXT.

UPDATE: you also have SET EVERY BROWSER (except Safari) SEPERATLEY now. ugh. (Yes, I'm sure some will think that's good, but that's not the way the app originally worked, and it's NOT pointed out as far as I can tell.).
 
Last edited:

Boo Berry

Moderator + Beta Tester
Moderator
Apparently updating to this version, TURNS OFF the blocking UNTIL you install AND ACTIVATE the browser extension.
Uhhh, that shouldn't be happening. What exactly do you mean? AG for Mac should still filter websites even without the Browser Assistant installed/enabled. Which browser(s) is this happening in? All? Or specific ones, e.g. Safari?

UPDATE: you also have SET EVERY BROWSER (except Safari) SEPERATLEY now. ugh. (Yes, I'm sure some will think that's good, but that's not the way the app originally worked, and it's NOT pointed out as far as I can tell.).
Unavoidable I'm afraid, since the Browser Assistant is a browser extension and needs to be installed from each browser's extension/addon web store. Safari is an exception... Firefox is too, until they enforce all installable extensions have to be on the Mozilla addons website (AMO). Chrome and Chromium-based browsers have that enforcement unfortunately, so there's really no way to automate the Browser Assistant install in all web browsers present. I'm sure some users wouldn't appreciate the Browser Assistant being force installed in all web browsers either. ;)
 

Boo Berry

Moderator + Beta Tester
Moderator
Yes, it can. Integration mode with the AdGuard Adblocker extensions is going to be removed, as it's been replaced with the Browser Assistant.
 

badvibel

New Member
Yes, it can. Integration mode with the AdGuard Adblocker extensions is going to be removed, as it's been replaced with the Browser Assistant.
Thank you; this is a good thing, because sometimes when I deactivated a site from protection, the extension would automatically switch on, creating conflicts. Great update as ever.
 

oldsarge

New Member
Just had notice of another update. 2 days in a row! So I updated. Again! Seems to be the same version as yesterday: version 2.4.8.797. And the assistant remains the same. Any thoughts from the more experienced members?
 

LumbermanSVO

New Member
It appear that you guys have broken the app, it's frustrating. If it's not broken you guys need to publish VERY CLEAR instructions on how to make it work properly again, and inslude those instructions VERY CLEARLY in the update process.

The extension is turned on in Safari. When I start the app it works, but then I get a prompt asking for my password:
After I enter the password the app refuses to turn on:
And it no longer blocks adds.
 

zebrum

Administrator
Staff member
Administrator
Just had notice of another update. 2 days in a row! So I updated. Again! Seems to be the same version as yesterday: version 2.4.8.797. And the assistant remains the same. Any thoughts from the more experienced members?
what is your default browser?
 
Top