[AdGuard for Mac] Beta version 1.2.2

Status
Not open for further replies.

vasily_bagirov

Administrator
Staff member
Administrator
Hello guys!

We are ready to release new beta version of Adguard for Mac, v.1.2.2. New beta features few changes and mostly concerns network issues.

A link to GitHub: https://github.com/AdguardTeam/AdguardForMac/releases/tag/v1.2.2-beta
Download link: https://github.com/AdguardTeam/AdguardForMac/releases/download/v1.2.2-beta/Adguard-1.2.2.beta.dmg

Networking

[Changed] Rewritten mechanism of checking the websites availability. New approach improves browsing of some of the most problematic websites when IPv6 is enabled #93
[Fixed] Adguard prevents UDP traffic on 443 port #90
[Fixed] Adguard fails to detect HTML on some websites #100

We are waiting for your comments!
 
Last edited:

Boo Berry

Moderator + Beta Tester
Moderator
Nice, this is looking to be a very good build - and I can keep IPv6 enabled too!

I wonder though, is/was the Windows and Android builds affected by the websites accessibilities IPv6 issue like the Mac build was?
 

vasily_bagirov

Administrator
Staff member
Administrator
I wonder though, is/was the Windows and Android builds affected by the websites accessibilities IPv6 issue like the Mac build was?
We haven't tested specifically that for Adguard for Windows, but haven't received any complaints. Still, testing needs to be done to be sure.

Regarding Android, there is this issue which we are currently working on.
 

avatar

Administrator
Staff member
Administrator
I wonder though, is/was the Windows and Android builds affected by the websites accessibilities IPv6 issue like the Mac build was?
Windows - no issues.
Android - there were lots of issues, but all are pretty different from what we had in OS X:) This new "iptables redirect" issue is also very different.
 

Arthurnolan

Beta Tester
I would like to suggest adding a connecting status for Adguard on Mac, as just after switching on that filter, the website that I was encountering problem with worked for about 10 seconds, but after that when I try refreshing the webpage, only then I see that it is the one which caused the problem. So, it's a bit hard and troublesome to determine the problem if you can't see whether Adguard has refreshed the connection.
 

vasily_bagirov

Administrator
Staff member
Administrator
as just after switching on that filter
I am a litle lost, do you mean Adguard as a whole by the 'filter'? So, basically, you want to have a special status to be shown while Adguard is turning on, but hasn't quite started to filter the traffic yet?
 

Arthurnolan

Beta Tester
I am a litle lost, do you mean Adguard as a whole by the 'filter'? So, basically, you want to have a special status to be shown while Adguard is turning on, but hasn't quite started to filter the traffic yet?
Yeah kind of, I just want a status of Adguard when it is refreshing the connection to the enabled filters after manually disabling some filters to determine which filter cause a problem to a website or when enabling new filters.

And I would also like to suggest the ability to overwrite Adguard from automatically turning on filter as I was trying to determine which filter cause a video not to load and with Adguard automatically turning on filters, I can't accurately identify which filter is causing the problem.
 
Last edited:

vasily_bagirov

Administrator
Staff member
Administrator
I just want a status of Adguard when it is refreshing the connection to the enabled filters after manually disabling some filters to determine which filter cause a problem to a website or when enabling new filters.
Unfortunately, this is not really easy to do. It doesn't depend solely on Adguard, also browser caches the page, and overall we can't just tell when the new filter starts to 'do work'.

I would also like to suggest the ability to overwrite Adguard from automatically turning on filter
You can disable automatic filter enabling in Adguard Settings.
 
Status
Not open for further replies.
Top