AdGuard for Safari crash on current beta (DP2) of macOS Catalina

ragnorok

New Member
More of an FYI than anything else, but the current version of AdGuard for Safari (1.3.4) crashes upon open in the current macOS Catalina beta.

Two things occur, first, upon open I get this error:

".TC3Q7MAJXF.com.adguard.safari.AdGuard.4C1JbH" can’t be opened because it is from an unidentified developer.

And then, once I click OK, I get this long string of errors:

A JavaScript error occurred in the main process

Uncaught Exception:

Error: dlopen(/var/folders/xj/d3lz5pss4gqfkfqghngc48qm0000gn/T/com.adguard.safari.AdGuard/.TC3Q7MAJXF.com.adguard.safari.AdGuard.4C1JbH, 1): no suitable image found. Did find:

/var/folders/xj/d3lz5pss4gqfkfqghngc48qm0000gn/T/com.adguard.safari.AdGuard/.TC3Q7MAJXF.com.adguard.safari.AdGuard.4C1JbH: code signature in (/var/folders/xj/d3lz5pss4gqfkfqghngc48qm0000gn/T/com.adguard.safari.AdGuard/.TC3Q7MAJXF.com.adguard.safari.AdGuard.4C1JbH) not valid for use in process using Library Validation: Library load disallowed by System Policy

/var/folders/xj/d3lz5pss4gqfkfqghngc48qm0000gn/T/com.adguard.safari.AdGuard/.TC3Q7MAJXF.com.adguard.safari.AdGuard.4C1JbH: stat() failed with errno=17

at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:166:20)

at Object.Module._extensions..node (module.js:671:18)

at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:180:18)

at Module.load (module.js:561:32)

at tryModuleLoad (module.js:504:12)

at Function.Module._load (module.js:496:3)

at Module.require (module.js:586:17)

at require (internal/module.js:11:18)

at bindings (/Applications/AdGuard for Safari.app/Contents/Resources/app.asar/node_modules/safari-ext/node_modules/bindings/bindings.js:112:48)

at Object.<anonymous> (/Applications/AdGuard for Safari.app/Contents/Resources/app.asar/node_modules/safari-ext/index.js:1:189)


I have manually allowed the block ".TC3Q7MAJXF.com.adguard.safari.AdGuard.4C1JbH" process, but I still get the JavaScript error.

I have also uninstall and reinstall AdGuard from the Mac App Store.

I'm also a bit confused that AdGuard is trying to call up a process from an "unidentified developer" since it is coming directly from the App Store.

In any case, I know Catalina is in beta, so I don't expect a solution anytime soon - but figured I'd at least post I here.
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
@ragnorok
Good day!
Thanks for the request!

You correctly noted that we are not in a hurry to develop applications for the "raw" version of Catalina. But thank you, I think this information will be useful for us!
Stay tuned and have a good day! :)
 
Top