AdGuard for Windows 7.1.2817 Release


Usually, new stable versions are preceded with a number of betas and take longer than a month to develop. But this one is a bit different, its purpose is mainly to fix some incompatibilities (such as Windscribe VPN), so it makes a lot of sense to release this version as soon as possible. It should also spark interest in Firefox users, as we addressed several certificate-related problems unique to that browser.

Ad blocking
  • [Fixed] Manual blocker options bug #2677
  • [Fixed] AG certificate is not removed on the app uninstall or reinstall #2772
  • [Fixed] Certificate gets installed into the wrong system storage #2756
  • [Fixed] Compatibility issues with Sophos AV #2710
  • [Fixed] Cookies are getting removed even though self-destructing cookies options are disabled #2714
  • [Fixed] Windscribe extension compatibility #2703
  • [Changed] Domain name is now shown in the filtering log in all cases when it's detected #2691
  • [Changed] Translations have been updated #2697
  • [Fixed] AdGuard settings respond slowly when Parental Control is enabled #2687
  • [Fixed] Release channel label is missing #2695
  • [Fixed] "Hide User-Agent" flag state is not passed properly to web reporter #2732
  • [Fixed] AdGuard crashes randomly when you open settings #2685
  • [Fixed] Userscripts' update channels don't match app's release channel #2694
This version on a Github.
Direct download link.
Last edited by a moderator:
:( ... I don't know if it's this Update, the near-simultaneous update to Chrome 71 (beta) or a change in Youtube itself but: Youtube is now no longer ad-free for me.

I keep getting ads that are interrupting the videos and I haven't seen those in Windows in forever.
QUIC in Chrome enabled? If so, try disabling it and try again.
It isn't explicitly. Well, it's still set to default in chrome://flags - it's certainly possible that Chrome 71 enables it by default now, but I haven't found any info on that.
Instead of fiddling with Chrome flags I'm giving uBlock Origin a try - it hasn't really changed much over the years but is working flawlessly.

Boo Berry

Moderator + Beta Tester
Google's beginning to change how ads on YouTube are served. From what I've seen they're starting to embed them within the video streams themselves (and/or loading them from the same domains the videos are loaded from), which will likely make blocking ads on YouTube impossible eventually. And if you attempt to block the ads, you'll end up blocking the whole video stream. Right now, blocking YouTube ads seems to be working for AdGuard for Windows and AdGuard for Mac for most users but I have started seeing posts from users where YouTube ad blocking stops working. In your case, you might try disabling QUIC in Chrome 71, as there's a chance QUIC blocking broke again (or an antivirus, like Avast, is causing QUIC blocking from not working).

That said, I think it's a matter of time until all ad blockers completely become ineffective at blocking YouTube ads. What I think Google is doing is setting it up where no video ads on YouTube can be blocked, forcing users who hate seeing those ads into getting YouTube Premium subscriptions.
There is no 3rd party Antivirus on this machine, never has - Windows Defender on Windows 10 has become sufficiently competitive and secure within the last couple of years. There is nothing that would or should interfere with QUIC blocking.

This also isn't some A/B testing for "non-blockabled ads" Google may be running.
The simple facts are: after upgrading to Chrome 71 (beta) and AdGuard for Windows v6.4.1814 (both released and upgraded to near-simultaneously), Youtube in-video ad-blocking stopped working. After fully disabling and shutting down AdGuard for Windows and enabling uBlock Origin, Youtube is entirely ad-free again.

This may be a QUIC issue, if so it isn't caused by 3rd party applications. These are not fully stream-embedded ads that can't be blocked - for the simple fact that only AdGuard for Windows Premium fails to do so while uBlock Origin blocks them without issue.

Boo Berry

Moderator + Beta Tester
Another random thought that came to mind is the YouTube app Chrome installs by default. This also has caused issues in the past but I admit this one is a bit of a longshot. Nonetheless, if you're willing to try this and see if it's causing it, you can go to chrome://apps and remove/uninstall the bundled YouTube app from there. One other thing, if QUIC is behind this, you can try going to chrome://net-internals#quic and then opening YouTube and see if any QUIC connections appear there. It's worth noting that at least in Chrome 72 chrome://net-internals has been removed.

But I just tried Chrome Canary (which is running Chrome 72 dev) and YouTube ad blocking is working there.



Staff member
:( ... I don't know if it's this Update, the near-simultaneous update to Chrome 71 (beta) or a change in Youtube itself but: Youtube is now no longer ad-free for me.
First of all, try rebooting the computer. I know it sounds weird, but it might be necessary.

Second, I'd like to know more about your current configuration, AV specifically?
Ok, I think I found the source of the issue:

"Do not filter websites with EV certificates"

Something has changed either on Google's end, with the release of AdGuard 6.4.1814 or with Chrome 71 - but as long as this feature is enabled, Youtube videos are full of ads. This wasn't an issue before, everything worked fine with the EV exclusion enabled before.
Simply adding to the exclusion list isn't entirely sufficient, although ... maybe, I have seen the yellow bars but no ads actually appeared since.

Boo Berry

Moderator + Beta Tester
Perhaps the domain, which is where videos (and ads) are served from, is using an EV certificate now? Though probably not, as or doesn't appear to be using one.

No idea, but it's 100% reproducible on my end:
EV exclusion on: Youtube has ads. EV exclusion off: Youtube is ad free again.

But I was wrong before my edit: Adding to the EV exception list seems to fix the issue (it just took a couple of reloads).

I don't remember being warned that it uses an EV certificate, but the EV popups are so annoying and useless at the time of notification that it's easy to zone them out. And there is no history to revisit them.


New Member
For me, Adgard 6.4 is working fine on Youtube with QUIC Protocol disabled on Chrome 70, but not if enabled.
Last edited:


@Purple Tentacle


Do you saw same as this notification while visiting youtube?

Is there any changes if you switch WFP/TDI driver (AdGuard - Settings - Network - Use WFP enable/disable)?
Do you saw same as this notification while visiting youtube?
I don't know; I don't believe so.

I still believe that the current solution to EV notifications is simply utterly terrible and anti-user UI: The notifications are mandatory, constant and annoying to the point where the user simply zones them out. And they come at the wrong time as well, by the time one knows if a domain is worth filtering, one has to dig deep through Windows 10's notification history.

Why on earth don't you keep a short history of EV sites inside the app for easy blacklisting? And stop showing the pointless notifications?

Well, back to my issue:

QUIC appears to have absolutely nothing to do with the issue: Even after forcing it off inside chrome://flags I have seen Youtube video-ads with EV filter enabled and and blacklisted inside the EV settings, albeit much fewer than before.

I have disabled EV-filtering entirely for now (although I'm not feeling good about that), I did whitelist my online banking sites. I haven't seen an ad since. I still think the issue lies with the EV filter, but I still can't be sure.

EDIT: Nope, not the EV filter either ... at least not entirely. Ads keep sneaking through.

I'm using the WFP driver, by the way. Never had an issue with that. I don't really feel like rebooting to switch to an outdated driver model at the moment.
Last edited:


New Member
Really, really, really regret upgrading...
Always getting this ridiculous error about "Family Protection" (does not exist!) and "Parental Filter Restrictions" (does not exist!)!!! Brand new computer - i7 8700 w/ Win 10 x64 v1803. No A/V or firewall. No hosts changes. Win Defender disabled.

Uninstalled and selected yes to removing settings. Installed latest stable (same version AdGuard 6.4.1814.exe). All config and filters still installed and selected, so no settings or configuration data was wiped! Even after uninstall, it shows the SAME message w/ no AdGuard service, no extensions, nothing. Even if I install the standard AdGuard limited extension. Nothing changes!!

After removal it still occurs. Check browser extensions. Check DNS settings ( + Where the WTF is this bear coming from???
Any ideas? Hmm o_O
Maybe I should try a portable version of Firefox instead of Yandex Browser...?

Family protection

We blocked this page because of parental filter restrictions.

You're trying to reach a website listed by AdGuard as inappropriate for kids.
If you’re an adult then you can switch off parental control in the settings or add this website to the whitelist.

More information

[ Go back ]
[ Send feedback ]

Report about
This website is safe!
The website is safe to visit according to our data. If you want to block ads on this website, you need AdGuard.