[AdGuard for Windows] Beta version 5.10.2012

Status
Not open for further replies.

avatar

Administrator
Staff member
Administrator
Today we've released one more 5.10 beta version.
This version brings some important changes and fixes (mostly in SSL filtering library).

Changelog for 5.10.2012:
* Fixed compatibility issue with latest Bitdefender version and Adguard WFP driver
* Fixed a bug with checking existence of AG certificate in Firefox-based browsers. Now if AG does not detect our cert it disables SSL filtering for Firefox
* Improved SSL filter, fixed FREAK vulnerability
* Changed AG certificate generation algorithm (you may need to reinstall it to Firefox after update or to simply reboot the computer)
 

Boo Berry

Moderator + Beta Tester
Moderator
So far, so good. I cleaned out the NetworkTemp SSL folder before installing, just in case. ;) I see the certificate is named Adguard CA R94 in this build, I'm assuming with every certificate update the R number will increase?
 

avatar

Administrator
Staff member
Administrator
So far, so good. I cleaned out the NetworkTemp SSL folder before installing, just in case. ;) I see the certificate is named Adguard CA R94 in this build, I'm assuming with every certificate update the R number will increase?
No, R number depends on your computer configuration.

In this release we've changed our certificate from RSA1024 to RSA2048. Anyway we should have changed cert name to apply this (otherwise update could break SSL filtering in Firefox).

So we've decided to improve ssl filter security a bit more:
1. Pvk files are now encrypted
2. Cert name is now randomly generated

Soon we'll change our cert again, now from RSA to DSA, and for this change we will also need to change cert name.
 

streetwolf

Beta Tester
How do I stop getting server not found messages for https sites after updating to 2012.6273?

I only have in my SSL folder Adguard CA R48.cer and Adguard CA R48.p
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
For this one I'd open Firefox/Nightly and remove the Adguard certificate, then close all browsers, close Adguard from the system tray, open task manager and kill AdguardSvc.exe (and Adguard.exe if its still hanging around), go to the %ProgramData%\Adguard\NetworkTemp\SSL folder, delete ALL files inside and reboot.
 
Last edited by a moderator:

streetwolf

Beta Tester
Didn't work BB. Now what? Also why no Adguard CA R94 cert?

Another thing. When I enable AG it takes about 15 seconds for AG to be marked enabled when it is disabled.
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
Like Avatar said, it depends on your computer's configuration for the R number. Odd that it didn't work, it worked fine for me. Hmmm. Needs more testing - any sites where you're seeing this or is it all SSL sites?
 

streetwolf

Beta Tester
Now it's happening on every site I go to. Unless you need me to stay on 2012 to troubleshoot how do I get back to the previous version?
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
Simple way:
1. Stop AG protection
2. Stop Firefox (check with task manager that there're no firefox.exe processes)
3. Start AG protection
4. Wait for 30 seconds

That should do it.

I guess you have Firefox in autorun?

---------- Post added at 03:08 AM ---------- Previous post was at 03:06 AM ----------

Other way is to manually import "Adguard CA RXX.cert" into the firefox.
But please first check protection stop/start instruction. It must work.
 

Boo Berry

Moderator + Beta Tester
Moderator
He's using Nightly, so that could be it or the profile. Not sure. I'm currently using 32-bit Nightly and its working fine here.

EDIT: Tested 64-bit Nightly and its working fine too, as is 64-bit Firefox (pcxFirefox). Hmmmm.
 
Last edited by a moderator:

streetwolf

Beta Tester
When you mean stop AG protection are you talking about disabling it or closing it? Tried the steps you mentioned by disabling/enabling and that didn't work. Also some sites just produce a spinning throbber without any message.

I have 5 Adguard.CA R48.cer's when I view my certificates.
 
Last edited by a moderator:

streetwolf

Beta Tester
At this moment I have in SSL... Adguard CA R48.cer, Adguard CA R48.p, test.cer, and test.p

Also notice that when I close AG then restart it it takes about 15 seconds for the icon to go from yellow to green. Never did that before.
 

avatar

Administrator
Staff member
Administrator
When you mean stop AG protection are you talking about disabling it or closing it? Tried the steps you mentioned by disabling/enabling and that didn't work. Also some sites just produce a spinning throbber without any message.
Could you please send me AG service logs? It is really strange, AG should have either not filter HTTPS or import the certificate, cert error in this version is unexpected.

Have you tried importing certificate manually?

---------- Post added at 03:26 AM ---------- Previous post was at 03:24 AM ----------

At this moment I have in SSL... Adguard CA R48.cer, Adguard CA R48.p, test.cer, and test.p
Import Adguard CA R48.cer manually to firefox.

Also notice that when I close AG then restart it it takes about 15 seconds for the icon to go from yellow to green. Never did that before.
Again I need to see your log to say why is it so slow.
 

avatar

Administrator
Staff member
Administrator
Yes I did try to import it manually to no avail.
You should also check "Trust this CA to identify websites" while importing it.

---------- Post added at 03:36 AM ---------- Previous post was at 03:33 AM ----------

Ok, now I see what's wrong and why does it take so long.

Something is wrong with how cert is checked in your case (check process hangs for more than 10 seconds).
I recommend you downgrading to the stable version for now, I will prepare a patch tomorrow.
 

streetwolf

Beta Tester
Also I can't even use Outlook to access my mail, I get a receive error. Where can I find the last beta version which worked fine?
 

streetwolf

Beta Tester
When I run it it tells me to uninstall my current version. Will I lose my settings and custom filters if I do this?
 
Status
Not open for further replies.
Top