[AdGuard for Windows] Beta version 6.0.67.364

Status
Not open for further replies.

Confessor

Administrator
Administrator
It was a long way, and we are finally ready to introduce the first beta version of Adguard 6 :cool:

Version 6.0.67.364.

There is really a load of changes, that is why meet the very basic and most important ones:
* Totally new program design.
* The full-fledged Privacy protecton mode (Stealth mode).
* Added ability to install filters through the link.
* New Filter editor - much more convenient and clear than the old one.
* New Filtering Log. Much easier than the old one.
* New version of network drivers.
* Many changes 'under the bonnet', new filtering engine.
* Improved SSL filtering - added OCSP Stapling.
* Ability to reinstall certificate from the program settings window.
* Reworked the list of filtered applications, it is now much easier to add new applications.
*Added "Do not filter sites with SSL EV certificates" option.
* Added update channels, now it is not necessary to have a beta key for the installation of beta versions.
* Changed a list of supported languages, now available:
- Russian
- Ukranian
- Polish
- English
- German

In preparing of this release the great importance had the help of our users, who took a risk with use of earlier Adguard 6 versions. Therefore, we made a special thank-you page: http://adguard.com/en/acknowledgements.html#win-acknowledgments. We have tried to give a shout out to all who contributed to the alpha testing. But if your name is missing (we could have forgotten to write it down) - please write us and this mistake will be corrected :)

Currently there is a manual update to the beta version of the program.
If this beta is stable enough, then we will soon enable the auto-update :)



Ways to update:
- check updates in the program (program shall be activated with a beta license; to check the available updates go to the icon's context menu in the tray and select "About")
- download an installer from github, currently it is - https://github.com/AdguardTeam/AdguardForWindows/releases/tag/6.0.67.364
- download an installer from our website - http://download.adguard.com/d/2/adguardInstallerBeta.exe
 
Last edited by a moderator:

Phonemes

Member
Hi, and thank you. I just installed the beta and it appears to be running just fine. Just one problem so far: http://avxhome.se/ won't load for me since installing this version. Disabling Adguard does not help - I have to close the application completely before the website will load.
 

NSG001

New Member
Congrats.
Thanks also to everyone for testing.
Also you may want to pop on to Wilders forums to update the users there.
 

mysteriously

Beta Tester & Translator
I updated via 'About' page. It took a while and worked on 2nd try.
However in tray menu and in 'about Adguard' window Adguard still lets me know the update is available.

http://i.imgur.com/cidOF7S.png
There is no such string as 'Update success' on translation platform.

Is the below statement correct?
MainWindowAdblockerFiltersMultiple for >=5 filters enabled
MainWindowAdblockerFiltersThird for 2-4 filters enabled
I thought it's exactly the opposite...

With this version the language confirmation window shows up in background. The language selection bar should be gone when user already clicked on any language.
http://i.imgur.com/G7tMBYp.png

Switching in between 'Problem type' in Support window is bit sluggish.
 
Last edited by a moderator:

pegas

Beta Tester
I recommend you to keep away of Miscellaneous from Stealth Mode settings. They can cause more troubles than good.
 

Blaz

Moderator & Translator
Staff member
Moderator
For those wondering how to update manually, you have to open the about window through the tray icon.

In main window it would be good if we could click on the green/gray arrow to disable/enable that module.
 
Last edited by a moderator:

Confessor

Administrator
Administrator
Hi, and thank you. I just installed the beta and it appears to be running just fine. Just one problem so far: http://avxhome.se/ won't load for me since installing this version. Disabling Adguard does not help - I have to close the application completely before the website will load.
This is strange, create issue:
https://github.com/AdguardTeam/AdguardForWindows/issues/255

Thanks!
https://github.com/AdguardTeam/AdguardForWindows/issues/256
https://github.com/AdguardTeam/AdguardForWindows/issues/257
https://github.com/AdguardTeam/AdguardForWindows/issues/258

The problem with http://avxhome.se/ went away after I unchecked "Use WFP network driver".

---------- Post added at 03:48 PM ---------- Previous post was at 03:33 PM ----------

Enabling "Hide your Rererrer from third parties" appears to remove the c-box on http://exystence.net/

With "Hide your Referrer" unchecked:

View attachment 3231

With "Hide your Referrer" checked:

View attachment 3232

Thank you
https://github.com/AdguardTeam/AdguardForWindows/issues/259

I updated via 'About' page. It took a while and worked on 2nd try.
However Adguard still lets me know the update is available and wants to perform it.

http://i.imgur.com/cidOF7S.png
There is no such string as 'Update success' on translation platform.

Is the below statement correct?
MainWindowAdblockerFiltersMultiple for >=5 filters enabled
MainWindowAdblockerFiltersThird for 2-4 filters enabled
I thought it's exactly the opposite...

With this version the language confirmation window shows up in background. The language selection bar should be gone when user already clicked on any language.
http://i.imgur.com/G7tMBYp.png

Switching in between 'Problem type' in Support window is bit sluggish.
https://github.com/AdguardTeam/AdguardForWindows/issues/260
https://github.com/AdguardTeam/AdguardForWindows/issues/261
https://github.com/AdguardTeam/AdguardForWindows/issues/262
https://github.com/AdguardTeam/AdguardForWindows/issues/263

Things are much complicated with MainWindowAdblockerFilters as they may be, I will describe the logic a bit later.

I recommend you to keep away of Miscellaneous from Stealth Mode settings. They can cause more troubles than good.
These are pretty specific capabilities, maybe we will just insist that only those, who really need these features, shall enable them.

For those wondering how to update manually, you have to open the about window through the tray icon.
It is a good point, OP updated.

In main window it would be good if we could click on the green/gray arrow to disable/enable that module.
But it is much more difficult to click on the icon rather than just switch.
 

mysteriously

Beta Tester & Translator
Hmm, sorry, I wasn't clear enough. The popup screenshoot was just to show missing 'Update success' from translations strings. The problem is that after update to the latest version:
1) 'New version is available' shows up in tray menu
2) 'Program update is available!' shows up in 'about Adguard' window.

BTW: Correct translation strings for
Filters has been updated X ago -> Filtry zostały zaktualizowane X temu

[offtop]Minute(s) -> :

1 minutę
2-4 minuty
5-21 minut
22-24 minuty
25-31 minut
32-34 minuty
35-41 minut
42-44 minuty
45-51 minut
52-54 minuty
55-59 minut

Hour(s):
1 godzinę
2-4 godziny
5-21 godzin
22-24 godziny

Day(s):
1 dzień
2-365 dni[/offtop]

I sent it to Vasily too.

Adguard installs userscript even if the file is empty. Also another phrase is missing on onesky. I just deleted the file and clicked to reinstall the extension.
http://i.imgur.com/Wkl3W3p.png
 
Last edited by a moderator:

NSG001

New Member
Hi, and thank you. I just installed the beta and it appears to be running just fine. Just one problem so far: http://avxhome.se/ won't load for me since installing this version. Disabling Adguard does not help - I have to close the application completely before the website will load.
FYI
avxhome.se hosts links to illegal and pirated files and software.
I suspect the malware/spyware filter blocked it ?
My ISP here in the UK is blocking the site outright because of copyright infringements.
 

ShakedBenratzon

New Member
Thanks for the beta guys,

Some page load very slow or even do not load with the beta same old problem that appear in AdGuard 5.10 the page try to load injection.adguard.com

or download.adguard.com do not remember which one

Also some pages are missing content or just freeze for example Outlook.com or Bing.com most of the time happen on safe and popular sites...

for example www.diablofans.com or www.winbeta.org

and here www.G2A.com Login Option is missing and removed from the website because AdGuard and I need to disable it to get login button option back again

I use Edge Browser with WFP and basic filters + easy list

any way to fix those bugs ?
 
Last edited by a moderator:

pegas

Beta Tester
Thanks!
These are pretty specific capabilities, maybe we will just insist that only those, who really need these features, shall enable them.
Yes, not only for those who need them but mainly for those who understand what these settings do/change. ;-)
 

Phonemes

Member
unhandled exception

Hi,

I just got an "unhandled exception" after opening Adguard's main GUI. I *think* it happened when I left-clicked Browsing Security settings.

The first line of the Dutch log file translates roughly as follows:

System.ArgumentException: The head-Visual of a VisualTarget cannot contain a superseding element.

After closing the GUI, Adguard's icon remains visible on the taskbar and cannot be removed by clicking "close window".

Log file attatched.
 

Attachments

Last edited by a moderator:

mysteriously

Beta Tester & Translator
If you disable some filtering rules in filter editor, click 'Show' and tick the tickbox on some filters, then those filters will stay on the list while search bar reports it shows 'status:disabled' only. If you leave some rules unticked and click 'Show' again, it has no affect. Maybe that's intentional in situation when user wants to check which rules could cause issues.
 

Confessor

Administrator
Administrator
Hi everyone :cool:

Hmm, sorry, I wasn't clear enough. The popup screenshoot was just to show missing 'Update success' from translations strings. The problem is that after update to the latest version:
1) 'New version is available' shows up in tray menu
2) 'Program update is available!' shows up in 'about Adguard' window.

BTW: Correct translation strings for
Filters has been updated X ago -> Filtry zostały zaktualizowane X temu

[offtop]Minute(s) -> :

1 minutę
2-4 minuty
5-21 minut
22-24 minuty
25-31 minut
32-34 minuty
35-41 minut
42-44 minuty
45-51 minut
52-54 minuty
55-59 minut

Hour(s):
1 godzinę
2-4 godziny
5-21 godzin
22-24 godziny

Day(s):
1 dzień
2-365 dni[/offtop]

I sent it to Vasily too.

Adguard installs userscript even if the file is empty. Also another phrase is missing on onesky. I just deleted the file and clicked to reinstall the extension.
http://i.imgur.com/Wkl3W3p.png
Ok, 'Update success' already added to resources.
Issue about update notification https://github.com/AdguardTeam/AdguardForWindows/issues/260 edited.
And here are the new ones:
https://github.com/AdguardTeam/AdguardForWindows/issues/274
https://github.com/AdguardTeam/AdguardForWindows/issues/275

Thanks for the beta guys,

Some page load very slow or even do not load with the beta same old problem that appear in AdGuard 5.10 the page try to load injection.adguard.com

or download.adguard.com do not remember which one

Also some pages are missing content or just freeze for example Outlook.com or Bing.com most of the time happen on safe and popular sites...

for example www.diablofans.com or www.winbeta.org

and here www.G2A.com Login Option is missing and removed from the website because AdGuard and I need to disable it to get login button option back again

I use Edge Browser with WFP and basic filters + easy list

any way to fix those bugs ?
You are welcome :)
Can you try to switch the driver type in Adguard settings? Does it help to resolve page loading problem?
As for the Login, Alex may help.
https://github.com/AdguardTeam/ExperimentalFilter/issues/762

Hi,

I just got an "unhandled exception" after opening Adguard's main GUI. I *think* it happened when I left-clicked Browsing Security settings.

The first line of the Dutch log file translates roughly as follows:

System.ArgumentException: The head-Visual of a VisualTarget cannot contain a superseding element.

After closing the GUI, Adguard's icon remains visible on the taskbar and cannot be removed by clicking "close window".

Log file attatched.
Yes, we already have a similar issue, it's now updated:
https://github.com/AdguardTeam/AdguardForWindows/issues/270

If you disable some filtering rules in filter editor, click 'Show' and tick the tickbox on some filters, then those filters will stay on the list while search bar reports it shows 'status:disabled' only. If you leave some rules unticked and click 'Show' again, it has no affect. Maybe that's intentional in situation when user wants to check which rules could cause issues.
We did this on purpose, because it looks really weird when you tick the rule and it just instantly disappears.
But at the second click on "Show" button, we maybe need to refresh the rules list.
https://github.com/AdguardTeam/AdguardForWindows/issues/276
 

avatar

Administrator
Staff member
Administrator
Some page load very slow or even do not load with the beta same old problem that appear in AdGuard 5.10 the page try to load injection.adguard.com
Maybe I'll need to take a look at this, seems strange that you've got the same problem in v6.

Could you please tell me more about your computer configuration?
Which AV do you use? Maybe a Firewall app or something like that?

What you describe is looks much like WFP drivers incompatibility. So we should understand what WFP drivers do you have installed besides Adguard's.
 
Status
Not open for further replies.
Top