[AdGuard for Windows] Beta version 6.0.67.364

Status
Not open for further replies.

ShakedBenratzon

New Member
Maybe I'll need to take a look at this, seems strange that you've got the same problem in v6.

Could you please tell me more about your computer configuration?
Which AV do you use? Maybe a Firewall app or something like that?

What you describe is looks much like WFP drivers incompatibility. So we should understand what WFP drivers do you have installed besides Adguard's.
First of all I would like you to tell me what does it mean to change WFP driver type in settings

I got Eset Smart Security and Malware Bytes Antimalware both last version + Eset is my firewall

I made sure to add the whole folder of AdGuard and the Exe it self to the exception list on both programs

I am using Edge Browser + Windows 10

I am using the default Adblock List + Easy List that it + I am Not using Adguard assistant or Web of trust extensions
 

mysteriously

Beta Tester & Translator
Ok, got it. The next one also may not be an issue.
In 'Filter subscriptions' click to edit any filter. Now when 'Filters editor' is already opened switch back to 'Filter subscriptions' window and click to edit any other filter. 'Filters editor' window will come to foreground in place of previously edited filter.

Typo in polish filters names: [l -> ł]
Adblock polskie reguly -> Adblock polskie reguły
Adblock polskie reguly cookies -> Adblock polskie reguły cookies
 

NSG001

New Member
@buuuuuuu190

I understand from various posts that ESET does not play along nice with Adguard WFP filter ?
Do you experience any problems or disadvantage using Adguard's TDI filter on Version 6 ?
Reason is i want to install ESET AV V9 and Adguard V6 when both are released onto my son's laptop.
Thanks in advance.
 

Phonemes

Member
I'm getting this when I try to open www.discogs.com:

The connection was reset

The connection to the server was reset while the page was loading.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

I use this site very frequently and never saw this problem before under version 5. When I disable Adguard, the site loads instantly.
 

pegas

Beta Tester
No problem here with v6 beta.

---------- Post added at 12:09 PM ---------- Previous post was at 11:55 AM ----------

When checking updates I'm getting "error" at Adguard Assistant quite often. I have to recheck updates to get the up-to-date result.
 

pegas

Beta Tester
Unchecking "Hide your IP address" under stealth options solved the problem with www.discogs.com.
Yeah, that's what I said in another thread. Don't use Miscellaneous options from Stealth Mode, they cause troubles. I recommend to developers to somehow reorganize Stealth Mode settings in a way that Miscellaneous settings will be hidden with warning that these settings can cause issues. Users should be aware of it and keep it in mind.
 
Last edited by a moderator:

Phonemes

Member
I agree that a warning would be a good idea if these options may cause issues. Perhaps also a button to set stealth and other options back to default.
 

mysteriously

Beta Tester & Translator
Text in browser's window is not translated (as well as tab's title)


@buuuuuuu190

I understand from various posts that ESET does not play along nice with Adguard WFP filter ?
Do you experience any problems or disadvantage using Adguard's TDI filter on Version 6 ?
Reason is i want to install ESET AV V9 and Adguard V6 when both are released onto my son's laptop.
Thanks in advance.
https://github.com/AdguardTeam/AdguardForWindows/issues/168

No, I don't. Everything seems to work fine. Adguard's WFP network driver is designed for Win >=8.x to filter Modern UI apps, so I don't need it on Win7.

Also my issue with randomly appearing ads on google domains is gone since I removed HTTPS Everywhere addon in FF.
 
Last edited by a moderator:

Tyrizian

New Member
I also posted this in the Wilders Security Forum

Just a suggestion for future versions of 6.0 Alpha/Beta/Final...

Under "License", could you add/show the amount of devices the license is installed on? (Example: License is Active Premium, Lifetime license: 2 out of 4 devices active).

In previous versions, it always displayed the amount of devices that were activated. Version 6.0 doesn't display this information, could you possibly add it?
 

NSG001

New Member
@buuuuuuu190

Thanks for your reply, all understood.
Looks like i'll load EMSI for him instead as his OS is 8.1 :)
 

Confessor

Administrator
Administrator
Ok, got it. The next one also may not be an issue.
In 'Filter subscriptions' click to edit any filter. Now when 'Filters editor' is already opened switch back to 'Filter subscriptions' window and click to edit any other filter. 'Filters editor' window will come to foreground in place of previously edited filter.

Typo in polish filters names: [l -> ł]
Adblock polskie reguly -> Adblock polskie reguły
Adblock polskie reguly cookies -> Adblock polskie reguły cookies
Ok, we will fix that:
https://github.com/AdguardTeam/AdguardForWindows/issues/280
https://github.com/AdguardTeam/AdguardForWindows/issues/281

No problem here with v6 beta.

---------- Post added at 12:09 PM ---------- Previous post was at 11:55 AM ----------

When checking updates I'm getting "error" at Adguard Assistant quite often. I have to recheck updates to get the up-to-date result.
Perhaps we have already created issue for this problem:
https://github.com/AdguardTeam/AdguardForWindows/issues/264

Text in browser's window is not translated (as well as tab's title)



https://github.com/AdguardTeam/AdguardForWindows/issues/168

No, I don't. Everything seems to work fine. Adguard's WFP network driver is designed for Win >=8.x to filter Modern UI apps, so I don't need it on Win7.

Also my issue with randomly appearing ads on google domains is gone since I removed HTTPS Everywhere addon in FF.
https://github.com/AdguardTeam/AdguardForWindows/issues/282
What filters you have enabled?

I also posted this in the Wilders Security Forum

Just a suggestion for future versions of 6.0 Alpha/Beta/Final...

Under "License", could you add/show the amount of devices the license is installed on? (Example: License is Active Premium, Lifetime license: 2 out of 4 devices active).

In previous versions, it always displayed the amount of devices that were activated. Version 6.0 doesn't display this information, could you possibly add it?
Maybe this is a good idea:
https://github.com/AdguardTeam/AdguardForWindows/issues/283
 

Blaz

Moderator & Translator
Staff member
Moderator
In my FF 40.0.3 sometimes the Certificate gets lost (no FF update, only Adguard) and then I have to reinstall the certificate :(
Would be good if the setup would automatically reinstall the certificate.
 
Last edited by a moderator:

mysteriously

Beta Tester & Translator
What filters you have enabled?
User Filter, English, Spyware, EasyPrivacy, Fanboy's Annoyances, Adblock polskie reguly, Adblock polskie reguly cookies
User filter has only one global rule:
Code:
#%#window.webkitRTCPeerConnection = undefined; window.mozRTCPeerConnection = undefined; navigator.mozGetUserMedia = undefined; navigator.webkitGetUserMedia = undefined; window.MediaStreamTrack = undefined; window.AudioContext = undefined; window.webkitAudioContext = undefined; window.RTCPeerConnection = function() {};
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
First of all I would like you to tell me what does it mean to change WFP driver type in settings
There is a checkbox in "General" settings.

The problem here is that WFP is the only way of filtering Modern UI apps (including Edge browser).

I got Eset Smart Security and Malware Bytes Antimalware both last version + Eset is my firewall
I bet on ESET, we've got some compatibilty issues with it before:
https://github.com/AdguardTeam/AdguardForWindows/issues/168

Also it may depend on eset version as they have different drivers in ESS and NOD.

---------- Post added at 07:48 PM ---------- Previous post was at 07:47 PM ----------

User Filter, English, Spyware, EasyPrivacy, Fanboy's Annoyances, Adblock polskie reguly, Adblock polskie reguly cookies
User filter has only one global rule:
Code:
#%#window.webkitRTCPeerConnection = undefined; window.mozRTCPeerConnection = undefined; navigator.mozGetUserMedia = undefined; navigator.webkitGetUserMedia = undefined; window.MediaStreamTrack = undefined; window.AudioContext = undefined; window.webkitAudioContext = undefined; window.RTCPeerConnection = function() {};
Btw you don't need this rule if Stealth Mode's "block webrtc" is enabled.
 

mysteriously

Beta Tester & Translator
:) Yes, I know, but I can use it when Stealth Mode is disabled.

Things are much complicated with MainWindowAdblockerFilters as they may be, I will describe the logic a bit later.
I think it would be good to find a way to resolve issues with numbers and polish translation strings shown in window before final release.

> Filters has been updated X ago -> Filtry zostały zaktualizowane X temu
>
> Minute(s) -> : 11 phrases, 3 wariants
>

if (numberOfMinutes == 1)
printf('minutę');
else if (numberOfHours >= 22 and (x % 10 >= 2) and (x % 10 <= 4))
printf('minuty');
else if printf('minut');
>
>
>
> 1 minutę
> 2-4 minuty
> 5-21 minut
> 22-24 minuty
> 25-31 minut
> 32-34 minuty
> 35-41 minut
> 42-44 minuty
> 45-51 minut
> 52-54 minuty
> 55-59 minut
>
>
> Hour(s): 4 phrases, 3 wariants
>

if (numberOfHours >= 1 and numberOfHours < 1.5)
printf('godzinę');
else if ((numberOfHours >= 1.5 and numberOfHours < 5.5) or (numberOfHours >= 21.5 and numberOfHours < 24))
printf('godziny');
else if printf('godzin');

> 1 godzinę
> 2-4 godziny
> 5-21 godzin
> 22-24 godziny
>
> Day(s):
> 1 dzień
> 2-365 dni

*Yes, I know there should be " in printf
Number of filters, extensions etc. are bit messy in polish :)

When I press Win key while full screen game is running or just exit it, I see Adguard's 'Thread blocked' popup in left down corner. It blinks for very short time but it is possible to reproduce it often. Firefox was not running.
 
Last edited by a moderator:

steve1209

Beta Tester
No problem here with v6 beta.

---------- Post added at 12:09 PM ---------- Previous post was at 11:55 AM ----------

When checking updates I'm getting "error" at Adguard Assistant quite often. I have to recheck updates to get the up-to-date result.
Hi Pegas,

Andrey has entered a Github issue for this problem, I sent him logs to investigate, he is not sure it can be fixed but wants to look into it more when he returns from Vacation, I've had the problem off and on from the beginning...
 

Blaz

Moderator & Translator
Staff member
Moderator
In Open dialogue of Add application to the filtered apps, it should be possible to add several exe files at once if they are in the same folder.

Also if that mentioned exe file is already in filtered apps list, there should be an information about it and asking the user if he wants to add a different exe.
 

ShakedBenratzon

New Member
If there are compatibillty issue with ESET why you do not talk with them or work with them to fix this problems

also as I said I got Eset Smart Security last version and Malwarebytes Anti Malware pro with real time scanning last version also

from what you know is any more that I need to do or consider or I should just wait till you will fix this bugs
 
Last edited by a moderator:

Innuendo

Beta Tester
Speaking of compatibility 'issues', Agnitum has released v9.2 of their security suite and while their beta would install without complaints if AdGuard was installed, the release version complains & refuses to install if it detects AdGuard on the system.

Someone from the AdGuard team may wish to get with the Agnitum guys & find out why they think there's a problem as I'm running them in tandem with no issues. I've also sent this note to Agnitum as well.
 
Status
Not open for further replies.
Top