[AdGuard for Windows] Beta version 6.0.67.364

Status
Not open for further replies.

mysteriously

Beta Tester & Translator
I left FF opened on polish website with shoutbox and with few short videos to buffer and left PC locked. When I came back, no new shoutbox messages appeared even after pressing refresh button (there were some new messages for sure). Then I tried to load some webpages, those simply could not load - firefox loading circle was spinning infinitely. In the meantime I also tried to update Adguard filters (for some reason filters do not update automatically for me with the latest beta), then noticed that Adguard service froze up and crashed. Message about service error appeared, however the one about restoring service did not. I had to reboot the PC anyway, because Adguard service cpu usage was jumping up to 50% - full one core usage
Logs: https://mega.nz/#!jgwjBZhS!BVgO4Wf3PPsuQyzvO0KLk762A-YfQp87M1K99mrS0Es
 

avatar

Administrator
Staff member
Administrator
If there are compatibillty issue with ESET why you do not talk with them or work with them to fix this problems

also as I said I got Eset Smart Security last version and Malwarebytes Anti Malware pro with real time scanning last version also

from what you know is any more that I need to do or consider or I should just wait till you will fix this bugs
We will, that's why that bug on github is still open.

Try disabling Firewall in ESS for now.

---------- Post added at 09:43 AM ---------- Previous post was at 09:42 AM ----------

Speaking of compatibility 'issues', Agnitum has released v9.2 of their security suite and while their beta would install without complaints if AdGuard was installed, the release version complains & refuses to install if it detects AdGuard on the system.

Someone from the AdGuard team may wish to get with the Agnitum guys & find out why they think there's a problem as I'm running them in tandem with no issues. I've also sent this note to Agnitum as well.
Filed a bug report:
https://github.com/AdguardTeam/AdguardForWindows/issues/289

---------- Post added at 09:44 AM ---------- Previous post was at 09:43 AM ----------

The parental control blacklsit doesn't work with the browsers in sandboxie.
I have tried ie and firefox.
Blacklist only? What for ad blocking? Was it working with these browsers?

---------- Post added at 09:46 AM ---------- Previous post was at 09:44 AM ----------

I left FF opened on polish website with shoutbox and with few short videos to buffer and left PC locked. When I came back, no new shoutbox messages appeared even after pressing refresh button (there were some new messages for sure). Then I tried to load some webpages, those simply could not load - firefox loading circle was spinning infinitely. In the meantime I also tried to update Adguard filters (for some reason filters do not update automatically for me with the latest beta), then noticed that Adguard service froze up and crashed. Message about service error appeared, however the one about restoring service did not. I had to reboot the PC anyway, because Adguard service cpu usage was jumping up to 50% - full one core usage
Logs: https://mega.nz/#!jgwjBZhS!BVgO4Wf3PPsuQyzvO0KLk762A-YfQp87M1K99mrS0Es
Logs are not enough, we need process dump to check what's going on.

You can make it with Task Manager, right-click on the service process and look for "Create Dump File" option there.

---------- Post added at 10:34 AM ---------- Previous post was at 09:46 AM ----------

In Open dialogue of Add application to the filtered apps, it should be possible to add several exe files at once if they are in the same folder.
https://github.com/AdguardTeam/AdguardForWindows/issues/291

Also if that mentioned exe file is already in filtered apps list, there should be an information about it and asking the user if he wants to add a different exe.
https://github.com/AdguardTeam/AdguardForWindows/issues/292
 

mysteriously

Beta Tester & Translator
The parental control blacklsit doesn't work with the browsers in sandboxie.
I have tried ie and firefox.
To be honest I have not tested this module (yet). Quick look on the case confirms the issue. Maybe the Sandboxie just need a template to have read access to parental control database.
I will look into this... maybe this evening and update threads if find something worth posting.

Parental control blocking info shows up in english


Logs are not enough, we need process dump to check what's going on.

You can make it with Task Manager, right-click on the service process and look for "Create Dump File" option there.
Ok, no problem. I guess you want the dump to be created as soon as service crashes.
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
Parental control blocking info shows up in english
That's the same bug as with "access denied" page.


Ok, no problem. I guess you want the dump to be created as soon as service crashes.
No, when it's in "frozen" state or consuming too much CPU. We'll see what program does at that moment.
 

mysteriously

Beta Tester & Translator
Blacklist only? What for ad blocking? Was it working with these browsers?
Ad blocking works fine for me with sandboxed browsers. I browse the web running web browsers inside sandbox pretty much all the time.
No, when it's in "frozen" state or consuming too much CPU. We'll see what program does at that moment.
Ok, so frozen state. Even after automatic restoring protection the service still consumed too much CPU.
 

avatar

Administrator
Staff member
Administrator
Ad blocking works fine for me with sandboxed browsers. I browse the web running web browsers inside sandbox pretty much all the time.
So ad blocking is good, parental control is not? Or everything is good?

Ok, so frozen state. Even after automatic restoring protection the service still consumed too much CPU.
Possible shortly after restart, while it's in process of preparing everything.
 

Blaz

Moderator & Translator
Staff member
Moderator
When entering an invalid subscription url, the error message is in English (don't know if already reported).

---------- Post added at 12:39 PM ---------- Previous post was at 12:19 PM ----------

Just a heads up for the needed feature "Search and replace" to block VAST video ads.

---------- Post added at 12:41 PM ---------- Previous post was at 12:39 PM ----------

Sadly had to reinstall FireFox's certificate again :(
Also reinstall certificate button should not disconnect connections for applications which are disabled to filter like uTorrent in my case.
 
Last edited by a moderator:

agasoft

Beta Tester
Hello,
Thanks for the new version.
I am the blind person, and testing the program accessibility and how its working with screen readers.
We have a good progress with this v 6.0, except one thing.
On first setup screen, and later on settings, checkboxes are not checkable with space key as is usual in 99.9999% of Windows programs.
For example screen reader says:
"Enable ad blocker check box not checked".
When I press space, it Checked.
Now, screen readers says:
Enable ad blocker check box not checked button.
I think that this kind of button near checkbox conflicting, and space key wont check or uncheck the box.
Finally, my another question regarding tranlation.
I am translator, but I dont seeing AdGuard for Windows on available projects.
What should I do?
 

mysteriously

Beta Tester & Translator
If you disable internet connection and try to update filters manually, an error will show up. However 'Filters has been updated 1 minute ago' in main window will show up anyway.
 

hanschke

Beta Tester & Translator
sys tray Icon is missing and I cannot start the gui. Anyone the same problem after the update under win 10 and insider build? Setup told me that adguard is already installed
 

Blaz

Moderator & Translator
Staff member
Moderator
Sadly the support form doesn't inform the user he/she reached limit of the message.

EDIT: My test message #WHJ-763-69579 included html code, but it is not in the actual ticket.
 
Last edited by a moderator:

lanesra36

New Member
sys tray Icon is missing and I cannot start the gui. Anyone the same problem after the update under win 10 and insider build? Setup told me that adguard is already installed
Yes this has happened to me updating in win 10
Tried everything but no success
Been told to do a manual uninstall
I like I tried that and they did not work too
 

Yuuka Kazami

New Member
So ad blocking is good, parental control is not? Or everything is good?
Yes, ad blocking is good. Parental control is not.
I test that blacklist, safe search, and block executable files download do not work.
I don't know how to test whitelist, but I think the parental control is totally not work in sandboxie.
 

avatar

Administrator
Staff member
Administrator
When entering an invalid subscription url, the error message is in English (don't know if already reported).
https://github.com/AdguardTeam/AdguardForWindows/issues/295


Just a heads up for the needed feature "Search and replace" to block VAST video ads.
I remember:)

Also reinstall certificate button should not disconnect connections for applications which are disabled to filter like uTorrent in my case.
For now that's not possible, all active connections are killed on network filtering restart.

---------- Post added at 05:43 AM ---------- Previous post was at 05:40 AM ----------

Yes, ad blocking works fine. Parental control does not work at all.
I created new thread on sandboxie forums http://forums.sandboxie.com/phpBB3/viewtopic.php?f=11&t=21800&p=113726#p113726
Ok I know why is it, the problem is that we cannot detect windows user if the browser is in the sandbox:
https://github.com/AdguardTeam/AdguardForWindows/issues/296

---------- Post added at 05:46 AM ---------- Previous post was at 05:43 AM ----------

Hello,
Thanks for the new version.
I am the blind person, and testing the program accessibility and how its working with screen readers.
We have a good progress with this v 6.0, except one thing.
On first setup screen, and later on settings, checkboxes are not checkable with space key as is usual in 99.9999% of Windows programs.
For example screen reader says:
"Enable ad blocker check box not checked".
When I press space, it Checked.
Now, screen readers says:
Enable ad blocker check box not checked button.
I think that this kind of button near checkbox conflicting, and space key wont check or uncheck the box.
This is temporary tutorial version, soon we'll have whole new tutorial window and it should be working there.

I've created an issue on the github just in case:
https://github.com/AdguardTeam/AdguardForWindows/issues/297

Finally, my another question regarding tranlation.
I am translator, but I dont seeing AdGuard for Windows on available projects.
What should I do?
I've alerted vasiliy_bagirov about it, he'll grant you the role so you can see AG for Windows project in translation management system.

---------- Post added at 05:47 AM ---------- Previous post was at 05:46 AM ----------

If you disable internet connection and try to update filters manually, an error will show up. However 'Filters has been updated 1 minute ago' in main window will show up anyway.
We again return to this question - how we should properly name it?
This is not update time, but "last update check time".

---------- Post added at 05:50 AM ---------- Previous post was at 05:47 AM ----------

Sadly the support form doesn't inform the user he/she reached limit of the message.
Isn't it obvious?

EDIT: My test message #WHJ-763-69579 included html code, but it is not in the actual ticket.
https://github.com/AdguardTeam/AdguardForWindows/issues/298

---------- Post added at 05:51 AM ---------- Previous post was at 05:50 AM ----------

Yes this has happened to me updating in win 10
Tried everything but no success
Been told to do a manual uninstall
I like I tried that and they did not work too
Manual uninstall has not fixed the install problem?
Then we'll need installer logs to check what's wrong:
https://kb.adguard.com/index.php?/Knowledgebase/Article/View/57/9/collecting-adguard-for-windows-installation-logs

---------- Post added at 05:51 AM ---------- Previous post was at 05:51 AM ----------

sys tray Icon is missing and I cannot start the gui. Anyone the same problem after the update under win 10 and insider build? Setup told me that adguard is already installed
What happens to GUI when you start it?
 

l0rdraiden

Beta Tester
I was looking at the beta yesterday and I miss some of these list (I know you can add them manually but it would be nice to have them by default)

Malvertising filter list by Disconnect‎ : 0 used out of ?
T Malware Domain List‎ (malwaredomainlist.com): 1,487 used out of 1,487httppurge cache
Malware domains‎ (www.malwaredomains.com): 10,617 used out of 10,683httppurge cache
Malware domains (long-lived)‎ (www.malwaredomains.com): 0 used out of ?http
Malware filter list by Disconnect‎ : 0 used out of ?
Spam404‎ (www.spam404.com): 0 used out of ?

This has been taken from ublock.

Regarding the interface IMO is a pain to have to scroll down all the time to see the list or the options/settings. Make the main window resizable, or make the stuff inside the window smaller, I think the interface has been simplified too much and is meant for touch screens.

I would like to see as well the number of items in a list, the items being used, the duplicated ones and the number of blocks that each list produces, this should appear in the panel where the active lists are. And the same but with global numbers (all lists) in Main screen.

A quick question to finish, how does compare Easylist+EasyPrivacy vs Adguard English default list? do I need both?
 
Last edited by a moderator:

agasoft

Beta Tester
Thanks. Hope it happen soon. I even alerted him via support ticket 2 days ago, but still no response.
I encountering another problem.
When stealth mode is enabled with all corresponding options, I am not able to login to the microsoft community, even I am loged in on my Microsoft account.
 

mysteriously

Beta Tester & Translator
Ok I know why is it, the problem is that we cannot detect windows user if the browser is in the sandbox:
https://github.com/AdguardTeam/AdguardForWindows/issues/296
Right, that was 'almost' obvious :)
We again return to this question - how we should properly name it?
This is not update time, but "last update check time".
Main window displays "Filters were updated X minutes ago".
Maybe "Filters updates have been checked X minutes ago"

Latest filters update check: hh.MM like 16:24 <- workaround for X minutes/hours ago issue
Latest filters update check at hh.MM.ss
Latest filters update check yesterday
Latest filters update check on Monday

Extensions
Installed: 5 enabled: 3

Ad blocker
Enabled filters: 7

I guess you don't want to clutter Adguard code with X minutes/hours ago etc. strings for various languages.
 
Last edited by a moderator:
Status
Not open for further replies.
Top