[AdGuard for Windows] Beta version 6.0.67.364

Status
Not open for further replies.

ouzbed

New Member
hi,

the beta version works well for me, performance is better than the previous alpha version (with a gigabit ISP).

a quick note, touch scrolling isn't working on app list (the one to add apps to be add blocked).
 

mysteriously

Beta Tester & Translator
Filters check/update time in main window does not update for me with latest Adguard beta version unless I manually check for filters updates. I don't think this is caused by loosing internet connection problems I have lately.
 

avatar

Administrator
Staff member
Administrator
You didn't understand me. I don't want separate windows. I meant that the main GUI is opened beneath the Check updates, Support, License and About windows. So when I close, for instance Check updates window, I have to close also the main GUI window. Why the main GUI window is opened in the background together with the said 4 options? The main GUI window is redundant in these cases. That's my point.
Ideally we shouldn't open main window on these tray icon actions.
Instead we should show small progress window somewhere in the tray area instead.

I've created an issue on github, but it's planned on 6.1 version:
https://github.com/AdguardTeam/AdguardForWindows/issues/314

---------- Post added at 10:55 PM ---------- Previous post was at 10:54 PM ----------

a quick note, touch scrolling isn't working on app list (the one to add apps to be add blocked).
Thanks!

https://github.com/AdguardTeam/AdguardForWindows/issues/315

---------- Post added at 10:57 PM ---------- Previous post was at 10:55 PM ----------

Filters check/update time in main window does not update for me with latest Adguard beta version unless I manually check for filters updates. I don't think this is caused by loosing internet connection problems I have lately.
Why not? AG won't check filter updates until it has working internet connection.
 

mysteriously

Beta Tester & Translator
Because I usually lost internet connection for 2-5 minutes and Adguard has not checked for filters updates for few days.
BTW: English time and date format is used in Ad blocker tab
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
BTW: English time and date format is used in Ad blocker tab
https://github.com/AdguardTeam/AdguardForWindows/issues/320

---------- Post added at 11:37 AM ---------- Previous post was at 11:35 AM ----------

Does "Hide your referrer from third parties" blocks google captcha? Happens for me in http://kgmoa.org/register
Seems it does. We should fix this in our filters:
https://github.com/AdguardTeam/ExperimentalFilter/issues/796
 

Blaz

Moderator & Translator
Staff member
Moderator
String "#7059262 " got changed back from "BETA" to "ALPHA". Seems to be an error to me and therefore haven't reverted in German translation.
 

ShakedBenratzon

New Member
I talked with ESET and they told me it is not their problem >,<

I do not get it why this 2 program can not work tougher did you guys tried to talk with them and solve it

I tried to disable SSL filter but it did not help website are still freeze in the load or load very slow on Edge browser

Any Idea ?

Btw when do you expect to release Adguard V6 ? ant ETA ?
 

mysteriously

Beta Tester & Translator
Adguard's 'Reinstall certificate' function does not check if cert8.db exist in %AppData%\Roaming\Mozilla\Firefox\Profiles\<profile name> and reports reinstallation success.

ShakedBenratzon@: Did you try to report it on ESET forum?
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
When protection is disabled and I open Google Chrome to https://news.google.com/ the site is still using Adguard's CA even through protection is disabled. That shouldn't be, should it?
Protection enable/disable does not stop Adguard from network filtering. To disable it you should close Adguard.

We do this to fix the issue with unfiltered connections (in v5 when you disable and then re-enable protection some alive connections may stay unfiltered).

---------- Post added at 02:04 PM ---------- Previous post was at 02:00 PM ----------

I talked with ESET and they told me it is not their problem >,<

I do not get it why this 2 program can not work tougher did you guys tried to talk with them and solve it
The next beta will bring some important changes in the WFP driver.
I can't guarantee that the problem is fixed but it's worth trying.

Btw when do you expect to release Adguard V6 ? ant ETA ?
There are still 57 open issues:
https://github.com/AdguardTeam/AdguardForWindows/issues?q=is:open+is:issue+milestone:"6.0+release"

I think we'll close all in a month or so.

---------- Post added at 02:05 PM ---------- Previous post was at 02:04 PM ----------

Adguard's 'Reinstall certificate' function does not check if cert8.db exist in %AppData%\Roaming\Mozilla\Firefox\Profiles\<profile name> and reports reinstallation success.
I am sure it does the check, why do you think it's ignored?
 

Boo Berry

Moderator + Beta Tester
Moderator
The next beta will bring some important changes in the WFP driver.
I can't guarantee that the problem is fixed but it's worth trying.
Ahh, like what kind of changes? Can't wait to test it!

P.S. Anything new with the YouTube+ userscript thing?
 

mysteriously

Beta Tester & Translator
Protection enable/disable does not stop Adguard from network filtering. To disable it you should close Adguard.

We do this to fix the issue with unfiltered connections (in v5 when you disable and then re-enable protection some alive connections may stay unfiltered).
Ah, I was wondering why the service still used cpu resources when Adguard protection was 'paused'.
I am sure it does the check, why do you think it's ignored?
Ok, so maybe it checks but ignores checking result or there is some other issue. Error about missing %AppData%\Mozilla\Firefox\Profiles\<profile name>\cert8.db does not show up.
https://youtu.be/bTQ4WasWxKw
 

avatar

Administrator
Staff member
Administrator
avatar, about the mentioned string at oneskyapp?
I've alerted @Confessor, let's wait for his answer.

---------- Post added at 11:32 AM ---------- Previous post was at 11:28 AM ----------

Ok, so maybe it checks but ignores checking result or there is some other issue. Error about missing %AppData%\Mozilla\Firefox\Profiles\<profile name>\cert8.db does not show up.
https://youtu.be/bTQ4WasWxKw
But that's right, AG does patch cert8.db, not creates a new one (it should be done by the Firefox).

This case on video is possible only if the user will delete cert8.db file himself, but I suppose it should not be often in the real life:)
 

mysteriously

Beta Tester & Translator
Yes, FF creates new cert database at next startup. Yep, I deleted the file, looks like ESET had some issue with SSL pages, but only out of sandbox (which is weird because Sandboxie has direct access to cert8.db). Now works fine
:)
 

Blaz

Moderator & Translator
Staff member
Moderator
You may rename the string "Remove confirmation" to "Remove subscription" or else a user could think if he/she clicks on Yes/OK the confirmation is never shown again.
 

Blaz

Moderator & Translator
Staff member
Moderator
When disabling a lot of Filter rules in the subscription and then click on Enable all, Adguard hangs over 5 minutes. Would be nice if it is possible to speed it up a bit.
 
Last edited by a moderator:
Status
Not open for further replies.
Top