[AdGuard for Windows] v6.1.258.1302 RC

Status
Not open for further replies.

avatar

Administrator
Staff member
Administrator
Still it should be possible (maybe add an option to enable blocking it with a warning it can cause browsing slowdown).
I disagree, basic rules are supposed to block web requests and data:image thing is not it. It can be blocked with `$$` or `##` rules though.
 

Blaz

Moderator & Translator
Staff member
Moderator
$$ rules are not supported by extension and sometimes you can't make a clear selection with ##.
 

Blaz

Moderator & Translator
Staff member
Moderator
If there are a lot of legit pictures with data:image and only one with bad content it is not wise to use such rule and then excluding all other images manually.
 

avatar

Administrator
Staff member
Administrator
If there are a lot of legit pictures with data:image and only one with bad content it is not wise to use such rule and then excluding all other images manually.
The change of collision is really tiny if the substring you use is long enough (i think length of 16 is more than enough).
 

Blaz

Moderator & Translator
Staff member
Moderator
Rarely I have the following bug in Adguard for Windows:

In Chrome Extension (integration mode) I set a site to exclusion to test something, then I set it back and now the whole document is excluded. Checked user filter and no such filter there.
Then I switch to another browser with no Extension and still whitelisted.

Already closed Adguard and started it new. Even when I stop Adguard service and restart the same error :(

Log files:
https://www.sendspace.com/file/n0a4vn
 

avatar

Administrator
Staff member
Administrator
It seems we don't log enough to understand what's wrong.

Already closed Adguard and started it new. Even when I stop Adguard service and restart the same error :(
So when the issue disappears?
 

Eli

Beta Tester
Hello everyone,

I'm currently running beta version 6.1.252.1283, whenever I attempt to upgrade to the latest beta posted on this thread it always throws up the message "Adguard is already installed" no matter what I try, I even attempted totally removing the application and re-installing it, when I try that it puts me back in version 6.1.252.1283, when I right click on the system tray it says there's an update available when I click on "Update" it says on "Starting Update" forever and it looks like it can never find or download anything.

Am I doing something wrong? how do I get out of this loop? is it that as a beta tester I'm not allowed anything above the version I'm currently on? any help would be appreciated.
 

vasily_bagirov

Administrator
Staff member
Administrator
@Eli Sorry for the delayed reply.

This is strange, considering this version has become a release. If you are still in the loop and can't update to it, or uninstall and perform a fresh install, here's one thing you can do:
go to this page and do the 'standard' uninstall, then the 'advanced' uninstall, following the guide on the page. Then install Adguard again, using the download button from the main page of adguard.com.

Let us know if it helps you.
 
Status
Not open for further replies.
Top