AdGuard for Windows v6.1.258

Discussion in 'Release Notes (AdGuard for Windows)' started by vasily_bagirov, Aug 31, 2016.

Thread Status:
Not open for further replies.
  1. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,905
    Briefly about new Adguard for Windows version: Stealth Mode got new useful options, userscripts work better now, ad blocking became more advanced and our network drivers - more stable. All the details are below.

    Stealth Mode

    [Added] "Self destructing cookies" option in Stealth Mode #678

    Previously Stealth Mode module provided only the option to completely block third-party cookies. Now you will not only have an ability to differ first- and third-party cookies, but also the ability to set the exact time which cookies will be kept alive for. Important note: you can still block cookies alltogether, just set the keep-alive time to '0'.

    [Added] Added an option to block "Browser location API" #139
    [Added] Added an option to block "Browser notifications API" #1121


    Normally browsers may detect your location and use this information to prioritize specific search results or make other various suggestions based on it. With browser location API blocked this will be impossible.
    Blocking browser notifications API feature works somewhat similar, but rather prevents browser from showing things like news or social media frames that pop-up in the corner of your browser.

    Userscripts

    [Improved] Content injection algorithm #1099

    We completely redesigned content injection algorithm. First and foremost, this should solve issues with scripts that start when the page opens, resolve some of the known conflicts (AdsBypasser, YouTube+), and also optimize usage of scripts and ad blocker styles. Overall, a technical, but very important change.

    [Added] Userscripts handling #1172

    We adopted a new way of handling user.js (userscript) files. Now Adguard will automatically detect when user.js file was processed. If it is a valid userscript, Adguard will open a dialog window, offering user to install it. Of course, this setting will be optional and possible to turn off through settings.

    UI

    [Added] Hebrew localization, Dutch localization #1076, #1063

    We continue to make Adguard more easily accessible for users all over the world. This time we add two more new localizations and fix some mistakes in already existing ones.

    Networking

    [Improved] Network SDK was updated #1179

    In reality, this implies many various fixes that concern our network drivers. It would be hard to list them all here, and most of them are rather technical anyway. For example, the WFP driver - Windows Defender compatibility issue was addressed.

    Ad Blocking

    [Added] Support for extended selectors #1225

    This is a technical term, but what hides behind it? With extended selectors support, we can much more easily create some rules that were very, very hard to create earlier. Notably, this concerns rules required to block such things as 'Sponsored posts' on Facebook.

    [Added] Extended CSS support https://github.com/AdguardTeam/ExtendedCss

    This is a very important addition in terms of future (and present) possibilities that it opens for ad blocking. Extended CSS is a module for applying CSS styles with extended selection properties. Basically, it means that we will be able to select and, therefore, block some elements that we would not be able to block otherwise. Currently we support following pseudo-classes: -ext-has ( :has ), -ext-contains ( :contains ), -ext-matches-css ( :matches-css ).

    Other

    Dozens of minor fixes and improvements.
     
    Last edited: Aug 31, 2016
  2. Venky

    Venky Beta Tester

    Joined:
    Jul 19, 2013
    Messages:
    151
    Looks like lot of useful changes...can't wait to try it out!
     
  3. caleb59

    caleb59 Member

    Joined:
    May 14, 2016
    Messages:
    171
  4. Petrovic

    Petrovic Alpha Tester

    Joined:
    Dec 21, 2013
    Messages:
    1,883
  5. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,060
    The incompatibility still exists - disable SSL scan in ESS or disable the WFP driver. This *should* be fixed/worked around once and for all with a new WFP driver that's in development (but AFAIK, is still in the alpha stage).
     
    caleb59 likes this.
  6. Rik

    Rik Beta Tester

    Joined:
    Jun 13, 2016
    Messages:
    72
    Hello Vasily / Boo Berry,
    I see that the official release has exactly the same number and size/bytes as the last RC.
    As you know there are YouTube-issues which I tested on for hours and reported on extensivily in the forum, see last sunday in the Windows beta/rc-release section and days before.
    Since I got no reaction on my larger test-report from last sunday , I presume that the Internet Explorer 11/YouTube-bug is still present in the official release, so it makes little sense to install it for me.
    Can you give me some feedback on this bug as it is not present in the last official 6.0.226.1108 release where YouTube runs perfect on IE11
    Thanks.
     
  7. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,143
    @Rik it's my bad, I've completely missed this issue, sorry for this.

    However, I cannot reproduce it on my side. Is it possible for me to take a look at this issue through teamviewer?
     
  8. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,143
  9. Rik

    Rik Beta Tester

    Joined:
    Jun 13, 2016
    Messages:
    72
    Hello, thanks for your reply :)
    Important ?.... Yes and no :rolleyes:
    Yes...
    Well, in many of my cases also shorter YTvideos have 2 or 3 pauses still in the video-clip itself near the end , and even crashes before the end is reached (see copy of screen I attached earlier in the beta-forum), so the music-clips are interrupted. If you use YouTube-playlists like me, that's not so pleasant to listen to...
    From the fact that with Adguard 6.0, the videos play flawlessly (I really never had this issue with 6.0), I assume there's a possible solution to be found for this bug as the cause must be a difference between 6.0 and 6.1.
    I think also that frequent YouTube-users with Internet Explorer 11 who have a slower internet-connection will have larger impact, because the additional buffering will be triggered cq. fulfilled slower... As a beta-tester I try to think about as many users possible (at work I do the same for the banking-apps we make for KBC Bank in Belgium - call it "professional deformation" from my daily business ;):oops:
    No...
    I can always use YouTube in Firefox on my Windows7-PC as an alternative, because there is no impact in that browser from 6.1 , and of course also on my samsung android tablet I can stream-cast perfectly YT-videos to my sony-tv with Adguard 2.7.220 - that works great !! :)
    Thanks for your concern.
     
  10. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,143
    Oh I see, that's the difference between our cases: in my case it never pauses and continues preloading before video reaches the end of the preloaded buffer.

    Do you have that pause/crash issue with every video or it happens randomly?
     
  11. Rik

    Rik Beta Tester

    Joined:
    Jun 13, 2016
    Messages:
    72
    I have a fast internet-connection between 150-200 mbps stable LAN. In most of the YouTube-videos (let's say music videos from 3 to 5 minutes) it happens with IE 11...
    When playing with Aguard 6.1 ON the pre-loading builds up to aproximate 20 seconds before the end of the clip (the buffer-white line when you hoover it) and then the preload-buffering stops ...(IE11 with Adguard 6.0 preloads right till the end and also Firefox with Adguard 6.1 preloads right untill the end)
    - the video plays flawless in IE11 untill it reaches that point (20 secs before the end) and then of course the rest of the buffering is triggered, which explains the 1st short stop in playing, the playing restarts but again reaches the new buffering point very soon, which explains the 2nd stop in playing the clip, and then the grey-crash-screen follows (see earlier upload).
     
  12. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,143
    Just in case, could you please try adding googlevideo.com to HTTPS exclusions list in Adguard and see if it changes anything?
     
    Rik likes this.
  13. Rik

    Rik Beta Tester

    Joined:
    Jun 13, 2016
    Messages:
    72
    Hello Andrey, I hadn't too much time to test this evening, but I think you hit the right solution.
    I did a clean install of the new 6.1, and added googlevideo.com to the HTTPS exclusions list. I played five YouTube-clips, who used to crash the last weeks at the end in IE11, and .... the buffering goes right till the end now and the clips play perfectly (no stops, no crash).
    I will do some extra tests during the weekend (I'll let you know if it should happen again), but I think you solved the problem.
    Thanks for your time & concern about this :)
    Thumbs up for your solution :cool:
     
  14. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,143
    Hm, in fact this proves that the issue exists, it's just hard to say what's causing it.

    I am glad we've found a temporary solution, though:)
     
  15. Dustyn

    Dustyn New Member

    Joined:
    Mar 28, 2016
    Messages:
    19
    Thanks for the update! ;)
    Installed and working beautifully. :)

    The best Ad-blocker out there in my opinion, I have been unable to find anything better! :D
     
    avatar likes this.
  16. Не забудьте исправить баг #857
     
  17. Gass

    Gass Member

    Joined:
    Jan 30, 2015
    Messages:
    437
    TRANSLATED = Do not forget to fix bug # 857
    Gass
     
  18. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,905
    Как я уже не раз, не два, и не три говорил - майлстоун для задачи стоит 6.2.
     
  19. Lucky86

    Lucky86 New Member

    Joined:
    Jul 4, 2016
    Messages:
    82
    Adguard for the past few days have completely stopped blocking ads in my Windows 10 lappy. I have no idea how this happen suddenly. It was working fine for so many years. I did nothing to settings or installed any new software, the application is also looking fine. Just not blocking ads. Its stats show similar figure all the time. I'm using the latest version of it. Can anybody of help to me in this case?

    Thanks

    Regards
     
    MIPCLP likes this.
  20. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,905
    @Lucky86 Hi! Sorry for taking this long to respond.

    Let me ask few questions here.

    1) What exactly Adguard version do you use? What browser(s)? What browsers does the problem appear in, and what browsers does it not?

    2) Are ads not blocked on all websites, or https websites only? (or maybe just some particular websites?)

    3) What exactly Windows build do you have at the moment?

    4) Finally, have you tried to reinstall Adguard? It probably won't help, but still worth trying.
     
Thread Status:
Not open for further replies.