[AdGuard for Windows] v6.1.296 R4 release candidate

Discussion in 'Release Notes (Beta Versions)' started by vasily_bagirov, Oct 11, 2016.

Thread Status:
Not open for further replies.
  1. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,905
    Update: release candidate 6.1.296 R4

    We thought we had fixed userscript handling in previous RC, but, as it turned out, the fix was not complete. New release candidate, hopefully, finishes the job.

    [Fixed] AdsBypasser and other userscripts do not work properly when added to Adguard #1363

    You can find the full description on GitHub: https://github.com/AdguardTeam/AdguardForWindows/releases

    And download it at this link: https://github.com/AdguardTeam/AdguardForWindows/releases/download/v6.1.296.1549-rc/Setup.exe

    Update: release candidate 6.1.294 R3

    In this release candidate there are only minimal (yet necessary) changes that mostly concern userscripts handling.


    Update: release candidate 6.1.290 R2

    An urgent fix for a major IPv6 filtering bug. A couple of other fixes thrown in as well.

    [Fixed] Bug preventing Adguard from filtering IPv6 #1389

    Not much to add here. Accidentally, we have disabled filtering for all IPv6 addresses in the last release candidate. This version fixes this major bug.

    [Changed] ALYac app added to the list of apps filtered by default #1344
    [Changed] Salam Browser added to the list of apps filtered by default #1347
    [Fixed] $replace rule is shown as applied to images #1392
    [Fixed] 'access-control-allow-origin' header console error #1381
    [Fixed] Adsbypasser and some other userscripts do not work properly #1363
    [Improved] HTTPS is now used for safebrowsing service requests #1386

    Update: release candidate 6.1.287 R2

    This is a release candidate, so, as it is often true for RCs, pretty much only technical fixes here. Worth noting that we went further with Web of Trust extension and added the option to remove it altogether, and not only disable.

    Networking

    [Changed] Loopback IPv6 connections are not filtered now (Visual Studio remote debugging bug) #1373
    [Fixed] $replace modifier breaks content charset #1378
    [Fixed] "Enable safe search" function in Parental Control breaks Google #1383
    [Fixed] Adguard doesn't filter HTTPs when Fiddler is switched on and in "decode https" mode #1372
    [Fixed] Adding a URL to temporary HTTPs exceptions is suppressed now when connection is closed from the server side #1341
    [Improved] Encrypted connection is used now with api.adguard.com #1369

    UI

    [Added] An option to remove WoT extension #1364
    [Fixed] Adguard crashes if you try to close UI while editing a filter rule #1258

    Update: 6.1.281.1494 R2 beta

    New beta fixes several bugs and makes some changes to UI. Also, recent WoT controversy is addressed by making WoT extension disabled by default.

    [Changed] WOT extension is now disabled by default #1364

    Recently, an article was posted in one of the popular technology blogs, claiming that Web of Trust is selling its users' browser history to third-parties. WoT extension is preinstalled in Adguard for Windows, and although it was developed by us and is not sending any of your data to WoT, we can not leave this without a reponse. For this reason we make WoT extension disabled by default in Adguard for Windows. You can read our official stance regarding these news in our blog.

    Ad Blocking

    [Fixed] Inconsistent $replace result #1358

    Networking

    [Changed] WoSign and StartCom certificates are now distrusted #1359
    [Fixed] $empty modifier behaviour #1360
    [Fixed] Stealth mode ignores $stealth exception #1362
    [Fixed] Inability to apply inline style #1331
    [Fixed] Filters update check period issue #941
    [Fixed] An empty 'style' tag is added even if there's no element hiding #1336
    [Improved] Adguard styles are now protected from removing #1272

    UI

    [Changed] Unnecessary text in 'Import rules' dialog window is removed #1349
    [Fixed] Filter's name isn't copied with the rest of request details #1318
    [Fixed] Button size issue on the last step of Adguard wizard #1352

    Update: 6.1.278.1411 R2 beta

    A small beta to add a new modifier and fix some known bugs.

    [Added] $important modifier #1312

    This new addition is an important one (no pun intended), but mostly relevant for creators of custom filter rules. With it's help you can give certain rules higher priority.

    Ad blocking

    [Fixed] HTTPS exceptions do not cover subdomains #1317
    [Fixed] $replace rule can now be applied along with the other rules #640

    Networking

    [Changed] Proxy mode will use IPv4 address when it is available from now on #1323
    [Fixed] Adguard code is injected into a non-HTML document #1316
    [Fixed] SSL exceptions aren't deleted on network API reinit #1304
    [Fixed] Inline style can't be applied because it violates the Content Security Policy directive #1330
    [Fixed] WFP driver impacting DPC latency #1156

    UI

    [Fixed] Filter's name is now copied with the rest of request details #1318

    Update: 6.1.273.1479 R2 beta

    A hotfix for the yesterday's beta release. A couple of urgent issues were addressed.

    [Fixed] "SEC_ERROR_BAD_SIGNATURE" problem in Firefox
    [Fixed] Issue with Proxy mode and IPv6 addresses #1314

    Update: 6.1.271.1366 R2

    We haven't released any beta versions in a while, as it does often happen after a new release. We were monitoring it for any bugs, and quite a few are fixed in this beta. Other changes and improvements are also present, but none of them are really huge enough to deserve a special mention.

    Ad Blocking

    [Changed] KMPlayer added to the list of apps filtered by default #1280
    [Changed] steamwebhelper.exe added to the list of apps filtered by default #1230
    [Changed] PotPlayer added to the list of apps filtered by default #1274
    [Changed] AceStream Engine added to the list of apps filtered by default #1236
    [Fixed] Adguard now filters pages with Content-Type:application/xhtml #571
    [Improved] Adguard now can partially filter HTTPs ads without decrypting SSL protocol (if HTTPs filtering is disabled) #1233
    [Improved] Filters update check period is now customizable #941

    Networking
    [Changed] Switched to the DigiCert certificate #1268
    [Fixed] CSP is now handled in meta tags #797
    [Fixed] Issue with invalid HTML #1222
    [Fixed] "iframe" elements are not removed from the page code #1245
    [Fixed] Adguard.Tools.exe heavy CPU load issue #1229
    [Fixed] Opera dev ad blocker compatibility issue with Adguard Assistant #1173
    [Fixed] Opera built-in VPN compatibility issue #1116
    [Fixed] Certificate validity check order #1277
    [Improved] Content type detection #1264
    [Improved] Content injection algorithm #1099
    [Improved] ContentScript approach is now used for injected content #1305


    Install/Update
    [Fixed] Deleted records from HTTPs exclusions are not restored on app update anymore #904

    Minor
    [Added] $websocket content type modifier #1302
    [Changed] Removed Firefox & Opera SSL filtering workaround #1278
    [Changed] "Stealth mode" scripts are moved to a file #1212
    [Changed] HTTPs exclusions updated #1283
    [Changed] 'Search filter' textbox width made fixed #1214
    [Fixed] UI issue with right-click paste #1254
    [Fixed] Incorrect information about User filter updates #1239
    [Fixed] Adguard crashes if you try to close UI while editing a filter rule #1258
    [Fixed] HTTPs requests are displayed as HTTP in filtering log #1237
    [Fixed] Can not transform CSP #1266
    [Fixed] Request URL contains wrong protocol prefix #1263
    [Fixed] Incorrect Adguard injection #1275
    [Fixed] SaveFrom.net userscript does not work in Adguard #882
    [Fixed] Userscript '@match' rule does not support '<all_urls>' pattern #1294
    [Fixed] Issues with several userscripts #1259
    [Fixed] Adsbypasser bug on openload.co #1247
    [Fixed] Some rules were not converted properly #1281
    [Improved] Selection style in settings was made more readable #772
     
    Last edited: Nov 28, 2016
    registradus likes this.
  2. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,750
    Great work, installed fine.
     
  3. Phonemes

    Phonemes Member

    Joined:
    Mar 15, 2014
    Messages:
    274
    Something is wrong with this beta for me using Firefox. Some pages are not displaying correctly.
    The layout of http://avxhome.in/music is completely messed up.
    No images whatsoever are loading on http://dieordiy2.blogspot.nl/ and http://jazzblogwatch.blogspot.nl/
    And I can't connect to this forum, it comes up with a SEC_ERROR_BAD_SIGNATURE message.

    I tried reinstalling the certificate twice. Rebooting the computer did not cure the problem.
    Using IE I have no problem reaching the forum and the above sites display properly (except for http://jazzblogwatch.blogspot.nl, which is messed up in IE).
     
  4. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,052
    Can't reproduce, all those sites work fine here.
     
  5. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,750
    Tested all three sites with my Firefox and no issue.
     
  6. Rik

    Rik Beta Tester

    Joined:
    Jun 13, 2016
    Messages:
    72
    I can confirm the issues with this new Adguard-version with the Facebook-site also:
    Internet Explorer 11 : no problem / Firefox gives a SEC_ERROR_BAD_SIGNATURE message and I can't log in :(
    Rik
     
    Last edited: Oct 11, 2016
  7. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,052
    Strange, Facebook in Firefox works fine here.
     
  8. Rik

    Rik Beta Tester

    Joined:
    Jun 13, 2016
    Messages:
    72
    @avatar
    I refer to earlier issues with IE 11 en playing YouTube-videos , namely the buffering-problem at the end of videos (stops & crash)
    https://github.com/AdguardTeam/AdguardForWindows/issues/1269
    The problem gets even worse with the new version... because your temporary solution (adding googlevideo.com to the HTTPS-exclusion-list, remember...) doesn't solve the problem no more. Please help me out.
    Rik

    When I deactivate the new Adguard, Facebook works fine on Firefox. In the 6.1.258.1302-version everything worked fine with Facebook on Firefox.

    The new Adguard-beta even blocks the YouTube-site totally on Firefox (no problem in IE11) , see screen - Adguard should block advertisments, not entire sites , isn't it ?? :confused:
    I think I will return to 6.1.258....

    I tested a few URL's all starting with HTTPS , and the new Adguard-beta blocks all of them (even PayPal !) on Firefox (no issue on IE11) , even your OWN site !! (see screen-capture)
     

    Attached Files:

    Last edited by a moderator: Oct 11, 2016
  9. GollyJer

    GollyJer New Member

    Joined:
    Feb 8, 2016
    Messages:
    14
    Just want to give you guys a heads up. As of Windows 10's newest build (14942) Adguard completely breaks internet connectivity. I tested with this newest beta in case it fixed things, but it didn't. I had to disable Adguard completely to use any browser.
     
  10. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,750
    Had open Filter Editor in Background, pressed Win+D to minimize everything and then Adguard crashed (first time and can't reproduce atm). I installed latest Intel Graphic Cards driver before and didn't restart yet, maybe that is somehow interfering.
    Code:
    Adguard.exe
    6.1.271.1366
    57fd042a
    igdumdim32.dll
    20.19.15.4501
    57acf438
    c0000005
    00024b37
    184c
    01d22458cb743376
    C:\Program Files (x86)\Adguard\Adguard.exe
    C:\WINDOWS\SYSTEM32\igdumdim32.dll
    60c3bc62-963d-4832-998d-a037bf6743eb
    
    Crash dump file (too big to attach):
    Code:
    https://www.sendspace.com/file/72kdwo
    
     
    Last edited: Oct 12, 2016
  11. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,143
    According to the screenshot these are two different elements (look at the code, quotes are escaped in the second one.
     
  12. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,143
    @Phonemes @Rik

    Could we arrange a remote access session with you? Please PM me if you are ok with it.

    I'd like to take a closer look at the issues.
     
  13. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,143
    This is a known issue of the latest insider preview build.

    WFP is completely broken there:
    https://forum.adguard.com/index.php...t-windows-10-insider-fast-ring-release.14637/

    Waiting for MS guys to fix it.
     
  14. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,143
    @Phonemes @Rik

    It seems that SEC_ERROR_BAD_SIGNATURE error is how FF reacts on an unknown certificate.

    So, here are the problems:
    1. Certificate reinstall button does not restart FF (while it should have). So, before clicking this button you should close FF manually.
    2. I don't understand what happened to the certificate on AG update. It shouldn't have been changed.
     
  15. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,143
    Oh my, certificate automatic import to FF is simply broken in this version.

    Next beta is coming very soon.
     
  16. Phonemes

    Phonemes Member

    Joined:
    Mar 15, 2014
    Messages:
    274
    @Andrey,

    I did close FF before reinstalling the certificate. Just tried it again, but it doesn't help.
    I am getting these SEC_ERROR_BAD_SIGNATURE messages on several sites now, including my bank.

    Awaiting the new beta. Do you want remote access now or do you prefer to wait until the new beta is out?
     
  17. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,143
    Without automatic import it won't help:( Will be fixed soon in the new build.
     
  18. Phonemes

    Phonemes Member

    Joined:
    Mar 15, 2014
    Messages:
    274
    OK, I'll wait for the new build then.
     
  19. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,052
    As far as I know, you can still manually import the certificate to Firefox.
     
  20. Rik

    Rik Beta Tester

    Joined:
    Jun 13, 2016
    Messages:
    72
    @avatar
    Hello, same situation as Phonemes & no solution with reinstall of the certificate over here - I was sure there was something fundamentally wrong with this bèta regarding Firefox.
    Thank you very much for quick action & looking forward to the new bèta :)
    Hope the new beta also works again with the google-video.com-workaround you proposed, regarding the YouTube-issue on IE11
     
Thread Status:
Not open for further replies.