[AdGuard for Windows] v6.1.296 R4 release candidate

Status
Not open for further replies.

Boo Berry

Moderator + Beta Tester
Moderator
Okay, it seems to be more-or-less reproducible by using Chrome and Edge at the same time - load pages in both, close and reopen Edge and it eventually resets in Edge (and Chrome when you restart it). I was able to save HARs from Chrome and Edge. I'll PM you the links.
 

Boo Berry

Moderator + Beta Tester
Moderator
Should fix this! This is in chrome.

It's a warning about the security (https) of the page.
Where? I'm not seeing any warnings about this unless I look at the connection details (in Chrome's developer tools > Security section) on a HTTPS site.

This was kinda addressed in a single beta build a year or so ago (using a modern key exchange), but it caused an issue in Chrome where it'd cause HTTPS sites like Google and Google News to load very slowly and was reverted. @avatar is there any chance this could be attempted again? I'd like to see if the issue I noticed a year or so ago still exists when using a better key exchange.
 

Blaz

Moderator & Translator
Staff member
Moderator
If a $replace rule is active with important, normal url block rules are not active anymore it seems.
Had a $replace on overclockers.ru and advert.js was not blocked until I disabled $replace.

The searched patterns were not even active on the site anymore and Adguard still applied the $replace rule and therefore disabled url blocking rules. Behaviour should be modified.
 

Blaz

Moderator & Translator
Staff member
Moderator
http://winfuture.de/news,95280.html

It seems [-ext-has=''] doesn't check deeper the DOM tree when it encounters an iframe.

To hide "Interessante Android-Bücher" normally the following rule should work, but isn't.
winfuture.de###centerRightWrap > #rightWrap > .rightBx[-ext-has='div.amzwgt']

I had to put "iframe" into -ext-has field to make it work.
 

vasily_bagirov

Administrator
Staff member
Administrator
Okay, it seems to be more-or-less reproducible by using Chrome and Edge at the same time - load pages in both, close and reopen Edge and it eventually resets in Edge (and Chrome when you restart it). I was able to save HARs from Chrome and Edge. I'll PM you the links.
HAR files you PMed me didn't contain any useful information, unfortunately. I don't know what can be done, maybe a remote control session? I don't remember your stance on this :)
 

Blaz

Moderator & Translator
Staff member
Moderator
That is sad to hear not to have such experimental feature :(
 

Starchild1976

Beta Tester
this release runs smooth on both comodo dragon and comodo ice dragon , but it is a lot slower on edge , page rendering takes quite some time.
 

Boo Berry

Moderator + Beta Tester
Moderator
Well, if the WFP driver in Adguard is disabled, then no filtering for Microsoft Edge is possible. So no clue why Edge would be slower for you in that case since Adguard isn't even filtering it.
 

Starchild1976

Beta Tester
OK Thanks for clearing that up. Edge is just my backup browser , so it is no biggie for me. ;) the other two comodo browsers are fine with adguard and run snappy!!
 
Status
Not open for further replies.
Top