AdGuard install fails, no error message on Windows 11

dutch55

New Member
I attempted to install AdGuard blocker on a fresh copy of Windows 11 Dev Channel Build 22471. Previously AdGuard had been installed on Windows 10, and continued to work on Windows 11 releases provided by the Microsoft Windows 11 Dev Channel update process.

In order to get the fresh install configured with previous settings, i copied selected folders from App Data and Program Data to the new hierarchy, and installed programs. All worked except AdGuard, which aborts with no message quickly after launching. AdGuard does not appear in the control panel programs and features, and there is no installer program in the system.

There is a link to an AdGuard uninstaller executable on this KB under the Advanced heading: https://kb.adguard.com/en/windows/installation but the link is bad. It produces an error 404.

The text of the link is: https://cdn.adguard.com/public/Adguard/tools/Uninstall_Utility.zip" . Removing the last three characters, "%22" allows download of the file, Uninstall_Utility.zip. The uninstall.exe inside the zip file has both a basic and an advanced option, and advises to reboot after.

On my system, both basic and advanced run to completion, and several screens are displayed that disappear too quickly to read.

After running the uninstaller in both basic and advanced, followed by a reboot, the AdGuard installer still fails.

I have written to AdGuard Support but it has only been a couple of days but I have not received a response yet, so am posting here.

Has anybody successfully completed a new install of AdGuard on Windows 11? I also scanned the registry for references to AdGuard and removed them. Any suggestions?
 

a.shulgin

Quality Assurance
Staff member
Administrator
Moderator
Hi,

To transfer settings, you don't need to copy and paste files from AppData and ProgramData folders.

You can just export settings from AdGuard. To do this, go to Settings --> General Settings --> Export Settings and save file.

On Windows 11, delete all the AdGuard files and reinstall the version you need.
Then, to import settings to the new system, go to Settings --> General Settings --> Import Settings and select the previously exported file.
 

Nunow

New Member
same issue here, can´t install adguard with windows 11 dev 471!

made a clean install on my laptop, and the installation aborts with no message!

=/
 

Nunow

New Member
well, i tried installing with safe mode! turning off all defender options, etc

none worked!

installed latest beta and it worked!
 

dutch55

New Member
@a.shulgin, thank you very much for the response. First, I DID (or at least I think I did) delete "all the AdGuard files" and install failed.

Second, snce the Beta install worked, no problem, maybe you have already done what I am about to suggest, but in case not, I suggest you guys add an enhancement to the AdGuard install process to display an error message with whatever diagnostic info you have before aborting instead of aborting with no message.
 

a.shulgin

Quality Assurance
Staff member
Administrator
Moderator
@a.shulgin, thank you very much for the response. First, I DID (or at least I think I did) delete "all the AdGuard files" and install failed.

Second, snce the Beta install worked, no problem, maybe you have already done what I am about to suggest, but in case not, I suggest you guys add an enhancement to the AdGuard install process to display an error message with whatever diagnostic info you have before aborting instead of aborting with no message.
AdGuard displays an error message if something went wrong during installation and the app cannot be installed. If the application was suddenly closed, it most likely means that the installation process was interrupted.
Are you having installation problems now?
 

goods

New Member
same issue, windows 11 built 22471.1000. initial installer splash appears and disappears after 3-4 seconds. no error message. checking task manager i see the process appear then disappear within seconds.

i've tried running as admin, deleting any reference to adguard in the system, still does not install.
 

tatolino

New Member
I can't install Adguard on Windows11 too... webinstaller launches, the loading bar goes full, and it stays indefinitely, never complete installation. I think it doesn't even download the necessary files..? I tried running it as admin, turning off Bitdefender, nothing changes...
Is there any way I can download the full install package from somewhere?
Thanks
EDIT: found it on github https://github.com/AdguardTeam/AdguardForWindows/releases/
 
Last edited:

goods

New Member
I can't install Adguard on Windows11 too... webinstaller launches, the loading bar goes full, and it stays indefinitely, never complete installation. I think it doesn't even download the necessary files..? I tried running it as admin, turning off Bitdefender, nothing changes...
Is there any way I can download the full install package from somewhere?
Thanks
EDIT: found it on github https://github.com/AdguardTeam/AdguardForWindows/releases/
Thanks, was able to install with the direct installer package, appreciate it!
 

gewd

New Member
Greetings All,

RE: AdGuard install fails, no error message on Windows 10 Pro

Thanks for this post. I am currently testing AdGuard on Android and and also want to test on Windows which is where I would need it also. In trying to install it Windows 10 Pro, I am getting a similar error with just the installer bar filled up to 100% then just it stays on the screen with no error message.

I restarted the laptop, disconnected my VPN, and checked if my Antivirus triggered a firewall block which didn't happen so everything should be ok from my laptop perspective. I went back to the AdGuard site and re-downloaded the install file again started the install again, however getting the same error. I did notice that the install file was 32bit version and was trying find a 62bit version which is usually the bit versions I notices in other software install files.

I've attached a screenshot of error. Looking forward to any assistance to resolve so I can install and start testing as soon as possible.

Kind regards,
gewd (Privacy Protected)

P.S.: This was the only Windows OS thread I found mentioning this issue so rather than start a whole new one I just posted here first.
 

Attachments

Coffee Cake

New Member
I have written to AdGuard Support but it has only been a couple of days but I have not received a response yet, so am posting here.
Remember, there's a war in Ukraine right now. Some of the AdGuard team lives in Ukraine! Not to mention the legal minefield Adguard's probably dealing with, both from the Ukraine war itself and from the trade war between the United States and Russia.

I hope both wars ends soon, Ukraine recovers, and things can go back to normal. But for the time being: It's no surprise that it'd take longer than two days to get a reply from AdGuard Support!


Edit: Oops, I missed the date on the post I was replying to.
 
Last edited:

gewd

New Member
Greetings All,

RE: AdGuard install fails, no error message on Windows 10 Pro

Thanks for this post. I am currently testing AdGuard on Android and and also want to test on Windows which is where I would need it also. In trying to install it Windows 10 Pro, I am getting a similar error with just the installer bar filled up to 100% then just it stays on the screen with no error message.

I restarted the laptop, disconnected my VPN, and checked if my Antivirus triggered a firewall block which didn't happen so everything should be ok from my laptop perspective. I went back to the AdGuard site and re-downloaded the install file again started the install again, however getting the same error. I did notice that the install file was 32bit version and was trying find a 62bit version which is usually the bit versions I notices in other software install files.

I've attached a screenshot of error. Looking forward to any assistance to resolve so I can install and start testing as soon as possible.

Kind regards,
gewd (Privacy Protected)

P.S.: This was the only Windows OS thread I found mentioning this issue so rather than start a whole new one I just posted here first.
Greetings All,

I was able to resolve using @tatolino method of just downloading and installing the file from Github, AdGuard Windows Releases.

Something is definitely wrong with the AdGuard Product Page Windows Web Installer.

I hope the team looks into it and resolves when they get a chance.

Stay secure,
gewd (Privacy Protected
 
Top