AdGuard interfering with Wi-Fi calling on T-Mobile

Trillyana

New Member
Device: OnePlus 5

If I tried to make a call with AdGuard and Wi-Fi calling on, it would sound really high-pitched and garbled with no way to understand anything being said. I looked into this and found the solution for what I had to do, but it didn't give specific info for T-Mobile so I thought it would be helpful to post it.

Settings > Low Level Settings > pref.ipv4.routes.excluded
That list already had 208.54.0.0/16 excluded for T-Mobile Wi-Fi calling, but since I was still experiencing the issue I added the addresses on this page:
https://www.t-mobile.com/support/coverage/wi-fi-calling-on-a-corporate-network
208.54.0.0/17
66.94.0.0/19
206.29.177.36
crl.t-mobile.com

I'm not sure which of those fixed my issue, but it doesn't particularly matter to me so I'm leaving them all excluded. Wi-Fi calling works properly for me now with AdGuard enabled. I'm on a company phone plan so not sure if that's what it means by "a corporate network."
 

ram1220

Member
Well that sucks. I made a few phone calls yesterday and today on my wifi network and so far they have been clear. The only time I heard garbled speech and cutouts was when my buddy had his phone on hands free.
 
Top