AdGuard, interupting with Visual Studio Debugging

Menalix

New Member
For some reason when using Adguard with my PC.
I can not use my debugger on my pc for software development. VS will throw this error:
"The address is not valid for this context."
When trying to debug my project, what can I do? For now I have uninstalled Adguard, but well I paid for it and like to use it.. So I hope there's a better way so I can have Adguard and develop software next to.
 

vasily_bagirov

Administrator
Staff member
Administrator
@Menalix

Hello! Very unusual. Could you please provide more info? Like, what version of Adguard did you use? Did you manually add any processes to the list of filtered apps?

Also, what is your VS version? What exactly were you debugging, maybe an x64 application (just any information that can be useful for us in order to reproduce the issue)?
 

Menalix

New Member
@Menalix

Hello! Very unusual. Could you please provide more info? Like, what version of Adguard did you use? Did you manually add any processes to the list of filtered apps?

Also, what is your VS version? What exactly were you debugging, maybe an x64 application (just any information that can be useful for us in order to reproduce the issue)?
Adguard version: 6.1.258.1302
Visual Studio Community 2015, Version: 14.0.25431.01

x86 or x64, doesn't matter, when I press (start) for dedugging, I get the error immidiately, even though the debug build is build witthout errors, running the program in release mode works fine though.
This is the error:


I've tried, altering my debug options in various ways, but nothing helps.

I re-installed adguard to get the error once again to take the screenshot, which also confirms it is adguard's doing
 

avatar

Administrator
Staff member
Administrator
Does it happen for x86 build?

Ah, I see it does not.

Ok then, here is one more question.

Try doing the following:
1. Exit Adguard and stop Adguard's windows service (services.msc -> adguard service)
2. Restart Visual Studio
3. Run Adguard again
4. Try debugging after that
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
I re-installed adguard to get the error once again to take the screenshot, which also confirms it is adguard's doing
The thing is that we all also use VS and never encountered this issue.

However, you are the third person with the same complaint, so something is definitely wrong with AG here.
 

Menalix

New Member
Ok then, here is one more question.

Try doing the following:
1. Exit Adguard and stop Adguard's windows service (services.msc -> adguard service)
2. Restart Visual Studio
3. Run Adguard again
4. Try debugging after that
Then it works perfectly fine.

The thing is that we all also use VS and never encountered this issue.

However, you are the third person with the same complaint, so something is definitely wrong with AG here.
Then feel pleased to ask me questions that I cand do to help you counter the problem, I have good technical understanding on WinOS internals :) !
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
Then feel pleased to ask me questions that I cand do to help you counter the problem, I have good technical understanding on WinOS internals :) !
Heh, the thing is that I don't see anything suspicious in user mode. I guess something happens inside of the driver and it makes things more complicated.

Let's start with something simple: could you please try switching to another driver type? Adguard -> Settings -> Switch "Use WFP driver" checkbox.
 

Menalix

New Member
Heh, the thing is that I don't see anything suspicious in user mode. I guess something happens inside of the driver and it makes things more complicated.

Let's start with something simple: could you please try switching to another driver type? Adguard -> Settings -> Switch "Use WFP driver" checkbox.
That made VS debugging work, but a lot of web-pages on my chrome-browser is getting ERR_CONNECIOTN_RESET error, adguard is one of them as an example, so I had to re-disable the wfp driver.
Might have something to do with my anti-virus ESET NOD32 would be my guess? You know of a fix for that too ?
 

avatar

Administrator
Staff member
Administrator
That made VS debugging work, but a lot of web-pages on my chrome-browser is getting ERR_CONNECIOTN_RESET error, adguard is one of them as an example, so I had to re-disable the wfp driver.
I feel we are close. This ERR_CONNECTION_RESET issue is possible in case if you use some AV incompatible with AG.

Which one do you use?
 

Blaz

Moderator & Translator
Staff member
Moderator
He is using Eset Nod32. Probably SSL scanning is on.
 

Menalix

New Member
I feel we are close. This ERR_CONNECTION_RESET issue is possible in case if you use some AV incompatible with AG.

Which one do you use?
NOD32 got it fixed by disabling SSL/TLS filtering, as I saw another guy had to do the same with Kaspersky

I guess I'll leave this here for google/forum searches (I know from my own software community, thats a good idea, to prevent the same questions):
Visual Studio 2015, Error: "The address is not valid in this context." happening on debug of any application architecture (x86, x64, AnyCompile) for me in C# and VB.NET
My Fix: Enabling the WPF Driver in Adguard's settings pane.
Since the WPF Driver has some incompatible issues with AV's doing SSL/TLS filtering, I disabled it in Eset NOD32, now everything is perfect.

Many thanks for your help avatar and vasily, thanks for providing such an awesome piece of software, making my pc clutter free from useless ads, yet being able to do exceptions for websites I like to support.
 

Zageron

New Member
I've also just run into this. Disabling Adguard and the service fixes the problem, but as soon as they are turned back on the issue comes back.

@avatar, I can do logs and experiments. Feel free to send me an email.
 

avatar

Administrator
Staff member
Administrator
I've also just run into this. Disabling Adguard and the service fixes the problem, but as soon as they are turned back on the issue comes back.
Could you please try the latest beta version? To install it, switch update channel in Adguard's settings.

If it does not help, here is one more thing you can try (in beta only): tray menu -> advanced -> settings -> uncheck "Use localhost for injections".

Please ignore the wording, it's very hard to describe what this checkbox really does :)

Please let me know if any of this helps.
 

Zageron

New Member
B
Could you please try the latest beta version? To install it, switch update channel in Adguard's settings.

If it does not help, here is one more thing you can try (in beta only): tray menu -> advanced -> settings -> uncheck "Use localhost for injections".

Please ignore the wording, it's very hard to describe what this checkbox really does :)

Please let me know if any of this helps.
Beta fixed the issue. Thank you. :)
 
Top