Adguard local VPN no longer shared with ChromeOS

Skawt

New Member
I've been using Adguard for several years on my Android phone, and in Android on my Asus Chromebook Tablet. Recently I noticed that the local VPN created by Adguard is not being shared with ChromeOS. Normally, Android (ARC) VPNs on ChromeOS are shared, with all of the ChromeOS traffic being sent through the Android VPN by default unless disabled in flags.

With the latest m76 release of ChromeOS, I discovered that the Adguard VPN is no longer being shared. I have uninstalled and reinstalled Adguard, tried beta and nightly builds, toggled the appropriate Chrome flag, and even wiped the device clean. I should point out that if I install an OpenVPN client and activate that connection, the VPN is shared from Android to ChromeOS with no problems whatsoever.
 

TheHasagi

Quality Assurance / Support Commando
Staff member
Administrator
Moderator
It cannot be shared with another device. Tethering is restricted. Any try to share the VPN or using hotspot function will not be filtered by AdGuard.
 

Skawt

New Member
I see you're not familiar with ChromeOS. It's the same device. Android is emulated under ChromeOS. And normally the local VPN that Adguard creates would be shared--not tethered--with ChromeOS, with ChromeOS directing all traffic over the VPN. This worked fine until recently.
 
Top